trouble with dhcp new to pfsense and limited networking and freebsd knowledge please be gentle,



  • so I bought a mini computer with an aes-ni processor for a open vpn wifi router. I have a laptop and two other desktops acting as mostly media storage (wired) and 4 nics on the router. I went through the instructions and setup of assigning the interfaces and notice only wan and lan got ip addresses immediately but read (not in the manual but through googling) opt1 and opt2 and wifi interfaces all needed to be enabled as well which I did. wifi would connect but not get an ip address. I read I needed to add allow all firewall rules to the interfaces and im pretty sure I did along with making sure ipv4 was dhcp and ipv6 was disabled for opt1 and opt2 but like I said im kinda limited in my understanding of firewall rules and networking. I spent the past 24 hours googling and going through forums and theres lots of people who are experiencing similar problems but they seem to have minor variations im not experiencing or setups different from mine. im pretty sure if I can get dhcp working wifi will work too.


  • LAYER 8 Rebel Alliance

    You need to enable DHCP per Interface, check Services > DHCP Server

    -Rico



  • so under each interface tab and ipv4 configuration tab I have dhcp selected. I tried with ipv6/dhcp6 enabled and disabled for each interface and no dice. forgive my previous statement that dhcp was disabled for ipv4 I meant ipv6 was disabled and ipv4 was set to dhcp. dhcp under services is enabled but only lan is available for changeable options.



  • For home users, your WAN is usually assigned dynamically. LAN is a static configuration so I don't know where your LAN grabbed an IP address from. All other OPTx interfaces usually have static configs just like LAN. They need firewall rules to work as only LAN has a default allow to any rule.

    For more detqiled help, describe the exact problem you'r ehaving, an dinclude screenshots of your WAN/LAN config, DHCP server config and firewall rules.



  • This post is deleted!


  • my problem seems to be no computers except the laptop (plugged into the lan interface) are not receiving ip addresses via dhcp thus theres no networking. since theres options for dhcp for internal ips on otpx I would assume it wouldn't be an issue? the lan received an internal ip of 192.168.1.1 which I would expect but the interface is connected to the laptop and id assume its the router that needs that ip address. assigning internal ip addresses to opt1 and 2 didn't seem to help either, (via cli or in the client) plus im not sure how that would work with wifi. when you say you need screenshots of the wan/lan config did you mean on the interface tab or the home screen ill assume the interface tab. for the most part things are left entirely default minus what I understand and what ive read im supposed to change. ! heres the rest of what you asked. thank you for the help.!0_1548194283112_Screenshot (1).png



  • 0_1548194307917_Screenshot (2).png 0_1548194321861_Screenshot (3).png 0_1548194338264_Screenshot (4).png 0_1548194350986_Screenshot (5).png 0_1548194403717_Screenshot (6).png 0_1548194472277_Screenshot (7).png 0_1548194486634_Screenshot (8).png

    as said most everything has been left default


  • LAYER 8 Netgate

    @calbha said in trouble with dhcp new to pfsense and limited networking and freebsd knowledge please be gentle,:

    so under each interface tab and ipv4 configuration tab I have dhcp selected.

    No. You are telling the system that every interface is a WAN and should OBTAIN its address using DHCP there.

    1. Set the LAN interfaces to Static IPv4
    2. Number them with (probably) unique RFC1918 /24s
    3. In Services > DHCP Server enable a DHCP Server for each LAN tab there.


  • @derelict said in trouble with dhcp new to pfsense and limited networking and freebsd knowledge please be gentle,:

    @calbha said in trouble with dhcp new to pfsense and limited networking and freebsd knowledge please be gentle,:

    so under each interface tab and ipv4 configuration tab I have dhcp selected.

    No. You are telling the system that every interface is a WAN and should OBTAIN its address using DHCP there.

    1. Set the LAN interfaces to Static IPv4
    2. Number them with (probably) unique RFC1918 /24s
    3. In Services > DHCP Server enable a DHCP Server for each LAN tab there.

    its been over 10 years since my cisco classes that I struggled miserably in im assuming rfc1918/24s would be internal ip addresses with 255.255.255.0 subnets correct? thank you for the correction it makes sense.


  • LAYER 8 Netgate

    Yes.

    If you want to configure an IP network correctly you need to know things like IP subnets. Else you probably want to hire someone who does.



  • @derelict upon trying to assign a static ip of 192.168.1.100/24 to opt1 im getting an error that its overlapping with lan which has a static ip of 192.168.1.1/24 does each interface need a different range of ip addresses? I figured one computer could be 192.168.1.1 the next .2 the third .3 but apparently that's not possible. sorry I know this is pretty basic networking stuff but yeah this is why I struggled in the classes.


  • LAYER 8 Netgate

    Interface 192.168.1.1/24 - DHCP pool 192.168.1.129 - 192.168.1.254
    Interface 192.168.2.1/24 - DHCP pool 192.168.2.129 - 192.168.2.254
    Interface 192.168.3.1/24 - DHCP pool 192.168.3.129 - 192.168.3.254



  • @calbha said in trouble with dhcp new to pfsense and limited networking and freebsd knowledge please be gentle,:

    upon trying to assign a static ip of 192.168.1.100/24 to opt1 im getting an error that its overlapping with lan which has a static ip of 192.168.1.1/24 does each interface need a different range of ip addresses?

    Yes, that's what differentiates one network from another. They cannot share IP space. If your LAN is configured to be 192.168.1.1/24, then any other interfaces cannot use 192.168.1.1 - 192.168.1.255. Derelict already showed how to divide up the DHCP ranges for each of your subnets.



  • @derelict thank you. Things I didn't understand in class before are making sense to me now suddenly. I appreciate everyone's patience.


Log in to reply