Block PPPoE WAN IPv6 DNS



  • Hi,

    all the clients connected to the pFsense via dhcp keep getting the IPv6 of my ISP modem as primary dns.

    The WAN on pFsense is connected as PPPoE and this is the setup:
    Modem > pFsense 2.4.4-RELEASE-p2 > Switches /AP's > Clients

    Sometimes the DNS is loaded correctly and nslookup returns the ip of pfsense, but 99% of the imes it points straight to my ISP modem.
    It's really annoying because I'm unable to resolve domain and host overrides.

    This is what I have already tried:

    • System > Interfaces (WAN / LAN) : IPv6 config type to none
    • System > General: Remove flag on Allow DNS server list to be overridden by DHCP/PPP on WAN
    • System > Advanced > Networking : Flag on Do not generate local IPv6 DNS entries for LAN interfaces
    • System > Routing > Gateways: Default IPv6 gateway to none
    • Manually added dns in DHCP server

    Any idea?

    Thanks!



  • Forgot to mention,

    I disabled DHCP and IPv6 on my isp modem and pfsense resolver is enabled.

    If I disable pf resolver than the dhcp clients get only the dns configured in system > general setup.



  • Solved by enabling " Enable Forwarding Mode"