upnp & windows network discovery



  • Hi everyone im new too pfsense I recently replaced my isp provided router for pfsense (running virtually hyper-V) things are up and running but hoping for some help on two problems i'm having

    1. upnp

    I have enabled this for the moment on pfsense while i'm still learning and setting up as its the fastest option,

    my smart tv uses upnp too talk too my openhab controller and xboxes for multi play but its extremely unreliable the pfsense dashboard says running but scanning with a upnp client i cant find the router or anything else the smarthome cant talk too the tv and the xbox says strict nat with upnp unsuccessful

    1. windows network discovery

    since adding pfsense windows network discovery doesen't work it shows no connected devices it used too be populated

    im not sure what information would help you here but ask and i will try too update it like i say i have a lot to learn about pfsense i have only been using for around 5 days have some networking understanding

    network setup
    modem > pfwan <> pflan > switch > wifi aps

    most of my network is wired i do have a small switch daisy chained no vlans yet
    pfsense doing all netjobs dns , dhcp etc


  • LAYER 8 Global Moderator

    If your only on 1 flat network.. LAN.. Pfsense has ZERO to do with devices on lan talking to each other, or anything to do with any discovery method at all, be it broadcast/multicast, etc. etc..

    If device X is wireless and can not talk to Y that is wired - I would guess your AP are set in an isolation mode where wireless can not talk to wired, or even setup where wireless can not talk to wireless, etc.

    If your having issues wifi talking to wifi or just discovery wired to wireless or wireless to wired then your AP might be blocking multicast traffic that is normally used for say SSDP, UPnP, etc. etc.

    But pfsense has zero to do with devices talking on the same Layer 2 network..


  • Netgate Administrator

    In addition the upnp daemon in pfSense, miniupnpd, supports IGD only. So it allows devices behind it to open firewall rules and setup port forwards like the xbox is doing.
    It does not support DLNA so won't help at all with media streaming applications.

    But as said since you only have one subnet that shouldn't be needed anyway.

    Steve



  • Thanks both of you for the replys

    yes im on a flat network / LAN

    i thought pfsense has something too do with it as it is acting as the main router

    i have managed too get some of the windows network discovery working but i'm still experiencing some issues

    upnp for my smart tv and xboxes still not working no change


  • Netgate Administrator

    Do you see anything in Status > UPNP?

    What exactly is the TV trying and failing to do? You won't see it doing anything DLNA related as I said. But if you have flat network that shouldn't matter.

    Steve



  • The smarthome controller (Openhab) uses upnp too discover the TV (Samsung) on the local network they then send information between themselfs openhab knows if the tv is on/off , volume levels ect it can also change these items

    i have had it working for a fraction of time but not since. the tv showed online on openhab so the upnp communications were sucessful but it quickly went offline and never comes back on

    Upnp Status is empty


  • Netgate Administrator

    Ok that would just be directly between those devices, pfSense would not be doing anything there. Nothing IGD related.

    The xbox could be though it doesn't always.

    I have previously used Skype for testing upnp is working but that was some versions of Skype ago. Otherwise most bit-torrent clients will open ports with upnp and you should see that in the status.

    Steve



  • Ok then i will keep looking on the devices and at the lan and post back

    i will also try a bit torrent client too see what happens and post back

    There must be something wrong with my LAN as its strange that windows network discovery is acting strange on some things and now not on others and the upnp communications if you say they both run on the local net only and have nothing too do with pfsense

    the only major thing i changed other than adding pfsense was changing alot of the ip addresses too local machines do you think this could have upset them both inside my switches? maby i should reset my switches


  • Netgate Administrator

    It sounds like a subnet mask mismatch somewhere, I'd check for that first.

    Steve


  • LAYER 8 Global Moderator

    Did you change these IPs locally on the devices - then yeah its quite possible you have mask mismatch..



  • They were changed on the pfsense router using dhcp static mapping

    I have been looking for mismatched subnets but can't find anything



  • Just an update here for anyone who's interested/following

    I seem too have fixed all my issues now the only thing i need too do too finish setup is move the the xboxs from a strict nat to a open nat

    What was the problem with the local upnp?

    Quote from Wikipedia

    "IGMP snooping and reliability

    If IGMP snooping is enabled on a switch, or more commonly a wireless router/switch, it will interfere with UPnP/DLNA device discovery (SSDP) if incorrectly or incompletely configured (e.g. without an active querier or IGMP proxy), making UPnP appear unreliable.

    Typical scenarios observed include a server or client (e.g. smart TV) appearing after power on, and then disappearing after a few minutes (often 30 by default configuration) due to IGMP group membership expiring."

    What was wrong with Network Discovery?

    im sorry i cant confirm what actually fixed this its been a combination of enabling different thigs and trial and error reading the net and watching videos it mainly seemed too be services stopped and features disabled (possibly from an windows update)

    What was wrong with xbox upnp?
    This was solved as soon as i fixed the upnp locally

    Thanks everyone for the replys and tips it might not have seemed like it but they helped alot


Log in to reply