cannot install packages



  • Hi to all,
    i am having some problems installing any package, i am running latest stable version of pfsense on an netgate 1541 firewall.Tried factory restoring it but the problem persist. On another machine running the community edition packages are installing just fine. One day before i upgraded pfblocker-ng just fine on the problematic machine. I can see the available packages and after confirming the install a message apears "Please wait while the update system initializes" and just hangs there. Is there something i can do about it??

    EDIT: I can manualy install packages from cli just fine but not from webgui


  • LAYER 8 Moderator

    What is the "latest stable" on your display? Did you update to 2.5 snapshots accidentally?



  • latest satble version in main screen is 2.4.4-RELEASE p2 its the version the firewall came with.It was working just fine no configuration changes made no manual fidling from cli nothing just updated pfblocker-ng and came next day and wanted to install ntopng but could not, just the message and then hangs there.


  • LAYER 8 Moderator

    Have you looked over pfBlocker Logs to check if there's something blocking you? Package Install problems currently only happen on Snapshots of 2.5 - installation on 2.4.4-2 should be unaffected and I did a test-install of the Filer package without a problem.



  • Yes nothing wierd there i even factory restored it and set it up from scratch but no go there either still having problem with installing packages from web gui but i can install them from cli just fine



  • @xdrm said in cannot install packages:

    i even factory restored it and set it up from scratch but no go

    This is strange.
    What it means that if "some one" installs pfSense for the first time, right after setting up WAN (by default DHCP, I guess, so plugging it in on the upstream router and WAN is UP) she/he can not install any packages ??

    This would be an issue all over the forum - like dozens of posts a day - and an urgency upgrade being produced right away.

    (edit : sorry, I know, this doesn't help you very much ...)



  • I know this is strange indeed on my comunity edition box i can just reinstall pfsense completly from cd-usb etc but this is an official netgate apliance and i dont want to lose the optimasations netgate does for their devices and i dont have the official iso with the optimasations i know i can download it but i have bouhgt the device from an official resseler and asked them to get the iso for me so i can try a complete reinstall if all else fails.



  • Official netgate device == you should have an account @ netgate.com where you can download what ever you need.

    Consider posting here : Home pfSense® Software Hardware and they get back to you in no time with useful information.


  • Banned

    @xdrm said in cannot install packages:

    i have bouhgt the device from an official resseler and asked them to get the iso for me so i can try a complete reinstall if all else fails.

    https://forum.netgate.com/topic/141047/useful-resources-for-new-appliance-owners



  • Thank you guys for all the information (i had missed the sighn up button on the bottom) i just created an account explained my problem and asked them for the official iso.


  • Rebel Alliance Developer Netgate

    Run through the suggestions here: https://docs.netgate.com/pfsense/en/latest/install/upgrade-troubleshooting.html#force-pkg-metadata-update

    Though that page is for upgrade troubleshooting, parts of it apply to package as well since they come from the same servers.



  • I have tried all those steps before posting here i had no problem updating or installing from cli but not from webgui. I have no clue what could have caused my problem since i have not done anything dramatic to the firewall. On my other box i have done worse things to it and it did not brake once on me(ghost in the machine maybe). Anyway my problem was resolved by completly reinstalling pfsense with the official netgate iso that i got by sending a support ticket and explaining my problem. The responce was super quick within 5 minutes actually wich was awsome and did not expected that at all.



  • I'm just poking a stick in here, and maybe the mods would have an answer for this, but could it be that your DNS servers your Netgate box are using may have trouble resolving the address(es) the update server(s) is/are using?

    Jeff



  • no i dont thing so i could update and install just fine from cli!!!it was just after the pfbkocker-devel update before that it was working just fine i dont know that is what actually caused the problem because i updated pfblocker and left then came the next day ours apart and tried to install another package but couldnt. Tried the same package from cli and it installed just fine. i could pkg update no errors and pkg upgrade no errors only on the webgui it was not working.


Log in to reply