Package manager unable to communicate to pfsense.com



  • Hello. (hope I have posted this in the correct section. Admin please feel free to move if not)

    First off I am new to PFsense so please go easy on me.

    I have pfsense 2.1 running on a watchguard x750e in my home network rack.

    It all seems to be working fine and has been up for a few days routing traffic fine. I have internet connection on all of my devices.

    When I check for available packages I am getting an error message saying it is unable to communicate with pfsense.com. I can ping pfsense.com from the web interface with the below results.

    --- pfsense.com ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 125.132/125.438/125.935/0.355 ms

    I have looked around online and can see others have also had this problem. However these fixes don't seem to be working for me.

    So far I have ran the below command in the shell to change pfsense's prefferance from IPv6 to IPv4

    env ip6addrctl_enable="yes" ip6addrctl_policy="prefer_ipv4" /etc/rc.d/ip6addrctl start

    I have also disabled DHCP6 on my WAN.

    I have ensured my DNS settings in system/general setup are correct. I have 2 DNS serves listed 8.8.8.8 & 8.8.4.4 both using my WAN PPPOE interface as the gateway.

    Turned it off and on several time, had a beer and scratched my head. But still getting the same error.

    If anyone could assist with this I would be very grateful.

    Thanks

    Lee



  • Further to this I have also tried changing the package server URL in http://my_pfsense/pkg_mgr_settings.php to http://packages.pfsense.org but with no joy


  • Rebel Alliance Developer Netgate

    Back out any manual changes you have made and run through the suggestions here:

    https://docs.netgate.com/pfsense/en/latest/install/upgrade-troubleshooting.html#cli-troubleshooting



  • @jimp thanks for your reply.

    I have started to run through this guide however when entering command pkg-static update -f it is coming back with command not found.

    I also tried the command for the public key download however it is coming back with no such file or directory.



  • Hi,

    @LeeWright said in Package manager unable to communicate to pfsense.com:

    When I check for available packages

    And even when you see the packages, they are for 2.3.5 (maybe) if not only for 2.4.4.
    So : to make a long story short : packages ? Ok, but only if your pfSense is recent, today that will be 2.4.4.

    Ok to keep an ancient version (2.1 !! - I guess @jimp didn't saw the version), although for security reason I advice you to disconnect it from the Internet all together. That version will be fine to connect the copy machine to the coffee dispenser - nothing more.
    The "package problem" would be solved then also.

    Btw : the "package server" is not accessible on pfsense.com (redirected to netgate.com) and when you find the real package update server, you find out that that one doesn't reply to reply anyway (as stated many (more ?!) times on this forum already).


  • Rebel Alliance Developer Netgate

    I didn't notice it was 2.1.

    We shut off packages for versions older than 2.3 a long time ago.

    You need to upgrade.


  • LAYER 8 Global Moderator

    where did you even find a 2.1 copy? Clearly these old versions are no long hosted by pfsense/netgate - so you have no idea what might have been done to that image.



  • thanks for all the replies. I will have a look at updating to a newer version ASAP. I was having problems flashing version 8 of the watch guard BIOS but will give it another try.


Log in to reply