“Invalid WAN IP Address” error during Setup Wizard configuration using ISP-provided details



    • Hardware: SG-3100
    • OS: pfSense 2.4.4-RELEASE-p3

    I am following the directions provided on the “Getting Started” page for the SG-3100 manual. They worked well when using DHCP on a residential account, but I am having issues setting it up with a static IP now that I have migrated to such services with my ISP.

    • Primary / secondary DNS domains: what my ISP has provided me
    • WAN interface: Static
    • IP Address: xxx.0.yyy.72
    • Upstream Gateway: xxx.0.yyy.73
    • Subnet Mask: 255.255.255.248

    (Full IP addresses redacted... not sure about security practices on whether it’s advisable to give out the full address or not online.)

    Here is what is confusing me. My ISP tells me that the network mask is 255.255.255.248, which should translate to a CIDR range of “/29,” right? Upon selection of 29 as the Subnet Mask option and entry of the IP Address and Upstream Gateway as provided by my ISP, I get the following error:

    The following input errors were detected:

    • Invalid WAN IP Address. Please press back in the browser window and correct.

    I tried 32 as the Subnet Mask once by mistake and it let me continue... but there was no Internet connection after that. The Gateways status page showed the WANGW interface as offline with 100% loss.

    I have verified with my ISP that all of the information that I have from them is correct. I have power cycled the router and modem and reconnected them after a few minutes as generally recommended. I have verified with the ISP that the gateway is pinging properly on their end.

    Why is pfSense telling me that the data I have entered along with the proper (I assume) CIDR range constitutes an improper address? What can I do to resolve this issue? What other information or diagnostic steps would be helpful in fixing this issue?



  • @paanvaannd said in “Invalid WAN IP Address” error during Setup Wizard configuration using ISP-provided details:

    xxx.0.yyy.73

    i have this on one of my pfsense, maybe it work for you
    Interface - WAN
    wanstat.jpg


  • LAYER 8 Global Moderator

    .72/29 is the wire not the first host... Not good practice to use that IP..

    The first host on .72/29 would be .73 which would normally be ISP device where your IP would be .74


  • LAYER 8 Rebel Alliance

    Exactly like johnpoz said.
    I have .48/28 where .49 is the ISP device and .50 to .62 is for my hosts.

    -Rico



  • Thank you all for the responses!

    What you mentioned makes perfect sense.

    I will try this out later today and update this comment with the results, but I expect using the next IP number up in the range as I should have done will indeed be the solution.

    e: Indeed, that was the solution!


  • LAYER 8 Rebel Alliance

    Glad you have it working now. ☺

    -Rico