• Hi all,

    Recently had to start from scratch configuration wise due to some VPN issues I couldn't resolve. However, I now find myself having two issues which I didn't have before even though I'm certain I followed the same guides as before and even tried to compare config XML's for those sections of pfSense.

    I have two VLAN interfaces set up, one is for IoT devices and the other is for my Games Consoles.

    I now can't get my phone (which is on the main LAN) to talk to my Nanoleaf lights (which are on VLAN20) and also can't get an Open NAT without port forwarding (which I was able to previously).

    It seems like uPnP isn't working. Even though the service is running, it never appears to create any rules.

    Barring me starting all over again, does anyone have any ideas as to what I can try?

    Thank you.

  • Netgate Administrator

    Ok. those two things seem unrelated on the face of it.

    How does the phone connect to the Nanoleaf? Can you enter their IP directly? If so and it still doesn't connect it's either blocked by something at the firewall or misrouted so it never arrives. Or possibly the Nanoleaf doesn't have a valid route back.

    Do you have UPnP and NAT-PMP enabled in the upnp setup?

    Do you have any ACLs enabled or custom restrictions?

    You never see any entries in Status > UPnP? Do you blocked firewall logs on the GamesConsole interface?

    Anything logged for the upnp service?


  • @stephenw10 Managed to solve it myself. I don't know how I missed this before when I created the VLAN's I created them on igb2 rather than igb1 which is where my LAN network resides. I changed that and now everything is working fine as it was before I started a fresh configuration. Thank you for the suggestions anyway!