Squid Startup Error with PPTP



  • php: : There were error(s) loading the rules: /tmp/rules.debug:52: macro 'pptp' not defined /tmp/rules.debug:52: syntax error /tmp/rules.debug:64: macro 'pptp' not defined /tmp/rules.debug:64: syntax error pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [52]: rdr on $pptp proto tcp from any to !($pptp) port 80 -> 127.0.0.1 port 80



  • same here, please fix or let us downgrade to the last version



  • strange… do you have pptp as a wan interface or a vpn-dial-in-interface ?



  • nope.

    this bug is happening for a lot of people



  • I to am having the same exact issue.

    Edit: I had to comment out the pptpd rules in squid.inc to get it working.

    /* Handle PPTP case */
    /*		if($config['pptpd']['mode'] != "off") {
    			$rules .= "rdr on \$pptp proto tcp from any to !(\$pptp) port 80 -> 127.0.0.1 port 80\n";
    		}	
    */	
    		$rules .= "\n";
    		break;
    	case 'filter':
    		foreach ($ifaces as $iface){
    			$rules .= "# Setup squid pass rules for proxy\n";
    			$rules .= "pass in quick on $iface proto tcp from any to !($iface) port 80 flags S/SA keep state\n";
    			$rules .= "pass in quick on $iface proto tcp from any to !($iface) port $port flags S/SA keep state\n";
    			$rules .= "\n";
    		};
    		if($config['pppoe']['mode'] == "off") {
    			$rules .= "pass in quick on \$pppoe proto tcp from any to !(\$pppoe) port $port flags S/SA keep state\n";			
    		}			
    /*		if($config['pptpd']['mode'] != "off") {
    			$rules .= "pass in quick on \$pptp proto tcp from any to !(\$pptp) port $port flags S/SA keep state\n";
    		}	
    */		
    		break;
    	default:
    		break;
    	}
    
    	return $rules;
    }
    ?>
    
    


  • well, yes !
    i'm just wondering about and found the error…
    perhaps you could test if it works if you put this as pptpd:

    		if($config['pptpd']['mode'] == "server") {
    			$rules .= "rdr on \$pptp proto tcp from any to !(\$pptp) port 80 -> 127.0.0.1 port 80\n";
    		}	
    

    would you please tell me after this ?



  • this doesn't work for me, filter errors again
    There were error(s) loading the rules: /tmp/rules.debug:345: macro 'pptp' not defined/tmp/rules.debug:345: syntax error pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [345]: pass in quick on $pptp proto tcp from any to !($pptp) port 3128 flags S/SA keep state…

    This page will automatically refresh every 3 seconds until the filter is done reloading.



  • could you please paste your pptpd portion without any private data of your config.xml ? or pm me ?

    Diagnostics > Edit File > /conf/config.xml > Load > search for pptpd and then everything between <pptpd>and</pptpd> ?

    thanks…



  • <pptpd><mode><redir><localip></localip></redir></mode></pptpd>



  • ok, same problem here… sometimes there seems to be some pptp-mode string missing...

    which pfsense version are you using ?



  • 1.2.2
    built on Thu Jan 8 22:39:31 EST 2009



  • i don't even USE pptp and i'm getting this frustrating error



  • I had pptp in use … not active at the moment of upgrade to squid. I am as well getting the same error.



  • very strange… same version here and no problem...

    but please have a further try now... reinstall squid-gui components please



  • Hello

    I have the same problem after installing the latest squid.
    I'm using Pfsense 1.2 final dual WAN with squid+squidguard+lightsquid in transparent mode.
    If i disable transparent mode i don't get the error message.
    I removed all the packages and installed them again but the error appears again..

    Any ideas?



  • i temporarily disabled the pptp usage in squid, so update your xml-config and it should work… please let me know...



  • still get this error that i never got before

    Generating RRD graphs...
    ERROR: unknown DS name 'qPenaltyUp'
    done.
    
    

    and this one

    Warning: Invalid argument supplied for foreach() in /etc/inc/pkg-utils.inc(303) : eval()'d code on line 1
     squid
    
    

Log in to reply