Cannot uninstall package (SquidGuard)



  • I'm trying to uninstall squidgard, but it doesn't work.
    First from the GUI, it just doens't seem to do anything.

    Then from the shell, it just stalls with the following.

    [2.4.5-RC][root@pfSense.localdomain]/root: pkg delete pfSense-pkg-squidGuard
    Checking integrity... done (0 conflicting)
    Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):
    
    Installed packages to be REMOVED:
    	pfSense-pkg-squidGuard-1.16.18_3
    
    Number of packages to be removed: 1
    
    Proceed with deinstalling packages? [y/N]: y
    [1/1] Deinstalling pfSense-pkg-squidGuard-1.16.18_3...
    Removing squidGuard components...
    Menu items... done.
    Services... done.
    
    

    Been waiting for over an hour.



  • @yaminb I have never done it via the command line...always through the package manager and click on the trash can on the right, see image!

    Screen Shot 2020-01-29 at 9.17.16 AM.png



  • I've tried it through the web package manager. As mentioned, it doesn't do anything. I confirm the uninstall, then it just doesn't do anything.

    So I tried the command line with the results above.



  • @yaminb After your command line input and output, did you reboot your pfSense box to see whether SquidGuard was still showing installed?


  • Rebel Alliance Developer Netgate

    I see you are running a 2.4.5-RC snapshot. What hardware is this on?

    When you run it from the command line, during the time it's stuck, what does pressing ^T (ctrl-t) print on the console?



  • @NollipfSense yes, I have tried rebooting several time. Squidguard still shows as installed.

    @jimp
    I have a SG-3100. Just got it yesterday... and yes, I am trying out the 2.4.5-RC branch.
    If you think it's best to go back to the stable branch... what's the best way. Normally downgrades are iffy. There's no way to reinstall without direct console access?

    [1/1] Deinstalling pfSense-pkg-squidGuard-1.16.18_3...
    Removing squidGuard components...
    Menu items... done.
    Services... done.
    load: 0.81  cmd: openssl 89263 [crydev] 10.18r 0.00u 0.01s 0% 4220k
    load: 0.76  cmd: openssl 89263 [crydev] 22.12r 0.00u 0.01s 0% 4220k
    load: 0.69  cmd: openssl 89263 [crydev] 25.61r 0.00u 0.01s 0% 4220k
    load: 0.72  cmd: openssl 89263 [crydev] 33.06r 0.00u 0.01s 0% 4220k
    load: 0.66  cmd: openssl 89263 [crydev] 36.85r 0.00u 0.01s 0% 4220k
    
    

  • Rebel Alliance Developer Netgate

    That looks like a problem one of us has replicated internally on their SG-3100 here as well. We're still investigating it, and don't have a resolution yet.

    You may want to back down to 2.4.4-p3 for the time being on there. To get back to 2.4.4-p3 you would need to reinstall, you can get the recovery image from the support team, open an issue at https://go.netgate.com and they'll get you setup.



  • @yaminb I would suggest to try pfSense 2.5-dev...that's what I am running with those packages in the screen shot I provided above.



  • Just for record keeping. I flashed back to stock 2.4.4-p3 and no issues.


Log in to reply