[Solved] No web access in LAN



  • Hi,

    I've got a problem with my setup. I have set up pfsense, configured my WAN and LAN interface, set up a machine in LAN.
    Works fine until now.

    I am able to ping addresses from the local machine, but HTTP or SSH for example just getting a timeout. I have nothing configured so far, only set the web interface port to 8443 and added a rule to allow port 22 and 8443 from WAN.

    For the LAN there are the default rules to allow LAN from my LAN net on any to any. The NAT Outbound rule is on automatic.

    Maybe someone has an idea, what to do to fix this


  • LAYER 8 Global Moderator

    Where are you trying to access this from? If your outside your network you would need to setup a port forward. If your inside on you lan pfsense would have nothing to do with the conversation between lan device and another lan device.

    If your trying to hit your public IP to get reflected back in, you would need to setup nat reflection.. But that is rarely a good idea, nor even a good work around.. If your on the same network as what your trying to access use split dns where the fqdn your trying to access resolves to the local IP vs the public (wan) IP... This is simple enough to do with a host override.



  • I am trying to access web resources from the LAN, so e.g. I, logged in on the machine on the LAN (10.0.0.104), am trying to access google.com (placeholder for every other resource) via curl or wget. SSH works neither. I don't have tried other protocols.

    As far as I can say, the request went from the machine in the LAN to pfsense, getting natted to the WAN IP and sent to the Server. In the pfsense it says SYN_SENT;CLOSED in the logs.


  • LAYER 8 Global Moderator

    so this is just normal outbound access.



  • Yes, but it isn't working.

    Here is are the Outbound Settings I have, they are preconfigured by pfsense. Is there anything else I have to configure to make it working correctly?

    66fb19b4-f2cf-41ef-abfe-e219908645b8-image.png


  • LAYER 8 Global Moderator

    Other than horrible Idea to use a /16 for your internal networks - really have you have some 65K IPs on this network?

    If your internal is being natted to your wan IP... There is nothing pfsense can do about not getting an answer..

    Sniff on your wan when you try and ping say 8.8.8.8 do you see traffic go out to your wan gateway natted to your wan IP? if you get no response that has nothing to do with pfsense.

    What is in front of pfsense? Does pfsense have rfc1918 on its wan or public?



  • Yeah the /16 is not optimal, I'm gonna change that in the future.

    The strange thing is that I am able to ping all addresses from inside the LAN, but nothing more.

    In front of the pfsense is a public address. I am able to curl websites from the pfsense.


  • LAYER 8 Global Moderator

    What are you lan rules?

    This really should be click turn it on, follow the bouncing ball = done..

    It just works out of the box.



  • Yeah, I thought also, but ..

    395f0577-a40d-49d0-8cdf-6e317626103e-image.png


  • LAYER 8 Global Moderator

    Which interface is that? Says source dmz net, but description say its the default lan rules?

    Did you copy rules from lan to your dmz?

    But then you have anti lock out... So you renamed lan to dmz?

    But doesn't seem like you have accessed the gui from this network because no hits or state on the antilock out rule.

    Are you running proxy or any other packages?



  • This is the original LAN interface, renamed to DMZ. So the rules originate from the DMZ interface. I'm accessing the GUI via WAN interface


  • LAYER 8 Global Moderator

    @Omikron said in No web access in LAN:

    I'm accessing the GUI via WAN interface

    I am curious to why - is this pfsense remote I take it..

    If you can ping, then pfsense is doing its nat thing correctly... Again sniff on your wan, when you have a client try and go to something via http... So you see the syn go out, with correct source IP (your wan) if so - what comes back...



  • Yeah, the pfsense runs in a virtualised environment with a proxmox as a hypervisor.

    The syn goes out, but theres nothing is ever returned.


  • LAYER 8 Global Moderator

    proxmox - and only ping works.. Yeah there was something I recall about that.. Having to turn off something.. Let me look.

    Thought there was a sticky, something about offloading.. But that was years ago, not sure if still a thing... But you could try turn off all offloading.

    But if your seeing syn go out and nothing return, that screams something upstream of pfsense.



  • This was the solution, thank you very much.


  • LAYER 8 Global Moderator

    Glad you got it sorted - you really need to state up front what your using, be it hardware (make and type) or if your running on VM, if so what virtualization your using.


Log in to reply