10Gbits NIC problem



  • Hello,

    i try to configure an 10Gbit NIC (SFP+ over Fiberoptic Intel-Compatible) from Intel as LAN. It dosent works. Board is an Supermicro X11SDV-4C-TP8F.

    When i try that, on the CLI shows following error:

    ixl3: ixl_init-locked: reconfigure MAC addr
    

    Is there a known Problem or Solution?

    Regards


  • LAYER 8

    not enough information, that is not an error,
    what is not working ? can you be more specific? what network card is it ? x710, x722, other?
    eventually more logs file are needed



  • @haithabu84 Are you trying to spoof your ISP's modem mac address?



  • @kiokoman said in 10Gbits NIC problem:

    not enough information, that is not an error,
    what is not working ? can you be more specific? what network card is it ? x710, x722, other?
    eventually more logs file are needed

    When i assign the 10Gbits NIC as LAN... this doesnt work. No access to the web interface, etc... I cant ping from pfsense to anywhere and backwards from computer in LAN to pfsense too. Before, i had the igb1 from the i350-AM4 controller for LAN configured. There was all fine. To Undo this, i go over the CLI with IPMI and change back to igb1.

    Link is up, that can i see over the activity LEDs on Switch and Board. Switch is an Brocade ICX7250-24 with 8xSFP+ License.

    Wich Controller... is a good question. My infos are: They (10Gbits NIC) are directly attached to the SoC and use the i40e Driver like the other Controllers from the Intel 700 series. But there is no "dedicated" Controller for them.

    Look here:
    https://www.supermicro.com/en/products/motherboard/X11SDV-4C-TP8F

    system.txt

    I have attached my full system.log... i hope that helps. I cant see any error to the related issue.

    @NollipfSense I dont understand your Question. I try to configure this NIC as LAN port. This Port is not linked to WAN or something.



  • @haithabu84 Never mind...your "reconfigure MAC addr" brought this thread in mind: https://forum.netgate.com/topic/150517/bypass-at-t-fiber-bgw210-700


  • LAYER 8

    idk the log show your interface go up but there are other errors i never saw

    rc.bootup: The command '/sbin/dhclient -c /var/etc/dhclient_wan.conf igb0 > /tmp/igb0_output 2> /tmp/igb0_error_output' returned exit code '1', the output was '' 
    or
    rc.bootup: Unbound /var/unbound/root.key file is corrupt, removing and recreating.
    

    does ifconfig show an ip address for the interface ? i never had a chance to try that driver/network card but I'm not convinced it's a network card problem ... not yet..


  • Netgate Administrator

    Show us the output of: ifconfig -vvm ixl3

    Do you see the same issue if you try to use any of the other ixl interfaces?

    Steve



  • Ok, i found some wierd things... that is the moment in the system.log when i switch LAN from igb1 to ixl2:

    system.txt.txt

    After that i tried a factory reset. Since that, something goes horrible wrong on the machine. The web interface is very slow and sometimes i become timeouts. Tomorrow i try a clean install and than i submit more logs/outputs.



  • @stephenw10 Ok. I have done an totally clean install and configured igb1 as WAN, ixl2 directly as LAN after install. Doesnt work.

    Output ifconfig ixl2:Auswahl_012.png

    no carrier... but why? I see activity over the LEDs on the NIC. I dont understand that.


  • LAYER 8

    it's possible that the card is unable to auto-negotiate to 10gb or/because of unsupported sfps



  • OK. I found out the Problem. The Switch-Stack has deactivated the Fiber-Ports from the pfsense. I have no idea why. After enabling, it works. But its ridiculous, i have seen active link leds...

    But i have another question: How works LACP with ixl NICs? I read some old bug reports from 2018 that there are some troubles. Like:

    https://forum.netgate.com/topic/141319/vlan-interfaces-does-not-came-up

    https://redmine.pfsense.org/issues/9453

    After a own try, same problems.

    lagg0: IPv6 addresses on ixl2 have been removed before adding it as a member to prevent IPv6 address scope violation.
    lagg0: IPv6 addresses on ixl3 have been removed before adding it as a member to prevent IPv6 address scope violation.
    

    Is there now an solution?

    The only thing that i found as solution is, to use Failover Mode in Lagg. But not an optimal solution.

    Thanks


  • Netgate Administrator

    That is not an error that should prevent the lagg coming up, it's expected if you have IPv6 addresses there.

    Neither of those links are relevant to ixl specifically. I would expect that to work.

    There is an open issue with vlans on ixl: https://redmine.pfsense.org/issues/9123
    Since you're not adding vlans directly you may not see that anyway. I assume you're not seeing that error.

    Steve



  • @stephenw10 But how can i bring up my lagg? I have nowhere configured IPv6 addresses. I have unchecked the Box "Allow IPv6" under System/Advanced/Networking... but my NIC has still an net6 address...

    ifconfig -vvm ixl2
    ixl2: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
            options=6400bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
            capabilities=7507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO,NETMAP,RXCSUM_IPV6,TXCSUM_IPV6>
            ether 00:25:90:ba:08:22
            hwaddr 00:25:90:ba:08:22
            inet6 fe80::225:90ff:feba:822%ixl2 prefixlen 64 scopeid 0x7 
            inet 10.4.0.10 netmask 0xffff0000 broadcast 10.4.255.255 
            nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
            media: Ethernet autoselect (10Gbase-SR <full-duplex>)
            status: active
            supported media:
                    media autoselect
                    media 10GBase-SFI
                    media 1000Base-KX
                    media 10Gbase-LR
                    media 10Gbase-SR
                    media 10Gbase-Twinax
                    media 1000baseLX
                    media 1000baseSX
    
    

    I want later to use VLANs on that LAGG. But when this Bug still exists, i will use without.


  • Netgate Administrator

    How have you configured the lagg? You see it showing in ifconfig -v lagg0?

    If not can we see screenshots of the config from the webgui.

    Steve



  • @stephenw10 I found the Problem: On the Switch i have configured a static LAG, wich not well supported für Bonding. My Fault.

    After Configure a dynamic LAG and enable the Interfaces, it works. But not for long. I have the same Problem in the Link from Bug 9123. When i add some VLANs to the LAG interface, i become

    aq_add_macvlan err -53, aq_error 14
    

    often in Relation with a hanging queue. Then i tried FAILOVER Mode, but same error occurs.

    After compiling the last i40e-Driver from Intel with FreeBSD 11.2 has solved the Problem.


  • Banned

    This post is deleted!

  • LAYER 8

    did you try to spam and forgot to put link to some non sense website ?


  • LAYER 8 Global Moderator

    Yeah that is a spammer, doing a per-emptive strike on that... Nonsense post from India IP - 99.999999% likely hood of freaking spammer.

    What he posted is a direct copy from a website.. It's like they search for some key words, copy paste what they find and then try and add some nonsense link in it..


Log in to reply