APU 4d4 installation problems 2.4.5



  • I've been doing some testing of 2.4.5 on the APU 4d4. The units I'm testing with have msata drives and are running BIOS 4.11.03
    An upgrade from 2.4.4p3 went fine. Then I tried a fresh install from the memstick serial installer on a USB drive. I used Etcher to write the image (JimP suggested this at some point). The write completed without errors. I booted from this stick, and saw errors on the console:
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command
    I wanted to keep my 2.4.4p3 installer, so I re-used an old stick for the 2.4.5 installer. I figured this one was bad, so I threw it away and wrote another one.
    Saw the same CAM errors on the second usb installer. I downloaded a new copy of 2.4.5 just in case, then tried a third stick of a different brand, same thing.
    Sometimes it dumps to a mountroot prompt, sometimes it gets past the errors, starts the install, then panics. After several tries, I got it to get past the errors and finish the install. Everything seems fine once it's installed.
    The APU4d4 has external USB3 ports- my theory is that something changed in the new version with mounting the usb stick, as the 2.4.4p3 installer worked perfectly. The usb sticks I was using were older, I did not have a spare usb 3 stick to test.
    Has anyone else tried installing from scratch on an APU4? Maybe I just have a pile of dodgy usb keys...
    I did check the pc Engines forum, but it's currently a spam infested mess.


  • Netgate Administrator

    Hmm, I'm aware of any such issues. I don't have an APU4 to test on but they are popular I would have expected to see more reports if it was a general issue.

    Can you try writing the installer to SD card and booting that instead?

    Steve



  • if this help: I change from USB to CD/DVD and it works. The USB right now has a check sum error when I tried to install it. I am like you: I have an extra PC as the backup. I running the PFSENSE on another old PC (I716G 240SSD) and when there is a big release, I backup the config; download the new PFSENSE, install on the backup and then restore the config. Run the backup for a few days and then do the same thing for the main then the backup goes back to shell. I think the USB version has some problem in its image and not the PFSENSE/FreeBSD...


  • Netgate Administrator

    You think the memstick serial installer image has a checksum error?



  • The SHA256 checksum matches what the download site says. I wrote the image without any errors. I've got a few things to try, but my access to hardware is limited for the near future. I'll do some more tests when I've attended to some more pressing issues.



  • Ok, I dug up an old usb connector- the kind that has two usb ports that connects to a 10 pin motherboard header. Opened the case and plugged it in. Installed using the same usb stick via the usb2 motherboard connection- no problems. Repeated- no problems. Tried the same thing with a second APU4 and could install via the usb2 connector with no problems.
    Tried the same usb installer, this time on the front connector.
    Bios version on both:
    PC Engines apu4
    coreboot build 20202901
    BIOS version v4.11.0.3
    4080 MB ECC DRAM
    SeaBIOS (version rel-1.12.1.3-0-g300e8b7)
    Here is the bootup from both boxes:
    first
    ugen0.2: <SanDisk Cruzer Blade> at usbus0
    umass0 on uhub0
    umass0: <SanDisk Cruzer Blade, class 0/0, rev 2.10/1.00, addr 1> on usbus0
    uhub2: 4 ports with 4 removable, self powered
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command

    second
    run_interrupt_driven_hooks: still waiting after 60 seconds for xpt_config
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command
    (probe0:umass-sim0:0:0:0): INQUIRY. CDB: 12 00 00 00 24 00
    (probe0:umass-sim0:0:0:0): CAM status: CCB request completed with an error
    (probe0:umass-sim0:0:0:0): Retrying command

    So-
    I've got two APU4d4 boxes running BIOS 4.11.0.3 and they both throw CAM errors installing 2.4.5 from a USB3 port, but there are no errors installing from a USB2 port off the board connector.
    I could install 2.4.4p3 via the USB3 ports without error.



  • Adding some more data points into this conversation with myself:
    Managed to get the first two apu4d4's loaded with 2.4.5 (using a usb header off the board, not the front usb). Swapped them out with two units that were running 2.4.4p3. Same batch of hardware, same bios revision.
    I tested writing the image to an SD card and installing from SD to the msata. This works fine.
    These two units get the same CAM errors trying to install from a usb stick in the front usb ports.
    I tried updating the bios on one from 4.11.0.3 to 4.11.0.6, no change.



  • I have the same exact problem on an APU2E4 when booting the pfSense 2.4.5-p1 installer from a 1GB USB stick.
    After trying 2 times and hanging for 1 to 2 minutes, the boot process continued and I was able to install pfSense on the SD Card.



  • @IntPlus

    maybe this can be useful information (we have many of these MOBOs in operation):
    (this is not a pfSense issue anyway)

    unfortunately APU coreboot is still struggling with USB issues
    this is a very old issue and they still could not make it work (https://3mdeb.com/) /

    ffdd672b-5ecb-4ee1-8f98-0ac40d48415b-image.png
    5186dc44-ee33-4a7c-9b16-1469aa63ea1f-image.png

    there is a problem with these as well, but it will work with great security if you install pfSense:

    the best flash drive for this purpose: Kingston DT100G3 / 16 or 32 (DataTraveler)
    (the 64GB already has problems, the 32 less is the best, the 16 perfect, but it's no longer available)

    many times you need to restart the installation, if necessary you need to change the USB port, but this will work after a while

    these are the experiences of my own and other APU fanatics....
    these flash drive restrictions are true for BIOS updates and all other OS installations

    +++++specifically only this type of pendrive "Swiss Army Knife" for APU 2 - 4 boards
    bb8b0c45-1d03-4b39-bf59-be72a6314ccb-image.png

    +++++ https://forums.freebsd.org/threads/can-not-install-freebsd-12-on-pcengines-apu-2d-system.72490/



  • I tried installing 2.4.5p1 on an APU4d4 via USB stick- it still failed. I tested with BIOS versions 4.10.0.1, 4.11.0.6, and 4.12.0.1 I'm using an SD card as a workaround.



  • @dotdash
    Unfortunately, it is still relevant:
    https://github.com/pcengines/apu2-documentation/blob/master/docs/debug/usb-debugging.md

    ++++It does not depend on the BIOS versions as the issue is not resolved yet

    this is equally true, if you are using one or two USB device(s)



  • I'm using some old USB sticks. Most of my testing has been with a SanDisk Cruzer Blade 8GB(not USB3), although I have tried some other brand 8GB USB2 sticks. I found I could install fine off the on-board USB2 ports (via a header), but not off either of the front USB3 ports. Something changed in the underlying FreeBSD handling of the USB3 ports, because the 2.4.4p3 installer works fine with the exact same APU and USB stick.



  • @dotdash

    it will not work..... edit: I mean, with these
    branded / non-branded device
    old / not old

    does not matter!!! ☺

    Kingston operates in 90% of cases with SanDisk in 40-50%
    only Kingston is the solution and it is also very difficult to operate

    pls. - imagine my situation, with this solution I have already installed more than 40 - 50 APU4d4 and updated the BIOS, hahahaha ✋

    but it works just need to be forced, plug / unplug the flash drive and once it starts

    annoying

    +++edit:
    had a 2 - 3 years old description on the internet (from this issue APU vs. USB)
    the guys analyzed on a very correct way, about 10 to 15 pcs. pendrives, from this point of view

    I learned this and experience it there.... Kingston or SanDisk... no more chance...
    unfortunately, I can no longer find this page



  • I have the same issue. I've tried different brands and sizes of USB sticks and they have inconsistent results like you guys. The question is, if the installation pushes through (after it hangs for a few mintues), doesn't that have any ill effects to the installation?

    Is the USB3 issue generally a problem with USB sticks or any USB (like my UPS) plugged in to these USB3 ports?



  • @kevindd992002 said in APU 4d4 installation problems 2.4.5:

    Is the USB3 issue generally a problem with USB sticks or any USB (like my UPS) plugged in to these USB3 ports?

    probably does not affect the compatible UPS connection via USB
    this issue applies to mass storage devices...

    because:

    d03351a3-3b63-4605-843c-7c12e3d0ba11-image.png

    948d9912-7e66-41dd-a6a0-4028dfdf1f27-image.png

    +++edit:
    https://pcengines.github.io/#mr-36



  • Why does the issue happen with USB 2 sticks too then?



  • @kevindd992002

    there is probably more behind it 😉
    I have been using APU MOBOs for many years and this error is just scrolled... tatatatatata
    it was never repaired

    USB3 is downward compatible with USB2, so I think this bug affects USB2 version storage devices as well


Log in to reply