Installed packages not working nor installing



  • Hi netgate community.
    I am new here and this is my first post as well. I am using pfsense 2.4.4 p3. My firewall was crashed for some reason luckily i had a backup so i restored it. After restoring multiple packages did not worked and package manager also was not available nor any packages. Can anybody tell what could be the issue. Thanks in advance.![alt text](Screenshot_2020-06-08 ZGL-Gateway zglpk com local - Status Dashboard.png Screenshot_2020-06-08 ZGL-Gateway zglpk com local - System Package Manager Installed Packages.png Screenshot_2020-06-08 ZGL-Gateway zglpk com local - System Package Manager Available Packages.png Screenshot_2020-06-08 ZGL-Gateway zglpk com local - Status Dashboard(1).png image url)



  • Hi,

    You must the update announcement , Netgate's Youtube video or one (no : many) forum posts.

    Packages are always based on the last pfSense version.
    So, if you want to use and update packages, you can not update them and not updating pfSense.
    Or : if a pfSense update is available, do not upgrade packages any more.

    When you import the config.xml backup file, you force pfSense to re install packages ... which are to recent.
    You opened the worm hole.

    So :start by updating pfSense.... or :
    I advise you to clean install, import the config, have oit install all packages referenced in that config.xml (give it some time) and you'll be fine.

    Btw : if you really want to stay with an old version, you should copy-clone your drive.
    And do not look at package update (or re install) anymore ...



  • As per the pfsense "The system is on latest version". I have tried clean install on a vm machine than restored the backup file and issue was still there.



  • If a clean install can't download and install packages, I would consider reviewing the "clean" about this install.

    Like : install a clean - new install - do not import anything.
    Just a plain vanilla, pfSense with a working "Internet" connection.

    The Installed package list will be empty - this is normal.
    The Available package list should populate. If not, there is your issue.
    If the list shows, import your backed up config. Or: get some more control over the process : first, install all packages manually without setting them up, and then import your config.



  • @Asadsarwar said in Installed packages not working nor installing:

    As per the pfsense "The system is on latest version".

    You wrote "2.4.4" and that's in your screen cap but the latest is 2.4.5. Probably the cleanest thing at this point is to install again, upgrade to 2.4.5 and then restore your config from backup.