Huawei E3372s-153 no Link Interface(s)



  • Hello,

    I bought a Huawei E3372s-153

    Hardware version: CL1E3372SM
    Software version: 22.300.09.00.00
    Web UI version: 17.100.13.112.03

    what i have to do with the Init string: &F&C1&D2E0S0=0 ?

    i tried camcontrol eject cd0 and i added <shellcmd>camcontrol eject cd0</shellcmd>

    in PPPs there is no Link interface(s)
    do i have to downgrade the firmware ?


  • Netgate Administrator

    What do you see in the system log when you connect it?

    What does it's output in usbconfig dump_all_desc look like?

    It probably requires some sort of mode switch if it's not presenting any ports.

    Does it have a webui? That implies it's in hilink (router) mode.

    Steve



  • I bought the specific usb stick because i read an old post that works in stick (modem) mode but it has webui .
    IMG_20200818_203330.jpg IMG_20200818_203616.jpg IMG_20200818_203650.jpg IMG_20200818_204140.jpg IMG_20200818_204206.jpg

    How can i change mode ?

    John


  • Netgate Administrator

    Photos of the screen are a lot less useful than text we can copy or serach.
    You should be able to just copy and paste that data out of the log or console.

    Was that all the output for ugen4.2?

    I only see one interface there and it's detecting both the virtual CD drive and the SD card reader.

    But that PID implies it's in HiLink mode:
    https://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=2697

    Do you see a usb ethernet device available to assign? ue0?

    Steve



  • Text is detected as a spam, here is the exact output in the txt files

    dump.txt
    logfile.txt

    ls /dev/ there is no ue0 device, when i plug it in a windows machine it is in HiLink mode

    John


  • Netgate Administrator

    Hmm, OK. If it doesn't get switched by ejecting the virtual CD you may need to use usb mode switch as the link above. If it then switches to one of the devices listed here it should be recognised and have the ports created:
    https://github.com/pfsense/FreeBSD-src/blob/RELENG_2_4_5/sys/dev/usb/serial/u3g.c#L246

    Steve



  • Sorry i didn't understand, i have to install pkg install usb_modeswitch or i have to compile and run the u3g.c ?

    I installed usb_modeswitch and i tried usb_modeswitch -v 12d1 -p 1f01

    no Link Interface(s) appeared


  • Netgate Administrator

    Did it report success finding the device and/or switching it?



  • No devices in default mode found. Nothing to do.


  • Netgate Administrator

    Hmm, more research needed! You might have to specify that as the default mode either using command line switches or a simple conf file.



  • if i enter

    usb_modeswitch -J -W -v 0x12d1 -p 0x1f01

    the switch command executes successfully , then an ethernet device ue0 appears but no serial interface, i enabled the serial ports from the bios , it appears cuau0, cuau0.init,cuau0.lock,cuau1,cuau1.init,cuau1.lock

    cu /dev/cuau0 prints cu: unknown host cu9600

    perhaps it is another interface that communicates with the modem ?

    I noticed when i plug the device these devices appear
    cd0,da0,iso9660,pass1,pass2


  • Netgate Administrator

    It's in HiLink mode most likely, running as a router. You may be able to mode switch it with a different command into modem mode where it gives you USB serial ports. They are denoted with an upper case U so cuaU0 for example.

    You can probably just assign the USB Ethernet device though and use it. However you will hit problems if/when you reboot as ue0 won;t exist until the device is mode-switched.

    Steve



  • @John8 said in Huawei E3372s-153 no Link Interface(s):

    I noticed when i plug the device these devices appear
    cd0,da0,iso9660,pass1,pass2

    Yeah, as your initial post above. The "kernel" (build in drivers) decided to recognize your device as a "cd". Plain wrong, of course. It shows no native Haiwata support is build into the (now old stable) FreeBSD 11.3.

    This device should not be removed as soon as you get it recognized.
    That's where Plug and Play becomes Plug and Pray.

    I advise you to install the latest and greatest from here https://www.freebsd.org/where.html - and check if the device gets recognized. If so, there is hope it will get retrofitted to 11.3 in a workable way - if not, say after me : "Do not use USB NIC and FreeBSD together".
    Do not forget to consult official FreeBSD support and see what been done for your device.



  • When i removed the usb device, after a reboot, pfsense went into a booting loop to set vlans, i ended reset to the factory defaults.

    I tried to install FreeBSD 12 but i got a loader error.

    Thank you for your help i quit.


  • Netgate Administrator

    @stephenw10 said in Huawei E3372s-153 no Link Interface(s):

    However you will hit problems if/when you reboot as ue0 won;t exist until the device is mode-switched

    Yup. No easy way past that. That's why you don't want something in HiLink mode if possible.

    Steve


Log in to reply