Can't get WAN IP when setting up pfSense with Netgear M1 4G Router as Modemm,



  • I have been researching on this but none give me the solution to fix the problem of not getting WAN IP. I used to use cable ISP with pfSense without any issues.

    My situation is that I have no Cable ISP and I have to use a 4G SIM Router (Netgear M1 is what I currently own) to provide Internet access to my home so this is no a failover topic. And something I knew while researching is that my SIM ISP is providing a 10.x.x.x IP for me, meaning my carrier is using CGNAT if I understand correctly. I check what is my public IP which is different from the 10.x.x.x so I am pretty sure on this. I checked this info on M1.

    I tried to set my M1 to have IP passthrough ON. When I plug in Ethernet port of M1 to WAN interface on an ordinary router (D-Link DIR 615, which is supe old I know), it works fine and can go on Internet without any issues. But I plug in M1 to pfSense WAN interface, I have no Internet access, the Gateway has 100% packet loss with the following error in system log:

    kernel: arpresolve: can't allocate llinfo 10.x.x.1
    

    I tried to disable IP passthrough and enable DHCP on M1, and DMZ the IP assigned to pfSense, but seems not working or my steps were wrong.

    I will gather more info, screenshot and log when I get home. Any advice would help thanks.

    Edit: my LAN is 10.1.1.1/24 not sure if that helps.


  • Netgate Administrator

    Is the WAN in that same subnet that will break it.

    That error means pfSense does not have an interface in that subnet so it can't add that address as local. Have you set that gateway manually?

    Is the pfSense WAN set to DHCP?

    Is it even showing as linked?

    Steve



  • @stephenw10 said in Can't get WAN IP when setting up pfSense with Netgear M1 4G Router as Modemm,:

    Is the WAN in that same subnet that will break it.

    That error means pfSense does not have an interface in that subnet so it can't add that address as local. Have you set that gateway manually?

    Is the pfSense WAN set to DHCP?

    Is it even showing as linked?

    Steve

    Do you mean passing through the IP of 10.x.y.z from M1 will conflict with what I have from my LAN net since the 10.x.y.z from WAN is possibly /8 which covers my LAN 10.1.1.1/24?

    If that is the case, is it possible for me not to change my LAN net settings? Cuz it will be a pain in the ass, I have many static IP set already.

    Yes the pfSense WAN is set to DHCP, and from the console I see the WAN interface gets an IP of 10.x.y.z/32, while the gateway is 10.x.y.1


  • Netgate Administrator

    Ah, so more likely then it's not a conflict but that your ISP is handing you a technically invalid gateway that's outside the WAN subnet, which is only a single address. Fun.

    There is an option to allow that for providers who decide to ignore the standards. In System > Routing > Gateways edit the dhcp gateway and set 'Use non-local gateway' in the advanced section.

    Steve