PfSense on Nokia IP130



  • Hi all,
    I'm a longtime user of m0n0wall, but now i like to switch to sfSense (need the enhancements :) )
    The m0n0wall runs fine on a Nokia IP110 (since 5 years), and i have another IP130 were i like to install pfSense.
    Unfortunately, the system won't boot. It stops immediately when it trys to mount the / partition
    Looks like this:


    hptrr: no controller detected.                                                 
    ad0: 38154MB <fujitsu mhv2040as="" 00000096="">at ata0-master UDMA33               
    Trying to mount root from ufs:/dev/da0s1a

    Manual root filesystem specification:                                         
      <fstype>:<device>  Mount <device>using filesystem <fstype>                 
                          eg. ufs:da0s1a                                         
      ?                  List valid disk boot devices                             
      <empty line="">      Abort manual input
    ...

    So i thinks i'm missing some modules/drivers for the controller? How to get or to build?
    Or any other hints?
    I tried the embedded and also the stand. kernel, same result everytime :(

    Thanks for help,
    Wolfgang</empty></fstype></device></device></fstype></fujitsu>



  • :)
    Found the mistake.

    I installed the HDD with a USB2IDE adapter. And this is a SCSI emulation.
    The Nokia only kows about IDE, so i had to change the da0… to ad0...

    -WOlfgang


Log in to reply