Pfsense and VLAN Problem



  • Hi All,

    I had trouble with setting VLAN by Pfsense and Switch L2 Asus.

    On PC running Pfsense Ver 1.2.3 I have 2 Netword Card

    Eth0 - Connect to modem to Internet
    Eth1 - Giga speed network conect to switch L2
    On eth1 i was create 3 VLAN and setup DHCP Server on each VLAN, everything seem ok. But when I connect PC client ( running windows XP SP2) to port on L2 switch were setting for Tagged with Pfsense VLAN it cannot communicate with VLAN -  It can not receice IP from VLAN DHCP. But when I change testing to pc running windows 7 everything was success in same port with same setting i can get IP from VLAN DHCP Server and connect to Internet from any VLAN.
    I dont know what happened to my network, this is my first VLAN setting so i have not much experience about this.
    Any body can help me to find some thing wrong with my network setting i cant change all of PC to Windows 7.

    Thanks in advance.!



  • Well it sounds like it should work.
    My recheck book contains.
    CIDR is correct on opt lan, DHCP is auto on client, change cable, boot from a livecd like ubuntu.

    else post some screenshots.



  • Thanks for reply,

    I'm not yet try on client running Linux I will try late and give the response to you. About setting on pfsense i think is not trouble, anyway I will look more again.

    Thanks



  • I'm not sure if i understood your description correctly, but is the port on the switch going to the client tagged or untagged?



  • I found the reason is network card on pc client doesn't support VLAN, and then I try to update driver for network card and now everytihing is OK but new problem is we have alot of Realtek 8139 network and is not support VLAN although i was update to newest driver.



  • Clients doesn't need vlan support nics. ports that they are connected to should be set as untagget.

    pfsense <–--tagget----> asus switch <----untagget---->clients



  • Oh thanks for your idea, It is realy clear to me.
    Thanks again.!


Log in to reply