PFSense hangs on reboot



  • I have pfSense running on a number of different pieces of hardware with no problems.  Today, however I ran into problems installing the 1.2.3 release on 3 machines.  In each case, the install works flawlessly, until the final reboot.  The processes and tasks are shut down and the reboot process starts.  The monitor reports "no signal" but the reboot never occurs.  A hard restart gets the system back up and running, but subsequent reboots hang.  I've disabled everything non essential in the bios with no change in behavior.  I did a quick unbuntu server install on one of the boxes and the reboot happens normally but as soon as I install pfSense the problem reappears.  Any ideas would be appreciated.



  • Have you tried disabling acpi?



  • That was the first thing I thought of trying (after reading the forums).  Unfortunately the motherboard in all the machines is an intel serverboard S875-WP1-e which doesn't have any option to disable ACPI.  I'm pretty sure I have used this same board before in other builds without this problem.



  • @kitdavis:

    That was the first thing I thought of trying (after reading the forums).  Unfortunately the motherboard in all the machines is an intel serverboard S875-WP1-e which doesn't have any option to disable ACPI.   I'm pretty sure I have used this same board before in other builds without this problem.

    During the boot up sequence choose "Boot pfSense with ACPI disabled" instead of the default, I've a similar problem way back and I can't figure out why the boot sequence hangs, I'm not sure though if it's applicable in your case, anyways there's no harm in trying.


  • Rebel Alliance Developer Netgate

    try this before a reboot:

    sysctl -w hw.acpi.handle_reboot=1

    If the resulting reboot works, add:

    hw.acpi.handle_reboot="1"

    To /etc/sysctl.conf

    From acpi(4):

    hw.acpi.handle_reboot
                Use the ACPI Reset Register capability to reboot the system.
                Default is 0, use legacy reboot support.  Some newer systems
                require use of this register, while some only work with legacy
                rebooting support.



  • hw.acpi.handle_reboot=1 does not work, but booting with ACPI disabled does - so the easy solution is to figure out how to disable ACPI in the boot up process by default.  (although this seems a bit like a kludge)


  • Rebel Alliance Developer Netgate

    ACPI can be disabled as follows:
    http://doc.pfsense.org/index.php/Disable_ACPI

    It is a bit kludge, but on some systems it is necessary.



  • Found the setting in the book - making changes in /boot/device.hints  I will try this and report back.



  • Disabling ACPI in the device.hints file works.  Thanks to all for the help on this.


Log in to reply