Setup wizard fails after ntp setting



  • Did look for issues on the setup wizard but did not find a relevant one.

    Encountered this with the march 4 and 5 versions:

    Sometimes the wizard kicks in automaticly sometimes I have to start it by hand. But everytime it stops after the step with the timezone and ntp server. It shows a nearly empty page with a link on it: "No page assigned to this user! Click here to logout.". The page title is "201".

    Clicking the link brings me to a nearly empty page in which I should be able to login (not the WebGUIs normal login page) but it does not accept the default account (admin/pfsense).

    It has allso happened (checked 2 times now) that traffic on the LAN interface is blocked after this. When this happens the console menu does not give any interfaces anymore at top but the following warning: "Warning: Invalid argument supplied for foreach() in /etc/inc/util.inc on line 466"

    Other thing I noticed was that I cannot seem to be able to edit the (WAN) interface properties. I want to allow private networks but the interface just resets the values and the rules stay active. The interface does ask for a reload.

    Peter



  • There was a patch to fix the disabled state on optX interfaces, but it made it impossible to save settings on the pages for configuring wan or lan, since they don't have that checkbox.  This has already been fixed, but some snapshots did get built before the fix was committed.

    For that particular issue if you want to manually apply the fix, look for these lines in usr/local/www/interfaces.php:

    
     			Enable
    
     				 onClick="show_allcfg(this);">
     			**Enable Interface**
    
    

    And change it to look like this:

    
     			Enable
    
     				 onClick="show_allcfg(this);">
     			**Enable Interface**
    
    

    Images from the 5th and later should have the fix.

    As for the other issues, I know nothing about those.



  • lol…. timing is all it seems....
    Made the change and I can now change the settings for the WAN interface... thanks o

    further on that other issue:
    Had to reboot the box to get access again.... noticed the LAN inface had reset itself to its initial IP configuration (192.168.1.1). Have to change this because my WAN interface is on a 192.168.1/24 network to.



  • @Efonne:

    Images from the 5th and later should have the fix.

    As for the other issues, I know nothing about those.

    Note I have this exact same problem with the 2g nanobsd version dated the 6th.

    Thanks



  • I've just had the "No page assigned to this user! Click here to logout." message.

    When I reboot I now get lots of "XML error: no pfsense object found!" messages on the console interface.

    This was with pfSense-2.0-BETA1-512mb-20100307-1243-nanobsd.img.gz.



  • @keylevel:

    I've just had the "No page assigned to this user! Click here to logout." message.

    When I reboot I now get lots of "XML error: no pfsense object found!" messages on the console interface.

    I had the same problem with pfSense-Full-Update-2.0-BETA1-20100308-2108.tgz.

    I checked and /usr/local/www/interfaces.php had the patch in Efonne's reply.



  • That was only related to the last part of what was mentioned in the first post.  The rest are other issues.



  • The originally reported issue also happens on the build pfSense-Full-Update-2.0-BETA1-20100221-0542.tgz

    From console, reset to factory defaults then set IP of LAN interface, then connect to web GUI.



  • @keylevel:

    I've just had the "No page assigned to this user! Click here to logout." message.

    When I reboot I now get lots of "XML error: no pfsense object found!" messages on the console interface.

    This was with pfSense-2.0-BETA1-512mb-20100307-1243-nanobsd.img.gz.

    Same issue with "pfSense-2.0-BETA1-1g-20100309-0142-nanobsd.img.gz"





  • A fix has been committed for this issue.  The snapshot after the first one available after this post should probably have the fix.


Log in to reply