No internet on lan



  • hello,

    flashed 19th march snapshot, pppoe is working, but no connection to the internet is possible on my lan either on the pfsense itself.
    when trying to ping a host I got the message

     [admin@pfSense.at.bepnet]/root(2): ping 88.198.66.71
    PING 88.198.66.71 (88.198.66.71): 56 data bytes
    ping: sendto: No route to host
    ping: sendto: No route to host
    ping: sendto: No route to host
    ping: sendto: No route to host
    ^C
    --- 88.198.66.71 ping statistics ---
    4 packets transmitted, 0 packets received, 100.0% packet loss
    
    

    may anybody help please.



  • Seems like the same problem was already reported with an older snapshot. I'm using nanobsd snapshot.

    http://forum.pfsense.org/index.php/topic,23246.0.html



  • Can you please give me the contents of /var/etc/mpd*.conf



  • mpd_wan.conf

    startup:
    pppoeclient:
            create bundle static wan
            set iface name pppoe0
            set iface route default
            set iface disable on-demand
            set iface idle 0
            set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
            set ipcp yes vjcomp
            set ipcp ranges 0.0.0.0/0 0.0.0.0/0
            create link static wanL1 pppoe
            set link disable incoming
            set link action bundle wan
            set auth authname "***"
            set auth password "***"
            set link keep-alive 10 60
            set link max-redial 0
            set link no acfcomp protocomp
            set link disable pap chap
            set link accept chap
            set pppoe iface vr1
            set pppoe service ""
                    set link mtu 1492
            open
    
    


  • Do you have a default gateway set?!
    route get default

    also show the output of netstat -rn



  • route get default

    [admin@pfSense.at.bepnet]/var/etc(11): route get default
       route to: default
    destination: default
           mask: default
      interface: vr0
          flags: <up,done,static>recvpipe  sendpipe  ssthresh  rtt,msec    mtu        weight    expire
           0         0         0         0      1500         1         0
    [2.0-BETA1]                                                                                                             [admin@pfSense.at.bepnet]/var/etc(12):</up,done,static> 
    

    netstat -rn

    [admin@pfSense.at.bepnet]/var/etc(12): netstat -rn
    Routing tables
    
    Internet:
    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            10.0.0.1           US          0    11129    vr0
    10.0.0.0/24        link#1             U           0    21724    vr0
    10.0.0.1           link#1             UHS         0       40    lo0
    10.0.0.243         link#2             UHS         0        0    lo0
    87.164.245.122     link#8             UHS         0        0    lo0
    127.0.0.1          link#7             UH          0       19    lo0
    127.0.0.2          127.0.0.1          UHS         0        0    lo0
    217.0.116.233      link#8             UH          0        0 pppoe0
    
    Internet6:
    Destination                       Gateway                       Flags      Netif Expire
    ::1                               ::1                           UH          lo0
    fe80::%vr0/64                     link#1                        U           vr0
    fe80::20d:b9ff:fe19:f31c%vr0      link#1                        UHS         lo0
    fe80::%vr1/64                     link#2                        U           vr1
    fe80::20d:b9ff:fe19:f31d%vr1      link#2                        UHS         lo0
    fe80::%lo0/64                     link#7                        U           lo0
    fe80::1%lo0                       link#7                        UHS         lo0
    fe80::%pppoe0/64                  link#8                        U        pppoe0
    fe80::20d:b9ff:fe19:f31c%pppoe0   link#8                        UHS         lo0
    ff01:1::/32                       fe80::20d:b9ff:fe19:f31c%vr0  U           vr0
    ff01:2::/32                       fe80::20d:b9ff:fe19:f31d%vr1  U           vr1
    ff01:7::/32                       ::1                           U           lo0
    ff01:8::/32                       fe80::20d:b9ff:fe19:f31c%pppoe0 U        pppoe0
    ff02::%vr0/32                     fe80::20d:b9ff:fe19:f31c%vr0  U           vr0
    ff02::%vr1/32                     fe80::20d:b9ff:fe19:f31d%vr1  U           vr1
    ff02::%lo0/32                     ::1                           U           lo0
    ff02::%pppoe0/32                  fe80::20d:b9ff:fe19:f31c%pppoe0 U        pppoe0
    [2.0-BETA1]                                                                                                             [admin@pfSense.at.bepnet]/var/etc(13):
    
    


  • You have set default gateway on your wan
    That is your problem.



  • Shouldn't the default gateway set automatically because in mpd_wan.conf "set iface route default" is set. In former snapshots there was no need to set this by hand. How do i set the default gateway by hand?
    the status page of the gateways shows following:

    WAN  	 217.0.116.233  	 217.0.116.233  	Gathering data	Interface wan Dynamic Gateway 
    


  • Ok, found it in the doc :) everything is working fine. Thanks a lot for your instant help.



  • @beppo:

    Ok, found it in the doc :) everything is working fine. Thanks a lot for your instant help.

    could u post the link to the doc which helped u?





  • Sorry for getting into this thread…
    I am also fighting with this "problem" ... Had an older snapshot of 2.0beta on the box, did an online upgrade to the 19th march snapshot and now I have the exact problem as you have with the default gateway...
    I have two PPoE-WAN-Uplinks (only one of the two is currently connected and has a public ip now), when I open the connected one and try to tick "use as default gateway", I get:

    "The following input errors were detected:

    • The gateway address 213.191.64.183 does not lie within the chosen interface's subnet."

    How did you resolve this?

    Thanks a lot for your help!

    Best regards,

    Chris



  • I had same issue (cannot access internet) after upgrading from March 4th to March 19th nanobsd snap.

    For everyone that cannot access internet try this: go to Interface > Wan and click save and then apply without changing anything. This should solve the problem.

    My config XML from March 4th build looked like this:

    	 <gateways><gateway_item><defaultgw>true</defaultgw></gateway_item> 
    		 <gateway_item><gateway>dynamic</gateway>
    			<descr>Interface wan dynamic gateway</descr>
    			<name>GW_WAN</name>
    			<interface>wan</interface></gateway_item></gateways> 
    

    New XML from March 19th looks like this:

    	 <gateways><gateway_item><gateway>dynamic</gateway>
    			<descr>Interface wan dynamic gateway</descr>
    			<name>GW_WAN</name>
    			<interface>wan</interface></gateway_item></gateways> 
    

    PHP code from March 19th that sets default route in mpd config file:

    	$setdefaultgw = false;
    	$founddefaultgw = false;
    	if (is_array($config['gateways']['gateway_item'])) {
    		foreach($config['gateways']['gateway_item'] as $gateway) {
    			if($interface == $gateway['interface'] && isset($gateway['defaultgw'])) {
    				$setdefaultgw = true;
    				break;
    			} else if (isset($gateway['defaultgw'])) {
    				$founddefaultgw = true;
    				break;
    			}
    		}
    	}
    	if (($interface == "wan" && $founddefaultgw == false) || $setdefaultgw == true)
    		$mpdconf .= << <eod<br>set iface route default
    
    EOD;</eod<br>
    

    When this code uses old XML config (which I think happens after upgrade) it will not add default route because $setdefaultgw will be false and $founddefaultgw will be true.
    In the new XML configuration this is missing:

    		 <gateway_item><defaultgw>true</defaultgw></gateway_item> 
    

    so $founddefaultgw will be false and default route will be set in the mpd config file.

    If I go to System > Routing and edit GW_WAN 'Default Gateway' checkbox is not checked so that might be a bug.



  • Thanks for your reply and your information! :-)

    Best regards,

    Chris


Log in to reply