Port Forwarding Issue



  • Hi all,

    Before I begin, I should mention that I'm totally new to pfSense.  The setup is fine except one thing which is portforwarding.  Simply put, i have a web server with IP address of 10.1.1.70 and I want to forward all the external requests on port 82 to my web server.  Can someone please tell me exactly, how to accomplish this?  If you need any additional info please feel free to ask.

    Thanks in advance,
    Sunny



  • On the firewall menu select NAT. Click the plus image to add a nule rule. Then fill in external port 82, nat ip 10.10.1.70, local port 80, and give it a description. Leave auto-add a firewall rule checked and click save.



  • Thanks for your reply!  I tried it but doesn't seem to be working.  Is there anything else that needs to be changed?  Actually, its getting timed out.



  • try this not sure if it will work





  • Don't use external adress "any". You need to bind it to the WAN-Adress. any is only for some special application (for example when redirectring traffic to any external adress on port x back to a proxy for example).



  • Hoba, do you mind walk me thru the process please?



  • Can you paste your setings for the firewallrule and the portforwarding that you created please?



  • Hi Hoba,

    I am also encountering issues with my NAT settings.  Can you please look at the attached settings?  Thank you.

    ![NAT settings.gif](/public/imported_attachments/1/NAT settings.gif)
    ![NAT settings.gif_thumb](/public/imported_attachments/1/NAT settings.gif_thumb)
    ![NAT settings.gif_thumb](/public/imported_attachments/1/NAT settings.gif_thumb)



  • The NAT entry looks ok from the first sight. If you have an appropriate firewallrule in place that is allowing this traffic it should work. Also make sure you are at 1.0.1.



  • What type of rule would allow visitors from the WAN to the OPT1 net with the host using the NAT I set above?



  • Interface WAN
    protocol tcp/udp
    source any
    destination <private ip="" of="" forwarded="" client="">port <destination port="" at="" the="" client="">gateway default</destination></private>



  • i have the same itentical problem, except for…

    i set 2 firewall rules:

    prot: * from: * port: * to: 192.168.0.40 port: * gate: *    (windows machine)
    prot: * from: * port: * to: 192.168.0.200 port: * gate: *    (linux machine)

    so i'll be sure that i can transfer any packets from and to any ports to these 2 machines

    now, i need to open only 1 or 2 single port to forward to, so i make a nat rule like this:
    if: wan prot: tcp port: 4889 nat: 192.168.0.40 (ext: 2.247.bla.bla) port: 4889  (correctly WORK!!)
    if: wan prot: tcp port: 4889 nat: 192.168.0.200 (ext: 2.247.bla.bla) port: 4889  (DON'T WORK!!)

    So, why nat don't like to linux port forward???



  • oky, the reason is that

    on the linux machine i have not jet configured the proper gateway!


Locked