Errors on boot - v1 embedded on 128 CF



  • Hello,

    I am getting the following messages with serial console. I imaged a 128 CF with the v1 release. Any Ideas? Also, if these erros can be ingorned, how do I start the console base setup? I would assume that this should start automatically, but is not per the errors below.

    TIA! …and keep up the great work.

    init 6
    
    pfSense is now shutting down ...
    
    **Warning**:  main(config.inc) [[function.main](function.main)]: failed to open stream: No such file or directory in **/etc/rc.conf_mount_rw** on line **32**
    
    **Fatal error**:  main() [[function.require](function.require)]: Failed opening required 'config.inc' (include_path='.:') in **/etc/rc.conf_mount_rw** on line **32**
    
    tar: var/db/rrd/*.rrd: Cannot stat: No such file or directory
    
    **Warning**:  main(config.inc) [[function.main](function.main)]: failed to open stream: No such file or directory in **/etc/rc.conf_mount_ro** on line **32**
    
    **Fatal error**:  main() [[function.require](function.require)]: Failed opening required 'config.inc' (include_path='.:') in **/etc/rc.conf_mount_ro** on line **32**
    
    Waiting (max 60 seconds) for system process `vnlru' to stop...done
    Waiting (max 60 seconds) for system process `bufdaemon' to stop...done
    Waiting (max 60 seconds) for system process `syncer' to stop...
    Syncing disks, vnodes remaining...0 0 done
    All buffers synced.
    Uptime: 23m53s
    ukphy0: detached
    miibus0: detached
    Rebooting...
    -\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\/boot/kernel/kernel text=0x4a3ce0 |/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\data=0x8fe74+0x41138 |/-\|/-\|/-\|/-\|/-\|/-\|
    /-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|/-\|
    Hit [Enter] to boot immediately, or any other key for command prompt.
    
    Booting [/boot/kernel/kernel]...               
    /-\|/-\Copyright (c) 1992-2006 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD 6.1-RELEASE-p10 #0: Fri Oct 13 03:43:07 UTC 2006
        sullrich@builder.livebsd.com:/usr/obj.pfSense/usr/src/sys/pfSense_wrap.6
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: VIA C3 Nehemiah+RNG+ACE (533.35-MHz 686-class CPU)
      Origin = "CentaurHauls"  Id = 0x698  Stepping = 8
      Features=0x381b93f <fpu,vme,de,pse,tsc,msr,cx8,sep,mtrr,pge,cmov,pat,mmx,fxsr,sse>real memory  = 259981312 (247 MB)
    avail memory = 245039104 (233 MB)
    wlan: mac acl policy registered
    ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    cpu0 on motherboard
    pcib0: <host to="" pci="" bridge=""> pcibus 0 on motherboard
    pir0: <pci 5="" interrupt="" routing="" table:="" entries=""> on motherboard
    pci0: <pci bus=""> on pcib0
    $PIR: No matching entry for 0.17.INTD
    $PIR: No matching entry for 0.17.INTD
    $PIR: No matching entry for 0.17.INTC
    $PIR: No matching entry for 0.18.INTA
    pcib1: <pci-pci bridge=""> at device 1.0 on pci0
    pci1: <pci bus=""> on pcib1
    pci1: <display, vga=""> at device 0.0 (no driver attached)
    isab0: <pci-isa bridge=""> at device 17.0 on pci0
    isa0: <isa bus=""> on isab0
    atapci0: <via 8231="" udma100="" controller=""> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xc000-0xc00f at device 17.1 on pci0
    ata0: <ata 0="" channel=""> on atapci0
    ata1: <ata 1="" channel=""> on atapci0
    uhci0: <via 83c572="" usb="" controller=""> port 0xc400-0xc41f irq 5 at device 17.2 on pci0
    uhci0: [GIANT-LOCKED]
    usb0: <via 83c572="" usb="" controller=""> on uhci0
    usb0: USB revision 1.0
    uhub0: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub0: 2 ports with 2 removable, self powered
    uhci1: <via 83c572="" usb="" controller=""> port 0xc800-0xc81f irq 5 at device 17.3 on pci0
    uhci1: [GIANT-LOCKED]
    usb1: <via 83c572="" usb="" controller=""> on uhci1
    usb1: USB revision 1.0
    uhub1: VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
    uhub1: 2 ports with 2 removable, self powered
    pci0: <bridge> at device 17.4 (no driver attached)
    pci0: <multimedia, audio=""> at device 17.5 (no driver attached)
    vr0: <via 10="" vt6102="" rhine="" ii="" 100basetx=""> port 0xd800-0xd8ff mem 0xe4001000-0xe40010ff irq 10 at device 18.0 on pci0
    miibus0: <mii bus=""> on vr0
    ukphy0: <generic ieee="" 802.3u="" media="" interface=""> on miibus0
    ukphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    vr0: Ethernet address: 00:40:63:e3:d0:50
    xl0: <3Com 3c905B-TX Fast Etherlink XL> port 0xdc00-0xdc7f mem 0xe4000000-0xe400007f irq 10 at device 19.0 on pci0
    miibus1: <mii bus=""> on xl0
    xlphy0: <3Com internal media interface> on miibus1
    xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    xl0: Ethernet address: 00:04:76:34:bf:12
    xl1: <3Com 3c905B-TX Fast Etherlink XL> port 0xe000-0xe07f mem 0xe4002000-0xe400207f irq 11 at device 20.0 on pci0
    miibus2: <mii bus=""> on xl1
    xlphy1: <3Com internal media interface> on miibus2
    xlphy1:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
    xl1: Ethernet address: 00:04:76:34:c0:1f
    orm0: <isa option="" rom=""> at iomem 0xc0000-0xcbfff on isa0
    ppc0: <parallel port=""> at port 0x378-0x37f irq 7 on isa0
    ppc0: Generic chipset (EPP/NIBBLE) in COMPATIBLE mode
    ppbus0: <parallel port="" bus=""> on ppc0
    ppi0: <parallel i="" o=""> on ppbus0
    sio0 at port 0x3f8-0x3ff irq 4 flags 0x30 on isa0
    sio0: type 16550A, console
    sio1: configured irq 3 not in bitmap of probed irqs 0
    sio1: port may not be enabled
    speaker0: <pc speaker=""> at port 0x61 on isa0
    unknown: <pnp0c01> can't assign resources (memory)
    unknown: <pnp0501> can't assign resources (port)
    unknown: <pnp0400> can't assign resources (port)
    Timecounter "TSC" frequency 533354914 Hz quality 800
    Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    ad2: 122MB <sandisk sdcfb-128="" hdx="" 2.15=""> at ata1-master PIO4
    GEOM_LABEL: Label for provider ad2a is ufs/pfSense.
    GEOM_LABEL: Label for provider ad2d is ufs/pfSenseCfg.
    Trying to mount root from ufs:/dev/ufs/pfSense
    
         ___
     ___/ f \
    / p \___/ Sense
    \___/   \
        \___/
    
    Welcome to pfSense 1.0-RELEASE on the 'embedded' platform...
    
    Setting up embedded specific environment... done.
    Mounting filesystems... done.
    Creating symlinks......done.
    Launching PHP init system... done.
    Initializing....
    
    **Warning**:  main(globals.inc) [[function.main](function.main)]: failed to open stream: No such file or directory in **/etc/rc.bootup** on line **38**
    
    **Fatal error**:  main() [[function.require](function.require)]: Failed opening required 'globals.inc' (include_path='.:') in **/etc/rc.bootup** on line **38**
    
    Starting CRON... done.
    Syncing packages...
    
    **Warning**:  main(config.inc) [[function.main](function.main)]: failed to open stream: No such file or directory in **/etc/rc.packages** on line **32**
    
    **Fatal error**:  main() [[function.require](function.require)]: Failed opening required 'config.inc' (include_path='.:') in **/etc/rc.packages** on line **32**
    
    Executing rc.d items... 
     Starting /usr/local/etc/rc.d/*.sh...done.
     Starting /usr/local/etc/rc.d/*.sh...done.
    
    **Warning**:  main(config.inc) [[function.main](function.main)]: failed to open stream: No such file or directory in **/etc/rc.conf_mount_ro** on line **32**
    
    **Fatal error**:  main() [[function.require](function.require)]: Failed opening required 'config.inc' (include_path='.:') in **/etc/rc.conf_moun**</sandisk></pnp0400></pnp0501></pnp0c01></pc></parallel></parallel></parallel></isa></mii></mii></generic></mii></via></multimedia,></bridge></via></via></via></via></ata></ata></via></isa></pci-isa></display,></pci></pci-pci></pci></pci></host></fpu,vme,de,pse,tsc,msr,cx8,sep,mtrr,pge,cmov,pat,mmx,fxsr,sse>
    


  • Those errors can not be ignored. Is the compact flash media old or new? Try reflashing and/or using a new compact flash card.



  • Thanks for your prompt reply…

    The card is brand new.... I will reflash now. I also have a brand new 256 laying around. I'll flash both and post what happans..

    Thanks!



  • I am glad I posted.. I reflashed the 128 and now all is well!!

    Should I be concerned about the reliablility of this particular card? or is this normal? Also, will hard shutdowns damage the contents of the CF media?

    Thanks!



  • Either something went wrong when you flashed that card or the card indeed is somehow flaky.

    The cf card in general should not be broken on a hard shutdown as the filesystem is readonly for embedded instralls (unless you hit the exact time when the config.xml is written when something was changed on the webgui).



  • I am currently having this problem on a non embedded image of PFsense, this is the second time this has happened to me. It's not a big deal to reflash except that I loose my config everytime I do so… I'm not sure why it is happening, I think it does have something to do with a hard shutdown because this time it happened after the power went out.


Locked