DMA limited to UDMA33, device found non-ATA66 cable



  • 2.0-BETA4  (i386)
    built on Thu Aug 26 00:12:24 EDT 2010
    FreeBSD 8.1-RELEASE

    I recently replaced my hard drive to a Sata drive and upgraded to 2.0. My Drive is first detected at UDMA133 then ultimately ends at UDMA33. What's weird is I have a Freenas box based on freebsd7.2 and it is shown as UDMA133. The motherboard,processor,cipset and bios are identical.

    I then loaded PfSense 1.23 back on and it's detected as UDMA133.

    I chesck the Freebsd 8.1 Harware compatibility list as well as the ATA4 driver and the SIS965 chipset is supported.
    I tried to manually set it using atacontrol, but that got me nowhere.

    Below is my dmesg output…..any ideas??

    $ dmesg
    Copyright (c) 1992-2010 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 8.1-RELEASE #1: Thu Aug 26 00:00:31 EDT 2010
        sullrich@FreeBSD_8.0_pfSense_2.0-snaps.pfsense.org:/usr/obj.pfSense/usr/pfSensesrc/src/sys/pfSense.8 i386
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: AMD Sempron(tm) Processor 3000+ (1800.07-MHz 686-class CPU)
      Origin = "AuthenticAMD"  Id = 0x20fc2  Family = f  Model = 2c  Stepping = 2
      Features=0x78bfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>Features2=0x1 <sse3>AMD Features=0xe2500800 <syscall,nx,mmx+,ffxsr,lm,3dnow!+,3dnow!>AMD Features2=0x1 <lahf>real memory  = 2147483648 (2048 MB)
    avail memory = 2053496832 (1958 MB)
    ACPI APIC Table: <a m="" i ="" oemapic="">ioapic0 <version 1.4="">irqs 0-23 on motherboard
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xc074f1b0, 0) error 1
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc074f270, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc074f330, 0) error 1
    wlan: mac acl policy registered
    wpi: You need to read the LICENSE file in /usr/share/doc/legal/intel_wpi/.
    wpi: If you agree with the license, set legal.intel_wpi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (wpi_fw, 0xc092f7c0, 0) error 1
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0:</software></version></a> <a m="" i="" oemrsdt="">on motherboard
    acpi0: [ITHREAD]
    ACPI Error: Invalid type (Method) for target of Scope operator [PCI0] (Cannot override) (20100331/dswload-821)
    ACPI Exception: AE_AML_OPERAND_TYPE, During name lookup/catalog (20100331/psloop-326)
    ACPI Error (psparse-0633): Method parse/execution failed [\SB.PCI0] (Node 0xc5ab2740), AE_AML_OPERAND_TYPE
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 7ff00000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <acpi cpu="">on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    pcib1: <acpi pci-pci="" bridge="">at device 1.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    vgapci0: <vga-compatible display="">port 0xe800-0xe87f mem 0xd8000000-0xdfffffff,0xfebe0000-0xfebfffff irq 16 at device 0.0 on pci1
    isab0: <pci-isa bridge="">at device 2.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <sis 965="" udma133="" controller="">port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 2.5 on pci0
    ata0: <ata 0="" channel="">on atapci0
    ata0: [ITHREAD]
    ata1: <ata 1="" channel="">on atapci0
    ata1: [ITHREAD]
    pci0: <multimedia, audio="">at device 2.7 (no driver attached)
    ohci0: <sis 5571="" usb="" controller="">mem 0xfeaff000-0xfeafffff irq 20 at device 3.0 on pci0
    ohci0: [ITHREAD]
    usbus0: <sis 5571="" usb="" controller="">on ohci0
    ohci1: <sis 5571="" usb="" controller="">mem 0xfeafe000-0xfeafefff irq 21 at device 3.1 on pci0
    ohci1: [ITHREAD]
    usbus1: <sis 5571="" usb="" controller="">on ohci1
    ohci2: <sis 5571="" usb="" controller="">mem 0xfeafd000-0xfeafdfff irq 22 at device 3.2 on pci0
    ohci2: [ITHREAD]
    usbus2: <sis 5571="" usb="" controller="">on ohci2
    ehci0: <ehci (generic)="" usb="" 2.0="" controller="">mem 0xfeafc000-0xfeafcfff irq 23 at device 3.3 on pci0
    ehci0: [ITHREAD]
    usbus3: EHCI version 1.0
    usbus3: <ehci (generic)="" usb="" 2.0="" controller="">on ehci0
    pcib2: <acpi pci-pci="" bridge="">at device 6.0 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pcib3: <acpi pci-pci="" bridge="">at device 7.0 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    atapci1: <sis 965="" udma133="" controller="">port 0xd000-0xd007,0xc800-0xc803,0xc400-0xc407,0xc000-0xc003,0xb800-0xb80f irq 17 at device 8.0 on pci0
    atapci1: [ITHREAD]
    ata2: <ata 0="" channel="">on atapci1
    ata2: [ITHREAD]
    ata3: <ata 1="" channel="">on atapci1
    ata3: [ITHREAD]
    em0: <intel(r) 1000="" pro="" legacy="" network="" connection="" 1.0.1="">port 0xb000-0xb03f mem 0xfeac0000-0xfeadffff,0xfeaa0000-0xfeabffff irq 17 at device 9.0 on pci0
    em0: [FILTER]
    em1: <intel(r) 1000="" pro="" legacy="" network="" connection="" 1.0.1="">port 0xa800-0xa83f mem 0xfea60000-0xfea7ffff,0xfea40000-0xfea5ffff irq 18 at device 10.0 on pci0
    em1: [FILTER]
    pcib4: <pci-pci bridge="">at device 31.0 on pci0
    pci4: <pci bus="">on pcib4
    acpi_button0: <power button="">on acpi0
    atrtc0: <at realtime="" clock="">port 0x70-0x71 irq 8 on acpi0
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    uart0: [FILTER]
    ppc0: <parallel port="">port 0x378-0x37f,0x778-0x77f irq 7 drq 3 on acpi0
    ppc0: Generic chipset (ECP/PS2/NIBBLE) in COMPATIBLE mode
    ppc0: FIFO with 16/16/16 bytes threshold
    ppc0: [ITHREAD]
    ppbus0: <parallel port="" bus="">on ppc0
    plip0: <plip network="" interface="">on ppbus0
    plip0: [ITHREAD]
    lpt0: <printer>on ppbus0
    lpt0: [ITHREAD]
    lpt0: Interrupt-driven port
    ppi0: <parallel i="" o="">on ppbus0
    pmtimer0 on isa0
    orm0: <isa option="" roms="">at iomem 0xc0000-0xc7fff,0xc8000-0xc8fff,0xc9000-0xc9fff pnpid ORM0000 on isa0
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    acpi_throttle0: <acpi cpu="" throttling="">on cpu0
    powernow0: <cooln'quiet k8="">on cpu0 Timecounter "TSC" frequency 1800074725 Hz quality 800 Timecounters tick every 1.000 msec IPsec: Initialized Security Association Processing. usbus0: 12Mbps Full Speed USB v1.0 usbus1: 12Mbps Full Speed USB v1.0 usbus2: 12Mbps Full Speed USB v1.0 usbus3: 480Mbps High Speed USB v2.0 acd0: CDROM <cd-rom ccd-52x6s="" ysg1="">at ata0-master UDMA33 ad4: DMA limited to UDMA33, device found non-ATA66 cable ad4: 76319MB <seagate st380815as="" 4.aab="">at ata2-master UDMA33 ugen0.1: <sis>at usbus0 uhub0: <sis 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus0 ugen1.1: <sis>at usbus1 uhub1: <sis 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus1 ugen2.1: <sis>at usbus2 uhub2: <sis 1="" 9="" ohci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus2 ugen3.1: <sis>at usbus3 uhub3: <sis 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus3 Root mount waiting for: usbus3 usbus2 usbus1 usbus0 uhub2: 2 ports with 2 removable, self powered uhub0: 3 ports with 3 removable, self powered uhub1: 3 ports with 3 removable, self powered Root mount waiting for: usbus3 Root mount waiting for: usbus3 Root mount waiting for: usbus3 uhub3: 8 ports with 8 removable, self powered Trying to mount root from ufs:/dev/ad4s1a ugen1.2: <american power="" conversion="">at usbus1 pflog0: promiscuous mode enabled em0: link state changed to UP pid 20968 (squid), uid 62: exited on signal 6 em1: promiscuous mode enabled em1: promiscuous mode disabled em1: promiscuous mode enabled</american></sis></sis></sis></sis></sis></sis></sis></sis></seagate></cd-rom></cooln'quiet></acpi></generic></system></isa></parallel></printer></plip></parallel></parallel></at></keyboard></at></power></pci></pci-pci></intel(r)></intel(r)></ata></ata></sis></acpi></acpi></acpi></acpi></ehci></ehci></sis></sis></sis></sis></sis></sis></multimedia,></ata></ata></sis></isa></pci-isa></vga-compatible></acpi></acpi></acpi></acpi></acpi></a></lahf></syscall,nx,mmx+,ffxsr,lm,3dnow!+,3dnow!></sse3></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,mmx,fxsr,sse,sse2>



  • Don't worry, be happy! I expect its just a reporting issue because SATA drives don't use the IDE cables.

    Its probably worth lodging a FreeBSD PR (Problem Report) at http://www.freebsd.org/send-pr.html inclding both FreeBSD 7.1 and FreeBSD 8.1 startup output.

    I expect this particular chipset is not particularly common which could make it a challenge for the developers to test a fix.


Log in to reply