Can't add static route



  • hello,

    pfSense 2.0-BETA4  (i386)built on Thu Sep 23 11:51:18 EDT 2010 FreeBSD 8.1-RELEASE-p1

    I can't add a static route: "A valid gateway must be specified"

    My network:

    ComputersLan1
                                                |172.16.0.x
                                                |(LAN1)
                                                |172.16.0.254
    MODEM–--------------------PFSENSE----------------NETWORK_CORE-----------------ComputersLan2
    192.168.0.254--192.168.0.251      10.0.0.254--10.0.0.253             172.17.0.0.254--172.17.0.0.x          
                    (WAN)                               (INTERCO)                                  (LAN2)

    Pfsense server have two networks card em0 and em1 connected to the Network-core with LAAG-LACP

    The 3 iface of pfsense are VLAN on the LAAG (laag0):
    WAN (DHCP and default gateway) 192.168.0.0/24
    LAN 172.16.0.0/24
    INTERCO 10.0.0.0/24

    I want to add a static route to join LAN2 (172.17.0.0/4)
    I had add a gateway:
    Interface: INTERCO
    name: Core
    Gateway: 10.0.0.253

    But when a want add the static route:
    Destination network: 172.17.0.0/24
    Gateway: i select  "Core - 10.0.0.253"

    I get: "A valid gateway must be specified"

    Thank in advance



  • Is this problem related to gateway problem that i had seen in
    others topic ?

    Thank



  • hi,

    Looks like the problem is specific to pfsense itself. What happens if you go to shell and add static manually using route command?

    cheers,



  • @nocer:

    hi,

    Looks like the problem is specific to pfsense itself. What happens if you go to shell and add static manually using route command?

    cheers,

    if i download the config, edit it to manually add the static route en upload the config, that work.



  • I can confirm this error. I have the following setup:

    Site 1----------------------- Site 2
     |                             |
    DNS at 192.168.11.123         Site2:Static route to 192.168.11.123 via LAN interface (Goes through IPSec)
    

    I get the same error "A valid gateway must be specified".
    Running an older version of pfSense on other hardware does not have this issue.

    Non-working version:
    2.0-BETA4  (i386)
    built on Mon Sep 27 05:13:14 EDT 2010
    FreeBSD 8.1-RELEASE-p1

    Working (old) version:
    2.0-BETA4  (i386)
    built on Sun Sep 5 18:43:23 EDT 2010
    FreeBSD 8.1-RELEASE


Log in to reply