Problem "Network interface mismatch"on pfSense Beta 2.0 while importing settings



  • Hello,

    first I would thank You for Your hard work on pfSense. I think it is very valuable software and I belive it will stay free.
    Ok let's explain my situation. I have up and running Qemu-kvm virtual environment, where one physical LAN port of Ubuntu Server hypervisor (without IP address in host system) is bridged to eth0 -> br0 –> re0, also eth0 -> br1 ->re1 of pfSense. This host-LAN-port is connected to the switch with 2 DSL modems connected.
    eth1 -> br2 -> re2 interface is bridge between LAN interface of the hypervisor and to LAN iface of pfSense.
    First, I installed pfSense stable version 1.2.3 and configured it to use Dual-WAN feature using this How-to:
    http://doc.pfsense.org/index.php/Multi_WAN_/_Load_Balancing
    Next, I used pfSense as gateway. Everything was working (I have 2 x 2048/256 kbit DSL links, I measured twice of this in tests), expect port forwarding to machine in LAN (but I think that I missed something in configuration).
    Then I discovered, that pfSense ver 1.2.3 can not handle QoS in Multi-WAN :(
    So I decided to upgrade to 2.0 BETA version and uploaded i386 file pfSense-Full-Update-2.0-BETA4-20101103-2125.gz to the router via webconfig.
    After reboot, again, everthing was fine until I decided to create CA certificate, private-key certificate and a firewall rule for WAN using this how-to:
    http://doc.pfsense.org/index.php/Remote_firewall_Administration
    I sucessfully created CA, private-key and checked option to use HTTPS instead of HTTP. I also checked some option about allow Webconsole from all interfaces..
    Then, I suddenly lost connection to pfSense and cannot connect anymore. When I connected via another router over VPN to hypervisor of pfSense I discovered "Network interface mismatch" message. So I reconfigured all network cards as they should be. But pfSense is asking me over and over about "Network interface mismatch" after message "Writing configuration... 1288906014ddone.", next try "Writing configuration... 1288906052ddone." .. I suppose main menu should appear, but this isn't happend. After reboot of pfSense same situation appears. Right now, I'm unable to enter console menu of pfSense.

    Screens attached.

    EDIT: I discovered that this also happend when importing XML setting file from pfSense 1.2.3 to 2.0 (latest i386 build in this case - pfSense-2.0-BETA4-20101104-0049.iso). Again, had to reinstall server to fix this, becouse "Network interface missmatch" appears after "Writing configuration..... done."





  • I'm going to compare XML from 1.2.3 with 2.0 and report results.

    EDIT: grabbed XML from 1.2.3 to text editor. Question: how does pfSense recognize missmatch of interface? Even I cannot find MAC adress there..

    
             <interfaces><lan><if>re2</if>
                            <ipaddr>192.168.1.1</ipaddr>
                            <subnet>24</subnet>
                             <media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan>
                     <wan><if>re0</if>
                             <mtu><ipaddr>82.x.x.x</ipaddr>
                            <subnet>1</subnet>
                            <gateway>82.x.x.x</gateway>
                            <blockpriv>on</blockpriv>
                            <blockbogons>on</blockbogons>
                             <disableftpproxy><dhcphostname><media><mediaopt><bandwidth>100</bandwidth>
                            <bandwidthtype>Mb</bandwidthtype>
                             <spoofmac></spoofmac></mediaopt></media></dhcphostname></disableftpproxy></mtu></wan>
                     <opt1><if>re1</if>
                            <descr>DSL2</descr>
                             <bridge><ipaddr>81.x.x.x</ipaddr>
                            <subnet>32</subnet>
                            <gateway>81.x.x.x</gateway>
                             <spoofmac><mtu><enable><disableftpproxy></disableftpproxy></enable></mtu></spoofmac></bridge></opt1></interfaces>  
             <staticroutes><route><interface>lan</interface>
                            <network>10.1.1.0/24</network></route></staticroutes> 
    

    EDIT: I successfully imported settings to 1.2.3, even if there was "Network interface mismatch" while importing. After router reboot it seems to be working - Welcome message appears, all interfaces have their IP.
    So assuming THERE IS PROBLEM with Beta 2.0 version while importing settings.


  • Rebel Alliance Developer Netgate

    The network interface matching is done by the network card device name. So in the config section you posted, it expects to find re0, re1, and re2. If it doesn't find one of these, it would say there was a mismatch.

    There are no current known issues with importing configurations to 2.0. There may be something specific in your config tripping the error, but it's hard to say without seeing the config at the point when the error occurred.

    If you were running OK and then changed a setting, and then saw the error, that could be different. It may be the change you made that caused a problem with the config, and the network interface mismatch was just a side effect of the real error.



  • Anyone else has problem with importing setting from 1.2.3 to 2.0? Please confirm. I'm still getting this.



  • I have problem with boot panic


  • Rebel Alliance Developer Netgate

    @TooMeeK:

    Anyone else has problem with importing setting from 1.2.3 to 2.0? Please confirm. I'm still getting this.

    Can you send me your config privately so I can run some tests with it, to see if it's something specific to your config?

    You can mail it to me at jimp (at) pfsense (dot) org

    @simby:

    I have problem with boot panic

    That has nothing to do with this thread. There are already threads for the boot panic issue on amd64.



  • I have this same problem.  A upgrade from 1.2.3 works fine upon the first boot, but once it finishes the upgrade if you reboot again then it comes up with the network interface mismatch each time.  If I install 2.0 and import the settings I'm getting the same interface mismatch.  I have not changed any settings before rebooting when the error comes up.  Even if I try to assign the interfaces after reboot it keeps in a loop with interface mismatch.

    Andy


  • Rebel Alliance Developer Netgate

    @geewhz01:

    I have this same problem.  A upgrade from 1.2.3 works fine upon the first boot, but once it finishes the upgrade if you reboot again then it comes up with the network interface mismatch each time.  If I install 2.0 and import the settings I'm getting the same interface mismatch.  I have not changed any settings before rebooting when the error comes up.  Even if I try to assign the interfaces after reboot it keeps in a loop with interface mismatch.

    Please e-mail me a copy of your 1.2.3 configuration so I can try to replicate the problem. Send it to jimp at pfsense . org.



  • @jimp:

    @geewhz01:

    I have this same problem.  A upgrade from 1.2.3 works fine upon the first boot, but once it finishes the upgrade if you reboot again then it comes up with the network interface mismatch each time.  If I install 2.0 and import the settings I'm getting the same interface mismatch.  I have not changed any settings before rebooting when the error comes up.  Even if I try to assign the interfaces after reboot it keeps in a loop with interface mismatch.

    Please e-mail me a copy of your 1.2.3 configuration so I can try to replicate the problem. Send it to jimp at pfsense . org.

    It has been sent.  If you need anything else please let me know.

    Thanks,
    Andy


  • Rebel Alliance Developer Netgate

    OK I think I fixed this.

    If you had the load balancer configured, the upgraded monitor IPs were accidentally getting created as interfaces. So the next reboot had interfaces that really didn't exist and had no physical hardware associated, so it believed there was a mismatch.

    Hopefully the next new snapshot dated after this post (note: Not the one building now, the one after it!) should include the fix.



  • Ok thanks.  I'll test tomorrow :).

    Thanks,

    Andy



  • Finally ;) hehe
    I hope my 1st post was helpfuly.



  • @geewhz01:

    Ok thanks.  I'll test tomorrow :).

    Thanks,

    Andy

    This is fixed for me.  THANKS!!!!


Log in to reply