A problem to set wan gateway



  • i install the pfsense to the harddrive. the computer has 2 interfaces ,fxp0 is wan fxp1 is lan.
    i set the static ip and gateway to the wan interface
    Static IP configuration
    IP address  218.10.111.189 /28
    Gateway  218.10.111.185
    and press save.
    then when i go to the  Diagnostics page ,and  Execute command ifconfig
    it reports :
    $ ifconfig
    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet6 fe80::210:5cff:feb3:a54e%fxp0 prefixlen 64 scopeid 0x1
    inet 218.10.111.189 netmask 0xfffffff0 broadcast 218.10.111.191
    ether 00:0d:87:bd:8e:f1
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    fxp1: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet 192.168.0.7 netmask 0xffffff00 broadcast 192.168.0.255
    inet6 fe80::290:27ff:fe7b:182d%fxp1 prefixlen 64 scopeid 0x2
    ether 00:90:27:7b:18:2d
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    pflog0: flags=100 <promisc>mtu 33208
    enc0: flags=0<> mtu 1536
    lo0: flags=8049 <up,loopback,running,multicast>mtu 16384
    inet 127.0.0.1 netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x5
    pfsync0: flags=41 <up,running>mtu 2020
    pfsync: syncdev: lo0 maxupd: 128

    in the fxp0 paragraph ,there is no route infomation!
    how dose this happen?
    thank you all</up,running></up,loopback,running,multicast></promisc></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast>



  • route get default

    But beware, multi wan from a shell most likely does not function how you think.  PF does multi wan.



  • Or from gui: diagnostics>routes



  • i fonud it in the Diagnostics>Route

    Diagnostics: Routing tables

    Name resolution  Enable
    Enable this to attempt to resolve names when displaying the tables.

    Note: By enabling name resolution, the query should take a bit longer. You can stop it at any time by clicking the Stop button in your browser.

    IPv4
    Destination Gateway Flags Refs Use Mtu Netif Expire
    default 218.10.111.185 UGS 0 2 1500 fxp0 
    127.0.0.1 127.0.0.1 UH 0 0 16384 lo0 
    192.168.0 link#2 UC 0 0 1500 fxp1 
    192.168.0.86 00:0d:87:bd:8e:f1 UHLW 1 193 1500 fxp1 1140

    it shows the gateway was correct.
    i halt the pfsense yesterday. and after i press the bottom to open it this morning , it works.


Locked