Schedule conflict with captive portal?


  • Hi all,

    I got a situation with my pfsense box. I have did some search in the forum and got no clues. I don't know it is a bug or I did something not correctly.

    The settings of my pfsense box is very simple. I use pfsense for NAT and use captive portal for gateway authorisation. Everything works fine before I add some scheduling rules to block some IP for certain times.

    Does anyone else got this situation also?

    Thanks
    Bill


  • when you disable the rules that have schedules with them, does the problem go away? If so then it is a schedule conflict.


  • @XIII:

    when you disable the rules that have schedules with them, does the problem go away? If so then it is a schedule conflict.

    Thank you for suggestion. I have not trying to diables the schedule rules. I did a reinstall and have not configure the schedule rules this time.

    Actually I have another two pfsense boxes. all of them run fine with captive portal and without schedule rules. And I have tried twice with captive portal and scheduling and all going wrong.


  • Can you be more specific on what is wrong?


  • Hi, I have the same problem.
    As soon as you define a schedule, the captive portal stops working: everyone bypasses it.
    Even if you don't use the schedule at all..

    You have to remove the schedule and reboot pfSense to get the captive portal working again.

    I found out that this is an old problem:
    http://sadsoftware.blogspot.com/2008/09/pfsense-captive-portal-with-firewall.html

    I'm using pfSense 1.2.3 on an Alix board, btw.


  • In 1.2.3 its not possible only 2.0 allows you to use schedules with CP.