Wan default gateway is link#2?



  • Last night I was having trouble from my ISP.

    I woke up this morning and it has connection latency issues, but once it connects to an actual site the speed is normal

    I looked at my interface status to try a release/renew and my default gateway says "link#2". Its always been the gateway IP

    plugged the modem directly into my PC and my gateway was the default gateway IP it usually would show on my router. Internet worked great without any latency issues

    any ideas? did a whole bunch of search for that string here and found nothing but refrences to ARP caches and such

    pfsense 1.2.3
    charter communications DFW ISP



  • well thank you the lack of help everyone

    I tried 2.0 RC1 and even though the interface rocks even more, it practically froze trying to load the interfaces page. it did say GW_WAN and the actual IP, but would not route. I'm not sure if I have to use some fresh settings or not.

    Ether way, I put this old airlink 101 mimo g and am having no issues at all

    pissed off long-time pfsense user, Paul


  • Netgate Administrator

    @Uranium-235:

    it practically froze trying to load the interfaces page

    What hardware are you running this on? Is that the first time you tried 2.0 (any version)?

    I read your previous post yesterday but had nothing to offer. I guess I could have posted for moral support!  ::)

    Steve



  • well i'm just wondering if you've ever heard of such a thing. link#2

    hardware: re-capped Epox K7G-Raid with 1ghz tbird and 512M ECC/REG memory. Two Dlink 530TX's, one atheros card I forget the name of. ruining on a CF CARD Been running flawlessly till just few nights ago when I first made this post

    yes its the first time I tried 2.0. I reloaded my old settings from the xml file from original pfsense, was that a nono?


  • Netgate Administrator

    You should be able to use your config file from 1.2.3 however there does seem to be some issues.
    There is a problem with illegal characters. The config file for 2.0 cannot contain some characters and if it does it won't be read correctly so if you had an odd name for one of your interfaces or aliases that could explain it.

    Steve



  • thank you, i'll see if I can get it working tomorrow



  • ok I got 2.0 installed, and after struggling with it, I realized I had a partially bum network card

    but I am still having troubles. One is I can't get wifi working without creating a bridge. I made the outgoing rules, and made the firewall rule like I would with 1.2.3 but it still does not work, though lan works good

    and a very strange thing happened. I can't access admin with firefox. On my wired lan I can't get it with chrome, IE, but it times out with firefox

    does the same thing when I try to access it on my laptop with wireless when they're bridged, it works in IE just fine. if I try to use it in firefox, it just times out. I switched to HTTP instead of SSL and it still does the same thing. does anyone have any idea?



  • Are you using https-connection? have you deleted the old certificate?



  • at first I thought that was it, but I switched it over to http and it still does the same thing



  • Then you'll have to wait until the smarter one's can help you


  • Netgate Administrator

    You've tried from two different machines?
    Same version of Firefox?

    Weird!  :-\



  • yup. One my desktop, on lan
    other laptop on wlan

    same version of firefox on each one, IE and chrome accesses it great (and yes I checked proxy settings too, all no proxy)

    well thank you everyone for hanging in there with me, but in the end this p-i-t-a attempt at 2.0 ultimately kicked my ass. I put a kne and a lne card (both dc driver) and even though it gives me this wierd thing about setting dc1 tx idle mode, it still works, loaded my old xml file and everything is working great under 1.2.3. keep up the good work and I hope that you can make things under 2.0 a little easier cause I could never get two seperate outgoing nat rules working even after adding the same nat and fw rules I would under 1.2.3


  • Netgate Administrator

    A bit late now but just for reference 'link#2' appears to be how pfsense refers to interfaces in the routing table. See image. It shouldn't be your default gateway though.

    Steve

    ![routing table.jpg](/public/imported_attachments/1/routing table.jpg)
    ![routing table.jpg_thumb](/public/imported_attachments/1/routing table.jpg_thumb)



  • well it 'twas, even after a full reload with 1.2.3. not sure how that partially bad nic caused it



  • well I finally figured the problem out. Wasn't a bad nic. I could ping google from wan, lan and wlan, but could not access with computers on each *lan. so, I reset my settings from scratch and started over, works great now

    the internal routing mechanism stopped working right. Never sure what exactly was wrong, but somehow pfsense internally f'd up enough to partially route intermittently.


Log in to reply