2.0-RC1 fix ?



  • 2.0-RC1-i386-20110314

    Intel® 82546EB dual-channel Gigabit Ethernet

    Watchdog timeout – resetting  on all March 2.0-RC1 snapshots updated to 2.0-RC1-i386-20110314 still around.

    I was getting Watchdog timeout -- resetting on the wan and now with the last 2 update it is no longer

    happening on the wan it is now happening on the Lan

    ? is the Watchdog timeout -- resetting issue going to be fix in the new snapshot rc1

    or if their is a fix for it ?

    I am not having this issues on the other identical servers with the 2.0 beta build or 1.2.3

    I tried the 2.0-RC1-i386-20110314 on the other servers and got the Watchdog timeout -- resetting



  • This started happening after 3/2/11 once the RC1's started using the yandex em drivers.  I believe its cosmetic but it sure is annoying.  I've been holding onto my 3/1/11 RC1 snapshot because it uses the previous em driver and because it doesnt have the ntpd issue as well.  I havent seen many commits lately except for ipv6 and it looks like the ntpd and yandex issues have a low priority in the pfsense bugtracker.


  • Rebel Alliance Developer Netgate

    The watchdog issue is annoying and largely cosmetic (though others have reported issues) but we're trying to find a good way around it. We will probably move away from the yandex drivers in the near future, but we're trying to figure out where (back to what we had or to an updated version of the driver from FreeBSD -stable or -current).

    Not sure about the ntpd thing, I've seen the ticket on it but I'm not sure if anyone has tracked down exactly which commit introduced the issue.



  • @jimp:

    We will probably move away from the yandex drivers in the near future, but we're trying to figure out where (back to what we had or to an updated version of the driver from FreeBSD -stable or -current).

    Yeeouch! I had terrible performance on a certain build before switching to Yandex.


  • Rebel Alliance Developer Netgate

    Were the RC1 builds OK? If so, those had no Yandex drivers. Some people have connectivity issues and traffic accounting issues (and the watchdog issues) and other things with the Yandex drivers, and they didn't fix the problems we originally hoped they would.



  • http://marc.info/?l=pfsense-support&m=129903385420047&w=2

    http://marc.info/?l=pfsense-support&m=129913331924304&w=2

    To summarize, I was the OP in that thread. Routing performance in the March 1 RC snap was poorer than expected, and inconsistent. Then on the March 4 RC snap routing performance improved to the expected level, and Seth Mos indicated that the Yandex driver had just gone into the builds.

    I had no other issues with that system, except maybe mbuf leaks. I no longer have access to it.



  • Any build I've used after March 3rd has giving me a couple of issues. Mostly with the LCDproc package sockets timing out after a reboot. Restart the service and it works like it did before. I have to do this with every 'reset of states' also..And I have the NTPd issue. When using the build right before the Yandex drivers were added, no issues.

    Since i'm testing the IPv6 code, I ended up using the pfSense-2.0-RC1-ipv6-i386-20110228-1715.iso.gz image and gitsync as updates are added, mostly after a mainline merge to smos git.

    I've heard of some performance issues with RC1 but I haven't experience any as I'm routing over a 50/5 cable link.





  • NTPD seems to be fixed but I'm still getting the watchdog messages on the 3/19 RC1 snapshot

    
    Mar 20 05:27:03 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (aaa.bbb.ccc.ddd)
    Mar 20 05:27:03 	check_reload_status: Linkup starting em0
    Mar 20 05:27:03 	kernel: em0: link state changed to UP
    Mar 20 05:27:01 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (aaa.bbb.ccc.ddd)
    Mar 20 05:27:00 	check_reload_status: Linkup starting em0
    Mar 20 05:27:00 	kernel: em0: link state changed to DOWN
    Mar 20 05:27:00 	kernel: em0: Watchdog timeout -- resetting
    Mar 20 05:23:33 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (aaa.bbb.ccc.ddd)
    Mar 20 05:23:33 	kernel: em0: link state changed to UP
    Mar 20 05:23:33 	check_reload_status: Linkup starting em0
    Mar 20 05:23:31 	php: : Hotplug event detected for lan but ignoring since interface is configured with static IP (aaa.bbb.ccc.ddd)
    Mar 20 05:23:30 	check_reload_status: Linkup starting em0
    
    

    Edit:  OK, looking good with the snap from the 20th.



  • Hello,

    I'm using a Jasomi 7650 (alias Lanner FW 7650 - [network: Intel 82540EM and Intel 82551QM])

    with Pfsense 2.0-RC1 (i386) built on Sun Mar 20 02:20:38 EDT 2011

    and have the same problem :

    Mar 21 18:52:12 	php: : Hotplug event detected for opt4 but ignoring since interface is configured with static IP (192.168.5.1)
    Mar 21 18:52:12 	kernel: em0: link state changed to UP
    Mar 21 18:52:12 	check_reload_status: Linkup starting em0
    Mar 21 18:52:09 	php: : Hotplug event detected for opt4 but ignoring since interface is configured with static IP (192.168.5.1)
    Mar 21 18:52:09 	kernel: em0: link state changed to DOWN
    Mar 21 18:52:09 	kernel: em0: Watchdog timeout -- resetting
    Mar 21 18:52:09 	check_reload_status: Linkup starting em0
    Mar 21 18:45:02 	php: : Hotplug event detected for opt4 but ignoring since interface is configured with static IP (192.168.5.1)
    Mar 21 18:45:01 	kernel: em0: link state changed to UP
    Mar 21 18:45:01 	check_reload_status: Linkup starting em0
    Mar 21 18:44:59 	php: : Hotplug event detected for opt4 but ignoring since interface is configured with static IP (192.168.5.1)
    Mar 21 18:44:58 	check_reload_status: Linkup starting em0
    Mar 21 18:44:58 	kernel: em0: link state changed to DOWN
    

    just to complet the informations …



  • Estragon, this was fixed, upgrade to a newer snap.



  • @onhel:

    Estragon, this was fixed, upgrade to a newer snap.

    the EM watchdog errors are fixed now?



  • Yes, I used the 3/20 update snapshot 1657 and my em's are running without error.



  • hello,
    I go on the newer snap
    2.0-RC1 (i386) built on Tue Mar 22 01:13:42 EDT 2011
    and no more watchdog issue … (my system log entries is now so depopulate  ::))

    incidentally, from some snap install I need to reboot after the installation in the way that the Wan interface can acquire the IP from DHCP, and these issue seam's to be resolved too ...

    many tanks  :)



  • yandex drivers are out now so no more guarddogs

    were the yandex supposed to be better performance?


Locked