PPPoE server in PfSense 2.0RC1 - trouble with gateway



  • Hi all,
    i'm a PfSense half-newbie and i'm using 2.0RC1 version updated because i have to use Layer7 and traffic shaping.
    I need to configure a PPPoE server w/o Radius server.
    This is my network configuration:

    WAN: public IP (1.2.3.4)
    LAN: private IP (192.168.1.1)

    I've created a PPPoE configuration:

    Interface: LAN
    Subnet: 24
    No. PPPoE users: 10
    Server address: 192.168.10.1
    Remote address range: 192.168.100.1

    I've also created a test user with pre-assigned IP (192.168.100.150).

    This configuration works as PPPoE. The user (with Windows 7) invoke PPPoE server using Microsoft PPPoE client and Windows 7 receive the IP (192.168.100.150) and DNS (the public DNS and the private DNS -192.168.1.1-).
    But, strange but true, the gateway.

    What i have to do ?



  • I've tried to make a PPPoE server with PfSense 1.2.3 (as described here: http://opuntia.biz/2011/04/02/configurazione-di-un-server-pppoe-su-pfsense/).
    I've tried too to make the same steps in PfSense with no result.
    I suppose that the problem is on 2.0RC1 firewall or Nat rule.
    Do you have experience with PPPoE Server working and PfSense 2.0RC1 ?


  • Rebel Alliance Developer Netgate

    There is an open ticket for the PPPoE server in 2.0 right now because it's not 100% working. The firewall rules aren't properly added yet. It's a known issue. (And there are other threads already open for it as well)


Log in to reply