Captative Portal & Bridge



  • Hi,

    I could need some help on this setup, so first I want to show you my topology:

    WAN<–vr0-->PFSENSE(Alix)
    LAPTOP <--WLAN--> FRITZBOX<--vr1-->PFSENSE(Alix)
    LAN<--vr2-->PFSENSE(Alix)

    So I have internet on vr0, a LAN on vr2, and a Fritzbox on vr1 with a laptop connected to it using Fritzbox Wlan.

    What I would like to have is that all WLAN guests have to login via captative portal.
    Thus I created a bridge on vr0, vr1 and vr2. Heres the first thing that I noticed, when I change the bridge config, e.g. that it just runs on vr0 and vr2,
    I sometimes can't ping to the Internet from my laptop... but when I then restart pfsense, it works again.

    So after restart, the bridge seems to work... I then created a VLAN on vr1, and on this VLAN-connection a new Interface called OPT1.
    This I want to run the captative portal on. So my Idea was to have an interface which captative portal needs for running. This interface is based on a virtual
    VLAN connection, which is finally bridged to my LAN and WAN.

    Problem is... it doesn't work ;)
    Does anybody have a hint on what's wrong in this setup - or even better have an easier idea or solution ?



  • In addition, I got these errors:

    php: : There were error(s) loading the rules: /tmp/rules.debug:46: syntax error /tmp/rules.debug:47: syntax error pfctl: Syntax error in config file: pf rules not loaded - The line in question reads [46]: nat on $WAN from $tonatsubnets port 500 to any port 500 -> 77.0.204.115/32 port 500

    Thanks a lot for your help!

    Juel


Log in to reply