Inetd[273]: 19112/tcp: bind: Can't assign requested address



  • Hi all,
    I have been using pfsense some time now, and over all I'm very happy with it. I have had some traffic shaping problems but I think that is solved now (hopefully). Any way, the question I now have is about a log entry I gat over and over in the System log.
    Every 10th minute I get 4 entries of the following text:
    inetd[273]: 19112/tcp: bind: Can't assign requested address

    I have searched the forum for some hints but have not been able to find any answer what to do.

    If anyone have any ideas please let me know, I have probably forgot something somewhere. :)
    Let me know what information you need (logs, configuration files, whatever) and I'll post it…

    I forgot to enter my setup. :)
    Here it goes.
    PIII 733Mhz, 512Mb Ram, 6 Gb disk.
    3 Nics WAN, LAN, OPT1. (OPT1 not yet used).
    pfSense 1.0-Beta 1
    No packets installed.

    Thank you all for a very good Firewall!



  • @Snille:

    Hi all,
    I have been using pfsense some time now, and over all I'm very happy with it. I have had some traffic shaping problems but I think that is solved now (hopefully). Any way, the question I now have is about a log entry I gat over and over in the System log.
    Every 10th minute I get 4 entries of the following text:
    inetd[273]: 19112/tcp: bind: Can't assign requested address

    I have searched the forum for some hints but have not been able to find any answer what to do.

    If anyone have any ideas please let me know, I have probably forgot something somewhere. :)
    Let me know what information you need (logs, configuration files, whatever) and I'll post it…

    I forgot to enter my setup. :)
    Here it goes.
    PIII 733Mhz, 512Mb Ram, 6 Gb disk.
    3 Nics WAN, LAN, OPT1. (OPT1 not yet used).
    pfSense 1.0-Beta 1
    No packets installed.

    Thank you all for a very good Firewall!

    Interesting, sounds like "Reflection"…if you have no need to use the WAN IP of your machine from the LAN to access Port Forwards, then I'd suggest disabling Reflection in "System->Advanced".

    In the meantime, is anyone else seeing this?  Also, can you go to Diagnostics: Edit File select /etc/inetd.conf and paste it's contents here? I'd like to make sure that all the entries look right.  Thanks

    --Bill



  • Reinstall and that will go away.



  • sullrich:
    Ok, reinstall I will.
    Can I still "reload" my old configuration file when I have reinstalled, or will the error come back if I do?
    I have a lot of rules entered in Alias, NAT, Rules, and the Traffic shaper. :/

    billm:
    I need the "Reflection", I'm using my own "site" allot from inside the LAN. In fact that was the "last" reasons that made me switch to pfSense in the first place. The possibility to reach my own site from the inside without having to use hostfiles on my LAN computers is great! :)



  • Basically you should be able to reimport your config. However we are trying to sort bugs out by only accepting them if the bug happens with a fresh install AND with a configuration from scratch. The nat-reflection option is only a single flag in the config.xml, so it shouldn't bring back this problem (unless they were caused by the nat's that exist in the config.xml). Depending on how old this config.xml is (in versions) I would say give it a try and if it doesn't work recreate it from sratch  ;)



  • i don't see it here i have Reflection on
    using beta1 iso
    inetd.conf:
    ftp-proxy stream tcp nowait root /usr/lib/libexec/ftp-proxy ftp-proxy -D0 -m 55000 -M 57000 -t 180 -u proxy



  • Hi everybody and a happy new year  :)

    I just started to use pfsense and I have fresh pfsense beta1 installation and I have exactly the same problem. This is my setup:

    Dual PII 300 Mhz
    128 Mb RAM
    600 Mb hard drive (yes, I know it's small but enough for now)
    3 NIC (WAN, LAN and OPT1)
    pfSense 1.0-Beta 1

    and that's all. Just a basic install without any extra configuration.

    From m0nowall website I found documentation how to configure portforwarding for bittorrent. Documentation is here:

    http://doc.m0n0.ch/handbook/thirdparty-bittorrent.html

    and that's how I did it. Bittorrent works but that error message puzzles me. This is the exact error message:

    inetd[6055]: 19001/tcp: bind: Can't assign requested address
    inetd[6055]: 19000/tcp: bind: Can't assign requested address

    I tried to change reflection to disabled but that didn't help and my /etc/inetd.conf is:

    ftp-proxy stream tcp nowait root /usr/lib/libexec/ftp-proxy ftp-proxy -D0 -m 55000 -M 57000 -t 180 -u proxy

    TIA


    palo



  • When you see this message, please run ps awux | grep inetd and see if inetd is already running.  We may be trying to start it overtop the other running process.  Checks are there to look for this, but bugs happen.



  • ps awux | grep inetd

    root    6055  0.0  0.9  1436  1088  ??  INs  4:58PM  0:00.43 /usr/sbin/inetd -a 127.0.0.1 /var/etc/inetd.conf
    root    13299  0.0  0.8  1456  952  p0  RL+  11:29PM  0:00.01 grep inetd

    Is that /var/etc/inetd.conf correct ? Should it be /etc/inetd.conf ?

    ls -l /var/etc/inetd.conf

    ls: /var/etc/inetd.conf: No such file or directory

    ls -l /etc/inetd.conf

    -rw-r–r--  1 root  wheel  108 Dec 26 05:18 /etc/inetd.conf

    Btw, it happens every 10 minutes:

    Jan 1 23:18:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address


    palo



  • @palo:

    ps awux | grep inetd

    root    6055  0.0  0.9  1436  1088  ??  INs  4:58PM  0:00.43 /usr/sbin/inetd -a 127.0.0.1 /var/etc/inetd.conf
    root    13299  0.0  0.8  1456  952  p0  RL+  11:29PM  0:00.01 grep inetd

    Is that /var/etc/inetd.conf correct ? Should it be /etc/inetd.conf ?

    Nope.

    ls -la /var/etc/inetd.conf

    -rw-r–r--  1 root  wheel  17949 Dec 31 23:15 /var/etc/inetd.conf

    @palo:

    ls -l /var/etc/inetd.conf

    ls: /var/etc/inetd.conf: No such file or directory

    ls -l /etc/inetd.conf

    -rw-r–r--  1 root  wheel  108 Dec 26 05:18 /etc/inetd.conf

    Btw, it happens every 10 minutes:

    Jan 1 23:18:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:18:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 23:08:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19000/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address
    Jan 1 22:58:51 inetd[6055]: 19001/tcp: bind: Can't assign requested address


    palo

    Every 10 minutes!?  I don't see how this is possible.  Do you not have any redirects in place?



  • in /var/etc there is no inetd.conf

    ls -la /var/etc/

    total 30
    drwxr-xr-x  3 root  wheel  512 Jan  2 03:44 .
    drwxr-xr-x  12 root  wheel  512 Dec 27 09:54 ..
    -rw-r–r--  1 root  wheel    17 Jan  2 03:44 defaultdomain.conf
    -rw-r--r--  1 root  wheel    55 Jan  1 15:44 dhclient_wan.conf
    -rw-r--r--  1 root  wheel  321 Jan  1 15:44 dhcpd.conf
    -rw-r--r--  1 root  wheel  103 Jan  1 15:44 hosts
    -rw-r--r--  1 root  wheel  5115 Jan  1 15:44 lighty-webConfigurator.conf
    drwxr-xr-x  2 root  wheel  512 Dec 27 10:12 mpd-vpn
    -rw-r--r--  1 root  wheel    43 Jan  2 03:44 nameserver_vr0
    -rw-r--r--  1 root  wheel    43 Jan  2 03:44 nameservers.conf
    -rw-r--r--  1 root  wheel  192 Jan  2 03:44 resolv.conf
    -rw-------  1 root  wheel    0 Jan  2 03:44 sasyncd.conf
    -rw-r--r--  1 root  wheel    0 Jan  1 15:44 slbd.conf
    -rw-rw-rw-  1 root  wheel  850 Dec 29 23:08 snmpd.conf
    -rw-r--r--  1 root  wheel  836 Jan  1 15:44 syslog.conf



  • Today I recreated that bittorrent portforwarding rule which I made yesterday and it seems that problem is gone. I don't have any idea what might cause that error message but everything seems to work ok right now. Well, I still don't have /var/etc/inetd.conf file but if everything works, I don't care.


    palo



  • I got the same error on a fresh installation of 1beta. Disabling reflection didnt help - deleting all NAT and Firewall rules didnt help ( didnt reboot though ). Finally I made a new  NAT port forward rule ( and the auto firewall at the same time ) AND rebooted the system. Problem went away…

    The only thing that I did differently the first time was that after creating the port forward rule...

    1 - I forgot that I needed UDP protocoll too so edited the NAT rule AND firewall rule to include that.
    2 - Edited them again a second time to remove ip and ad an Alias instead.

    How about the other guys who got this error message and then made it go away by making a fresh new rule. Maybe there is a bug with EDITING rules. I will try and mess with it some more tomorrow to see if I can get the error back. Need to hit the sack now though :)

    /DaK/



  • This is hopefully fixed in beta 2.



  • Now im getting something like this when running torrent software "inetd[348]: accept (for 19000): Software caused connection abort" but I suspect this is cuz I have forwarded one port only and torrents want a number of them to work well…

    Anyway I wanted to ask what log readers you guys are using?

    /DaK/



  • I also (still, after a clean install and setting up all the rules again) get the same error.
    inetd[366]: accept (for 19000): Software caused connection abort

    Are you sure this is due to only forwarding one port for torrent even when the torrent program says it only needs one?



  • Click System -> Advanced -> Disable Reflection



  • Isn't the "reflection" the function in the firewall that let "me" (inside the lan) surf to my own dns name without having to actually go out and back in again (or to be in need of a host file, or an internal DNS)?

    Anyway, is this a serious error? Or just an annoying thing filling up the log? :)



  • Yes that is the function that allows you access it from internal.  It looks like something is connecting and aborting the connect often.


Locked