Help.. RC3 Upgrade failed. How do I recover?

  • Hi all,

    I just upgraded this morning from RC2 (not sure which build) to the June 27th release of RC3.  On reboot, I get the following error:

    Configuring firewall.. Segmentation fault (core dumped)

    At this point, I can not even ping the LAN interface from my management workstation (let alone access the webgui).

    What are my options for recovery at this point?



  • Well, after a reboot I can ping the LAN IP address.  If I restart the webconfigurator from the console, I can then access the webgui.  The config looks OK.  But, I have no connectivity to the Internet.  I tried backing up the config and restoring it.  But, same result on reboot.  I'm going to try installing an older firmware and see what happens.

  • Well, I couldn't get the firmware re-installed no matter what way I tried.  So it looks like a re-install…. I should have known better to attempt an upgrade when I was scheduled to go production today...

  • FYI:

    I was able to reset to default via the console and get back running.  However, I had 2 different backup config files.  (One from a week prior to the upgrade and one from after the failed upgrade).  When restoring the config from after the failed upgrade, I got the same results.  When restoring the original config, I did not receive any errors, but I had no Internet connectivity.  I ended up redoing the config from scratch and it seems to be working now.

  • Rebel Alliance Developer Netgate

    Do you still have the broken configuration files? (Before and after the upgrade)

    If so, e-mail them to me - jimp (a) pfsense {dot} org

    I'd like to look them over to see if there might be a problem somewhere in the upgrade code.

  • jimp,

    Email sent…


Log in to reply