PPPoE WAN fails to reconnect



  • cat /tmp/pfSense_version

    Wed Aug 24 11:09:10 EDT 2011

    2.0-RC3 (amd64)
    built on Fri Aug 12 15:32:25 EDT 2011
    Platform nanobsd (2g)

    I recently acquired a backup WAN and I've been testing failover. My primary WAN is PPPoE (multilink on vlans) and when I pull the plug on the modem-connected pfsense interface failover kicks in nicely.

    The problem is when I plug the modem-connected interface back in. pfsense is never able to reestablish a pppoe connection until I reboot it. The PPP log shows persistent repeated connection attempts on all modem interfaces, but they all time out. I tried disabling then reenabling the WAN interface, but subsequent pppoe connection attempts still fail. Rebooting pfsense brings up all pppoe sessions nearly instantly, as expected.

    I believe this is a bug.



  • Having only a single wan, so i'm not able to say how this work, but does it seem that pfsense is not trying to monitor primary wan after failover state?



  • I do see connection reattempts in the PPP log though. I'll post them next time this happens.



  • this is an old issue related to mpd and many others and i have reported it but i guess the developers are not able to reproduce so no1 seems to be working on it to fix it



  • here is the long thread on the same matter, no fix for it, its since 2.0 and when mpd was upgraded to 5 which has made pfsense 2.0 very unreliable for me regarding pppoe only, rest all work fine, older mopd used to be brillant and no matter a power failure, cable unplug or any other situation, pppoe used to reconnect in a single attempt without issues.

    http://forum.pfsense.org/index.php/topic,35475.0.html


Log in to reply