Stge nic



  • stge not work in  v2 nanoversion.

    
    none0@pci0:0:14:0:	class=0x020000 card=0x81801043 chip=0x102313f0 rev=0x41 hdr=0x00
        class      = network
        subclass   = ethernet
    
    

    stge work in full install version  normal

    
    Sep 27 15:38:38 openbsd kernel: stge0: <sundance st-1023="" gigabit="" ethernet="">port 0x1400-0x14ff mem 0x44300000-0x443000ff irq 10 at device 14.0 on pci0
    Sep 27 15:38:38 kernel: miibus1: <mii bus="">on stge0
    Sep 27 15:38:38 kernel: ip1000phy0: <ic 10="" 100="" 1000="" plus="" media="" interface="">PHY 24 on miibus1
    Sep 27 15:38:38 kernel: ip1000phy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, 1000baseT, 1000baseT-FDX, auto
    Sep 27 15:38:38 kernel: stge0: [ITHREAD]</ic></mii></sundance> 
    

  • Rebel Alliance Developer Netgate

    Try downloading this and putting it in /boot/modules/

    http://files.pfsense.org/jimp/ko-8.1/i386/if_stge.ko

    (if you're on amd64, put that in the url instead of i386)

    Then add if_stge_load="YES" to /boot/loader.conf.local



  • Please include stge driver in base system.
    After this procedure nic is up and recognized.

    
    stge0@pci0:0:14:0:	class=0x020000 card=0x81801043 chip=0x102313f0 rev=0x41 hdr=0x00
        class      = network
        subclass   = ethernet
    
    
    
    stge0: flags=108843 <up,broadcast,running,simplex,multicast,ipfw_filter>metric 0 mtu 1500
    	options=8209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate>ether 00:1d:60:5c:xx:yy
    	inet 192.168.0.254 netmask 0xffffff00 broadcast 192.168.0.255
    	inet6 fe80::21d:60ff:fe5c:e576%stge0 prefixlen 64 scopeid 0x2 
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (1000baseT <full-duplex,flag0,flag2>)
    	status: active</full-duplex,flag0,flag2></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic,linkstate></up,broadcast,running,simplex,multicast,ipfw_filter> 
    

    ~20 MBits/sec on my old P2

    
    last pid: 51498;  load averages:  0.21,  0.10,  0.08                                                                            up 0+00:14:48  14:04:53
    86 processes:  3 running, 70 sleeping, 13 waiting
    CPU: 12.1% user,  0.0% nice,  8.2% system, 27.6% interrupt, 52.1% idle
    Mem: 37M Active, 19M Inact, 36M Wired, 30M Buf, 111M Free
    Swap: 
    
      PID USERNAME  PRI NICE   SIZE    RES STATE    TIME   WCPU COMMAND
       10 root      171 ki31     0K     8K RUN     11:29 42.97% idle
       11 root      -68    -     0K   112K WAIT     0:43 25.98% {irq11: fxp0}
       11 root      -68    -     0K   112K RUN      0:36 21.97% {irq10: stge0}
    
    

Locked