Intallation onto Transcend IDE Flash



  • Hi,

    I'm fairly new to PFSense, having tried it over the last couple of weeks on a test platform.  I'm looking to use it to replace several FreeBSD firewalls I have here on campus.  The existing machines work well using IPFilter, but I want to replace them with something that has a strong web GUI for those who work here who may not know FreeBSD as well as I do.

    I have installed 1.0.1 onto a Dell Optiplex GX260 (P4 2.5GHz 512MB) with no issues using an IDE hard drive, and Intel network cards.  So far, I really like what I see.

    Here is the problem I am having:

    I want to replace the IDE hard drive with a Transcend 4GB IDE flash module.  (http://ec.transcendusa.com/product/ItemDetail.asp?ItemID=TS4GDOM40V)    This is because I have had hard drive failures in the past that I just don't want to deal with anymore.  I understand that flash drives still fail, but if I don't use swap space, I'll feel better about not having moving parts.

    I've booted off the CD, and been able to get the network cards configured with no problem.  When I go into the installation screens, I see the flash drive no problem, and I am able to partition and format the disk.  I can then install the bootblocks, and create the slices on the disk, and run newfs on them.  The problem comes when I go to install the system.  It gets about 41% of the way through the                                              cpdup process, and just hangs at "/usr/local/bin/cpdup -vvv -I -o /usr /mnt/usr".  Eventually after hanging for quite a while, the system reboots automatically with only part of the pfsense install.

    Am I having hardware support issues here, or is there something different that I have to do when using a flash disk?  If I have to, I'll stay with a regular hard drive, but I would love to get into this IDE Flash.

    Thanks in advance.



  • Try the latest snapshot. It runs a newer freebsd. maybe that version works better for you.



  • Well, so far I've disabled DMA, and ACPI, still get basically the same result.  I'm loading the snapshot from April 05 2007 and right now it's hanging even earlier (/mnt/etc).  I'll keep playing with this more tomorrow morning.



  • Quite a few people using flash memory instead of hard disks for the same reasons. However that is a very large memory.

    I have had success with old 128 and 256MB's CF memory using PCI to flash adapters. Had problems getting a high speed (it was 10x or maybe 14x ?) memory recognised but you seem to be past that stage.



  • Well, heres a little bit of an update, but I'm no closer to having an install done.

    I used the snapshot that says its from 3-27-2007.  I get to the boot menu and exit that to get to a prompt.  I type:

    unset acpi_load
    set hint.acpi.0.disabled=1
    set hw.ata.ata_dma=0
    set hw.ata.atapi_dma=0
    boot

    It then boots into the install, and I format the disk, etc….  It now gets to 62%, albeit very slowly.  I get hard drive activity, and the CDROM drive reads very slowly, but it is installing.  It takes several minutes to get to that point.  Once it hits 62%, it just reboots on its own.  That's better than 41%, but not 100%.

    I have also tried making smaller partitions to see if that matters, but it doesnt seem to.

    I'm stumped.



  • Did you try turning off DMA , unwanted floppies, SCSIs etc in the BIOS?



  • @sai:

    Did you try turning off DMA , unwanted floppies, SCSIs etc in the BIOS?

    As far as I could tell, everything in the BIOS was off.  At one point, I even turned off the IDE controller accidentally.  I'm kind of at a loss.  My next step is to try a different model motherboard to make sure it's not an inconsistency there.  Right now the machine is running 1.0.1 on the Quantum HDD, so at least I have something.



  • You only disabled these settings in the bios? Did you try to disable them from the kernel on bootup? See http://wiki.pfsense.com/wikka.php?wakka=BootOptions how to do this.



  • @hoba:

    You only disabled these settings in the bios? Did you try to disable them from the kernel on bootup? See http://wiki.pfsense.com/wikka.php?wakka=BootOptions how to do this.

    Do you mean something other than what the OP wrote in reply #4?  Looks like he covered that to me.



  • Oops, sorry, missed that post in between. Sometimes it's hard to follow threads if they have become a bit longer and you try to read/answer all of them  ;)



  • Thanks to those who have helped out so far.

    I don't know if what I just did is good news or not:

    I put the flash card in a Dell GX110 instead, and did an installation onto the flash card.  It took a little time, but it went through without a problem.

    I took that flash card, and put it back into the GX260 and it booted up.  I walked away from it for a little while, and I had the following message on the screen when I came back.

    ad0: timeout - write_DMA retrying (1 Retry Left) LBA=5665679

    I'm thinking the GX260 doesn't like something about the flash card, or something is still enabled in the BIOS that I don't see.

    I rebooted the GX260 with the flash card and disabled the DMA and ACPI again.  I'm gonna keep watching it and see if the error comes back.


Log in to reply