All but one of my computers can route over to my other subnet.



  • I have 20+ systems and they all can access the other subnet just fine. I picked up 3 new aspire S3 notebooks and the 2 work fine but the 3rd cannot access the resources on the other subnet. After reloading windows 7 and drivers with no change, I went out an picked up another Aspire S3. Now with the new Aspire i have the same problem. If i replace the PFsense 10.0.2.1 with a basic linksys router the Aspire notebook that dose not work starts working. So I know that the Cisco and the PFsense 10.0.1.1 boxes are working fine, it must be the pfsense 10.0.2.1 box thats the problem.

    Here is my network setup.

    Acer 10.0.2.100 –> PFsense router LAN 10.0.2.1 --> Cisco router 10.0.2.2 --> WAN MPLS network --> Cisco Router 10.0.1.2--> PFsense LAN 10.0.1.1 --> server 10.0.1.10

    I can ping the server and tracert to the server but i cannot access the server resources (file shares, website)

    PFsense 10.0.2.1: route setting 10.0.1.0 to 10.0.2.2

    PFsense 10.0.1.1: route setting 10.0.2.0 to 10.0.1.2



  • check pfsense Subnet mask u can set /8 for full subnet



  • Have you tried disabling the firewall in Windows entirely?



  • Windows firewall on/off no change



  • f you can ping and tracert the destination and have no ports blocked in firewall rules and other clients from the same network/location/subnet work ….

    then i'm guessing the destination is blocking access, i highly doubt this has anything todo with pfsense

    check if your 'server' does not block that client, or if you have an ip-conflict (multiple devices with same ip)



  • The server does not block acces i tested that.  If i take my pfsesne box 10.0.2.1 out and replace it with a linksys basic router then my notebook connects just fine to the server. I also reloaded my firewall box with pfsense 2.0 (to make sure 201 was not the problem) and only changed the LAN ip and added 1 route statement to the base config and my notebook still cannot connect. What strainge is that i have now 4 of the same notebooks with windows 7 base install. The first 2 notebooks work fine the third will not connect so i went down a purchased the 4th fron a different store and pluged it in and it has the same problem. Could it be that i need to chage one of the PFsense advanced settings. Also on the notebook that cannot connect if i set its gateway to the cisco router of 10.0.2.2 then it connects just fine over to the server 10.0.1.10. I have also changed IP address on the noteboot and checked them for IP-conflicts.

    This is crazy :o



  • closer inspection raises some questions for me …..

    acer <--> pfsense1 lan | pfsense1 wan <--> cisco1 <--> MPLS network <--> Cisco2 <--> pfsense2 wan | pfsense2 lan <--> server 10.0.1.10
    

    is that an accurate interpretation of your situation ?
    do the subnets overlap or are they the same ?

    if yes then i can't imagine this ever working properly …
    if you plug in a linksys router this would not be an issue because they probably have a different default subnet 192.168.1.0/24 and thus have no issues

    perhaps you should consider changing the lan subnet's on both ends or change the subnet the cisco's are running on

    good luck



  • here is a pic of my setup



  • Did you enabled "Bypass firewall rules for traffic on the same interface " on system advanced -> Firewall/Nat?



  • Bypass firewall rules for traffic on the same interface. That seems to have fixed it. thanks ;D


Locked