No IGMP & UDPXY proxy among packages



  • Hi people,

    Need Your help:
    I have implemented pfSense-2.0.1-RELEASE-i386.iso on HP dx5150 (even AMD64 was not able to load after IPsec) with intention to use with IPTV. According to help on forum, I went to System -> Packages to install UDPXY or at least IGMPproxy and I was surprised - nothing found among the list of other PORTS.

    OK, so I decided to implement by hands - manually.
    Downloading also was not so succesfull - pkg_add -r udpxy was missing PACKAGE (ROOT and SITE in setenv).

    OK, so I decided to upload udpxy-1.0.21.tbz file from PC at LAN (it was uploaded to /tmp/ folder.
    After that I ran fetch command. And intended to check if it was implemented I ran udpxy -v. Result was a lot of information on switches and other help.

    But after restart - /tmp/ was empty. According to manual on forum there was offer to rename udpxy to udpxy.sh and copy it to /sbin (probably in /usr ???)

    I need Your help to implement this feature on pfsense.





  • The IGMP proxy is already in the base and not a package anymore.
    You can configure it under "Services –> IGMP proxy"



  • Ok,  falks. After try out - I'll write down the result.



  • Hi people,

    Just began my implementation:
    I need to edit /etc/defaults/rc.conf to add "variable" udpxy_enable="YES"
    so how to do it better:

    VARIANT A):
    cd /
    cd /etc/defaults/
    ee rc.conf

    VARIANT B):

    echo "udpxy_enable=YES" >> /etc/defaults/rc.conf

    But here result is not right, as should be YES as "YES"
    I was trying also:

    echo "udpxy_enable="YES"" >> /etc/defaults/rc.conf

    But still same result.



  • to get "" redirected to a file, use

    echo 'enable_my_var="YES"' >> /root/test.conf


  • Rebel Alliance Developer Netgate

    pfSense does not use rc.conf.

    Stick the script in /usr/local/etc/rc.d/, make sure it ends in .sh, edit the script and set that variable at the top.



  • Good day calleagues,

    I'm trying to implement mutli VLANs with IPTV support:

    Hereby I have placed a picture, where Pic. A1 is representing old system and Pic. A2 depicts new one:

    Interfaces:
    WAN (VLAN1): 88.88.88.88
    LAN (VLAN100) 192.168.1.1
    LAN OPT2 (VLAN101) 192.168.2.1

    I have configured IGMP service as follow:

    Firewall>Rules>Lan
    added rule
    Action=Pass
    Interface=Lan
    Protocol=IGMP
    Source=Lan subnet
    Destination=Network 239.2.3.0/24
    Advanced Options>checked "This allows packets with IP options to pass…"
    Rule is placed almost on top

    Firewall>Rules>Wan
    added rule
    Action=Pass
    Interface=Wan
    Protocol=UDP
    Source=any
    Destination=Network 239.2.3.0/24

    Applied all changes.

    Services>IGMP Proxy
    added upstream
    interface=Wan
    Type=Upstream Interfece
    Threshold=1
    Network(s)=88.88.88.88/24 192.168.1.1/24

    added downstream
    Interface=Lan
    Type=Downstream Interface
    Threshold=1
    Network(s)=192.168.1.0/24

    System>Advanced>Firewall/Nat
    checked Disable Firewall Scrub

    In Interfaces: WAN I have removed check mark from Block private networks в секции Private networks

    Also configured UDPXY as follow:
    At command prompt I have ran such command:
    pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/udpxy.tbz

    Then renamed udpxy file (which is placed in /usr/local/etc/rc.d/) into udpxy.sh and editted it as follow:
    udpxy_enable=${udpxy_enable="YES"}
    udpxy_flags=${udpxy_flags-" -a 192.168.1.1 -c 4 -M 60 -m 88.88.88.88"}

    Also I'll try to modify as suggested jimp udpxy_enable="YES" into rc.d

    I have checked status of udpxy over http://192.168.1.1:4022/status

    But, no streaming over multicast with http://192.168.1.1:4022/udp/239.192.12.5:1234

    Can You help or suggest on how to fix this problem.



  • @GruensFroeschli:

    The IGMP proxy is already in the base and not a package anymore.
    You can configure it under "Services –> IGMP proxy"

    Isn't already installed on pfsense just like GruensFroeschli said?


Log in to reply