Lightsquid 500 - Internal Server Error



  • I have just done an upgrade, trying to fix an issue.. upgraded from 2.0.1 i386 to 2.0.1 amd64.

    now my lightsquid is is just showing a 500 - Internal server error when i try and see the logs.  Any idea how i can fix this?  i really need these back.



  • did you do a upgrade or a full install? You shouldn't upgrade from i386 to amd64… a full-install is the same to go



  • I did an update.. as everyone in another thread said to go the update path.

    Either way, i also build another virtual of pfsense from scratch, and installed the config from my other box, same go.. 500 - Internal server error



  • @luke240778:

    I did an update.. as everyone in another thread said to go the update path.

    If you search, you will find a ton of posts that upgrading from i386 to amd64 is a bad idea.

    do you have logging enabled on squid? make sure the path for the log file is '/var/squid/log'  then do a refresh full within lightsquid



  • Yeah thanks.  Maybe a bad idea but it had to be done.  I am seeing my problem is that the squid service is not starting.  If i remove and reinstall this will the logs, cache and all that still be there form before the re-install?



  • From reading a few other posts on the net.. and already reinstalling squid and lightsquid and still getting this error, it seems it could be perl related?

    if i run: pkg_info -lx perl

    It tells me perl is not installed… so how do i get perl installed?  I cant see it in the packages list, and i dont know how to install packages via command line



  • pkg_add -r http://files.pfsense.org/packages/8/All/perl-5.12.3.tbz

    that should do it. hmm, what packages to you have installed btw? is lightsquid there? because perl should had installed when lightsquid was being installed



  • how do i check what packages are installed? I mean, in the GUI it shows Lightsquid as being installed..



  • pkg_info will should all the freebsd packages that are installed… the gui shows the pfsense package but there are usually dependencys that are required... in this case perl is needed for lightsquid to function



  • Ok strange.. when i run just pkg_info it says perl is installed… but when i run pkg_info -lx perl it says its not installed.. here is what pkg_info shows:

    GeoIP-1.4.8_1      Find the country that any IP address or hostname originates
    bsdinstaller-2.0.2011.0913 BSD Installer mega-package
    cyrus-sasl-2.1.25_1 RFC 2222 SASL (Simple Authentication and Security Layer)
    expat-2.0.1_1      XML 1.0 parser written in C
    expat-2.0.1_2      XML 1.0 parser written in C
    font-util-1.2.0    Create an index of X font files in a directory
    fontconfig-2.8.0,1  An XML-based font configuration API for X Windows
    fontconfig-2.8.0_1,1 An XML-based font configuration API for X Windows
    freetype2-2.4.3    A free and portable TrueType font rendering engine
    freetype2-2.4.4    A free and portable TrueType font rendering engine
    freetype2-2.4.7    A free and portable TrueType font rendering engine
    gd-2.0.35_7,1      A graphics library for fast creation of images
    gdbm-1.8.3_3        The GNU database manager
    gettext-0.18.1.1    GNU gettext package
    graphviz-2.28.0    Graph Visualization Software from AT&T and Bell Labs
    iperf-2.0.4        A tool to measure maximum TCP and UDP bandwidth
    jpeg-8_3            IJG's jpeg compression utilities
    libart_lgpl-2.3.21,1 Library for high-performance 2D graphics
    libevent-1.4.14b_2  Provides an API to execute callback functions on certain ev
    libiconv-1.13.1_1  A character set conversion library
    libltdl-2.4        System independent dlopen wrapper
    libltdl-2.4_1      System independent dlopen wrapper
    libpcap-1.1.1_1    Ubiquitous network traffic capture library
    libwww-5.4.0_4      The W3C Reference Library
    libxml2-2.7.8_1    XML parser library for GNOME
    lightsquid-1.8_2    A light and fast web based squid proxy traffic analyser
    ntop-4.0.1_1        Network monitoring tool with command line and web interface
    openldap-client-2.4.26 Open source LDAP client implementation
    p5-GD-2.46          A perl5 interface to Gd Graphics Library version2
    p7zip-9.13          File archiver with high compression ratio
    perl-5.12.3        Practical Extraction and Report Language
    perl-5.12.4        Practical Extraction and Report Language
    perl-5.12.4_3      Practical Extraction and Report Language
    pkg-config-0.25_1  A utility to retrieve information about installed libraries
    png-1.4.4          Library for manipulating PNG images
    png-1.4.5_1        Library for manipulating PNG images
    png-1.4.8          Library for manipulating PNG images
    python27-2.7.2_1    An interpreted object-oriented programming language
    rrdtool-1.2.26_1    Round Robin Database Tools
    squid-2.7.9_1      HTTP Caching Proxy
    squid_radius_auth-1.10 RADIUS authenticator for squid proxy 2.5 and later
    urwfonts-1.0_3      Another font package for X
    webfonts-0.30_6    TrueType core fonts for the Web
    zabbix-agent-1.8.5,2 Enterprise-class open source distributed monitoring (agent)
    zip-3.0            Create/update ZIP files compatible with pkzip



  • Any ideas?  I have reinstalled squid and lightsquid and apparently perl is installed.. still not working



  • From the output of the command "pkg_info", you can see that you have three version of perl installed.

    Type the command:

    perl -v

    Check the following directories for any perl symlinks:

    /usr/bin
      /usr/local/bin

    Delete any that you find, then:

    cd /usr/bin

    ln -s /usr/local/bin/perl /usr/bin/perl

    ls -ltr | grep -i perl

    lrwxr-xr-x  1 root  wheel      19 Sep 11 23:02 perl -> /usr/local/bin/perl

    perl -v

    That is how I solved the Error 500 message.



  • @scooterdouglas:

    From the output of the command "pkg_info", you can see that you have three version of perl installed.

    Type the command:

    perl -v

    Check the following directories for any perl symlinks:

    /usr/bin
      /usr/local/bin
     
    Delete any that you find, then:

    cd /usr/bin

    ln -s /usr/local/bin/perl /usr/bin/perl

    ls -ltr | grep -i perl

    lrwxr-xr-x  1 root  wheel       19 Sep 11 23:02 perl -> /usr/local/bin/perl

    perl -v

    That is how I solved the Error 500 message.

    Thanks for this help, when i run: perl -v i getthe following

    This is perl 5, version 12, subversion 4 (v5.12.4) built for i386-freebsd-64int

    Maybe this is a problem as i have 64bit pfSense.. and i386 perl?

    Sorry to be a noob but i don't know what is a symlink.. in /usr/bin the only reference i see to perl is this:

    perl -> /usr/local/bin/perl

    Is that a symlink and therefore i need to delete it?

    In /usr/local/bin/i have the following for perl:

    perl
    perl-after-upgrade
    perl5.12.3
    perl5.12.4
    perlbug
    perlivp
    perlthanks

    Are they symlinks?  need to remove anything?

    I will wait for your reply to this before running the commands that you mentioned to do after deleting symlinks



  • Someone able to help here?

    Is having that i386 version of perl a problem?  I still can't get these lightsquid logs working.

    I don't know how to install via command line, is there somehow i can install the 64bit version of perl?



  • is anyone else who is running lightsquid on 64bit pfsense able to do me a perl -v and tell me if their perl still says i386 or not?



  • If anyone else at all is able to help i would really aprreciate it.. i am still stuck and without Lightsquid logs.. THis is very importand for me to have , but i have no idea how i am going to fix this.



  • Ok, so no one knows about how to fix this once and for all?


  • Rebel Alliance Developer Netgate

    Hit it with a sledgehammer.

    Or, uninstall lightsquid and squid/squidguard, then from the shell:

    pkg_delete -f squid*
    pkg_delete -f perl*

    Then reinstall squid, then reinstall lightsquid.



  • Sorry to dig up this old thread, but this happened to me recently, TWICE.

    And the fix for me was to go inside lightsquid config and change the squid log directory to var/squid/log. The default on install tell lightsquid to search on var/squid/logs


Log in to reply