Shuttle XS35v2 (D525/NM10) install failure



  • I'm trying to install pfSense on a Shuttle XS35v2, with no luck.
    The system is an Atom D525, with the NM10 chipset (appears to detect as ICH7).
    Installing from either memstick or a USB CD-ROM, I get the same results:

    The loader boots, I get to the loader menu (and have tried both 1 and 3, the boot from USB option), and shortly thereafter, a ROOT MOUNT ERROR.

    Sorry, no serial ports, so I can't get at the full console output for you.

    This ends at a mountroot> prompt, and hitting ? returns an empty list.

    I believe the problem is specific to the pfSense installer/distro, as I've installed Freenas 8.0 on this hardware as a test.

    It feels like there's a driver missing that's required to mount usb devices after the BIOS is gone.



  • I just tested with a SATA CD-ROM installed, and have the same problem. It boots, but fails to mount cd9660:/dev/iso9660/pfSense

    Any thoughts on troubleshooting this?


  • Netgate Administrator

    USB boot problems can often be solved by this:
    http://doc.pfsense.org/index.php/Boot_Troubleshooting#Booting_from_USB

    However if you're tried a sata drive as well it may not help. Corrupt CD perhaps?

    Steve



  • It seems highly unlikely that both the memstick and cd installs I've tried are corrupt in exactly the same way.

    There's clearly some driver that's missing from pfSense that's present in FreeNAS.

    I'm thinking of reinstalling FreeNAS (or installing full-on FreeBSD) to get information on the hardware present. What would be useful to troubleshoot?

    I'm a linux guy, so I'd say dmesg and lspci… what's the BSD equivalent?


  • Netgate Administrator

    Use dmesg and pciconf.

    It sounded to me as though it wasn't getting past the boot loader but am I wrong? If so it's not a driver problem.

    You could try one of the 2.1 test snapshots which are built on FreeBSD 8.3:
    http://snapshots.pfsense.org/

    Steve



  • It does get past the loader menu, it's when the system tries to mount the root filesystem that things fall over.

    The machine is at home, so I'll get back to it tonight and tell you what dmesg and pciconf tell us.

    I'll give the 2.1/8.3 snapshot a try tonight. FreeNAS is based on 8.0, so I know that it can work, we're probably just missing a module.


  • Netgate Administrator

    Hmm, I thought FreeNAS was based on 8.2? There are two branches though, it's been a while.
    pfSense 2.0.1 is based on 8.1, almost all the same kernel modules will be there.
    Your hardware doesn't seem particularly exotic, I would expect it to just work.

    Do you have any on board raid component?

    Steve



  • No RAID, just the on-board NM10 (I see ICH7 messages scroll by).

    I'm surprised it doesn't work as well. I was more worried about the jme ethernet than anything else, frustrating that USB and SATA aren't right. :)


  • Netgate Administrator

    Is your sata controller set to IDE (legacy) mode?

    There are many people running D525/NM10 based boards.

    Steve



  • I believe I've tried in both IDE and AHCI modes, but I can check again. That's one of the few things in the BIOS on this thing that you can change.

    Which mode should work?


  • Netgate Administrator

    IDE mode, though it's normally more of an issue when booting from hard drive.

    At least that's what I thought but the boot troubleshooting page seems to suggest using AHCI. Again that's for hard disk booting though.  :-\

    Steve



  • So, last night's 2.1 snapshot installed without issue, in AHCI mode.
    As such, the rest of this is mostly of academic interest, if there's a desire to fix this for a possible 2.0.2.

    I did try both IDE and AHCI with 2.0.1 and neither worked. I don't have a serial dump, but if you want to look at the boot console output, here's a movie: http://gallery.me.com/n6mod#100121

    Here's dmesg and pciconf -l from the machine with 2.1 installed:

    [2.1-DEVELOPMENT][admin@paula.milewski.org]/root(4): dmesg
    Copyright © 1992-2012 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 8.3-RC2 #0: Fri Mar 23 22:12:25 EDT 2012
        root@FreeBSD_8.3_pfSense_2.1.snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8 amd64
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Atom(TM) CPU D525  @ 1.80GHz (1802.69-MHz K8-class CPU)
      Origin = "GenuineIntel"  Id = 0x106ca  Family = 6  Model = 1c  Stepping = 10
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x40e31d <sse3,dtes64,mon,ds_cpl,tm2,ssse3,cx16,xtpr,pdcm,movbe>AMD Features=0x20100800 <syscall,nx,lm>AMD Features2=0x1 <lahf>TSC: P-state invariant
    real memory  = 4294967296 (4096 MB)
    avail memory = 4083130368 (3893 MB)
    ACPI APIC Table: <062311 APIC1651>
    FreeBSD/SMP: Multiprocessor System Detected: 4 CPUs
    FreeBSD/SMP: 1 package(s) x 2 core(s) x 2 HTT threads
    cpu0 (BSP): APIC ID:  0
    cpu1 (AP/HT): APIC ID:  1
    cpu2 (AP): APIC ID:  2
    cpu3 (AP/HT): APIC ID:  3
    ioapic0: Changing APIC ID to 4
    ioapic0 <version 2.0="">irqs 0-23 on motherboard
    netisr_init: forcing maxthreads to 1 and bindthreads to 0 for device polling
    wlan: mac acl policy registered
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xffffffff80493e90, 0) error 1
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xffffffff80493f30, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xffffffff80493fd0, 0) error 1
    kbd1 at kbdmux0
    cryptosoft0: <software crypto="">on motherboard
    padlock0: No ACE support.
    acpi0: <shuttl shuttle="">on motherboard
    acpi0: [ITHREAD]
    ACPI Error: No handler for Region [ECRM] (0xffffff0002526080) [EmbeddedControl] (20101013/evregion-487)
    ACPI Error: Region EmbeddedControl(0x3) has no handler (20101013/exfldio-382)
    ACPI Error: Method parse/execution failed [\SB.PCI0.SBRG.EC0_._REG] (Node 0xffffff000252a880), AE_NOT_EXIST (20101013/psparse-633)
    acpi0: Power Button (fixed)
    acpi0: reservation of ffc00000, 300000 (3) failed
    acpi0: reservation of fee00000, 1000 (3) failed
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, bf600000 (3) failed
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
    cpu0: <acpi cpu="">on acpi0
    cpu1: <acpi cpu="">on acpi0
    cpu2: <acpi cpu="">on acpi0
    cpu3: <acpi cpu="">on acpi0
    acpi_ec0: <embedded controller:="" gpe="" 0x1d="">port 0x62,0x66 on acpi0
    pcib0: <acpi host-pci="" bridge="">port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus="">on pcib0
    vgapci0: <vga-compatible display="">port 0xcc00-0xcc07 mem 0xfe980000-0xfe9fffff,0xd0000000-0xdfffffff,0xfe800000-0xfe8fffff irq 16 at device 2.0 on pci0
    agp0: <intel pineview="" svga="" controller="">on vgapci0
    agp0: aperture size is 256M, detected 8188k stolen memory
    vgapci1: <vga-compatible display="">mem 0xfe780000-0xfe7fffff at device 2.1 on pci0
    pci0: <multimedia, hda="">at device 27.0 (no driver attached)
    pcib1: <acpi pci-pci="" bridge="">irq 16 at device 28.0 on pci0
    pci1: <acpi pci="" bus="">on pcib1
    pcib2: <acpi pci-pci="" bridge="">irq 17 at device 28.1 on pci0
    pci2: <acpi pci="" bus="">on pcib2
    pci2: <base peripheral=""> at device 0.0 (no driver attached)
    pci2: <base peripheral,="" sd="" host="" controller=""> at device 0.2 (no driver attached)
    pci2: <base peripheral=""> at device 0.3 (no driver attached)
    jme0: <jmicron inc,="" jmc25x="" gigabit="" ethernet="">port 0xdc00-0xdc7f,0xd800-0xd8ff mem 0xfeaf4000-0xfeaf7fff irq 17 at device 0.5 on pci2
    jme0: Using 1 MSIX messages.
    miibus0: <mii bus="">on jme0
    jmphy0: <jmp211 10="" 100="" 1000="" media="" interface="">PHY 1 on miibus0
    jmphy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    jme0: [FILTER]
    pcib3: <acpi pci-pci="" bridge="">irq 19 at device 28.3 on pci0
    pci3: <acpi pci="" bus="">on pcib3
    pci3: <network>at device 0.0 (no driver attached)
    uhci0: <intel 82801g="" (ich7)="" usb="" controller="" usb-a="">port 0xc880-0xc89f irq 23 at device 29.0 on pci0
    uhci0: [ITHREAD]
    uhci0: LegSup = 0x2f00
    usbus0: <intel 82801g="" (ich7)="" usb="" controller="" usb-a="">on uhci0
    uhci1: <intel 82801g="" (ich7)="" usb="" controller="" usb-b="">port 0xc800-0xc81f irq 19 at device 29.1 on pci0
    uhci1: [ITHREAD]
    uhci1: LegSup = 0x2f00
    usbus1: <intel 82801g="" (ich7)="" usb="" controller="" usb-b="">on uhci1
    uhci2: <intel 82801g="" (ich7)="" usb="" controller="" usb-c="">port 0xc480-0xc49f irq 18 at device 29.2 on pci0
    uhci2: [ITHREAD]
    uhci2: LegSup = 0x2f00
    usbus2: <intel 82801g="" (ich7)="" usb="" controller="" usb-c="">on uhci2
    uhci3: <intel 82801g="" (ich7)="" usb="" controller="" usb-d="">port 0xc400-0xc41f irq 16 at device 29.3 on pci0
    uhci3: [ITHREAD]
    uhci3: LegSup = 0x2f00
    usbus3: <intel 82801g="" (ich7)="" usb="" controller="" usb-d="">on uhci3
    ehci0: <intel 82801gb="" r="" (ich7)="" usb="" 2.0="" controller="">mem 0xfe977c00-0xfe977fff irq 23 at device 29.7 on pci0
    ehci0: [ITHREAD]
    usbus4: EHCI version 1.0
    usbus4: <intel 82801gb="" r="" (ich7)="" usb="" 2.0="" controller="">on ehci0
    pcib4: <acpi pci-pci="" bridge="">at device 30.0 on pci0
    pci4: <acpi pci="" bus="">on pcib4
    isab0: <pci-isa bridge="">at device 31.0 on pci0
    isa0: <isa bus="">on isab0
    atapci0: <intel ich7="" sata300="" controller="">port 0xc080-0xc087,0xc000-0xc003,0xbc00-0xbc07,0xb880-0xb883,0xb800-0xb81f mem 0xfe977800-0xfe977bff irq 19 at device 31.2 on pci0
    atapci0: [ITHREAD]
    atapci0: AHCI called from vendor specific driver
    atapci0: AHCI v1.10 controller with 4 3Gbps ports, PM not supported
    ata2: <ata channel="">at channel 0 on atapci0
    ata2: [ITHREAD]
    ata3: <ata channel="">at channel 1 on atapci0
    ata3: [ITHREAD]
    ata4: <ata channel="">at channel 2 on atapci0
    ata4: [ITHREAD]
    ata5: <ata channel="">at channel 3 on atapci0
    ata5: [ITHREAD]
    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)
    acpi_button0: <sleep button="">on acpi0
    acpi_button1: <power button="">on acpi0
    acpi_tz0: <thermal zone="">on acpi0
    atrtc0: <at realtime="" clock="">port 0x70-0x71 irq 8 on acpi0
    atkbdc0: <keyboard controller="" (i8042)="">port 0x60,0x64 irq 1 on acpi0
    atkbd0: <at keyboard="">irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    atkbd0: [ITHREAD]
    acpi_hpet0: <high precision="" event="" timer="">iomem 0xfed00000-0xfed003ff on acpi0
    Timecounter "HPET" frequency 14318180 Hz quality 900
    orm0: <isa option="" rom="">at iomem 0xce000-0xcf7ff on isa0
    sc0: <system console="">at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga="">at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    ppc0: cannot reserve I/O port range
    p4tcc0: <cpu frequency="" thermal="" control="">on cpu0
    p4tcc1: <cpu frequency="" thermal="" control="">on cpu1
    p4tcc2: <cpu frequency="" thermal="" control="">on cpu2
    p4tcc3: <cpu frequency="" thermal="" control="">on cpu3
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    usbus0: 12Mbps Full Speed USB v1.0
    usbus1: 12Mbps Full Speed USB v1.0
    usbus2: 12Mbps Full Speed USB v1.0
    usbus3: 12Mbps Full Speed USB v1.0
    usbus4: 480Mbps High Speed USB v2.0
    ad4: 114473MB <intel ssdsa2cw120g3="" 4pc10302="">at ata2-master UDMA100 SATA 3Gb/s
    ugen0.1: <intel>at usbus0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus0
    ugen1.1: <intel>at usbus1
    uhub1: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus1
    ugen2.1: <intel>at usbus2
    uhub2: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus2
    ugen3.1: <intel>at usbus3
    uhub3: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr="">on usbus3
    ugen4.1: <intel>at usbus4
    uhub4: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr="">on usbus4
    uhub0: 2 ports with 2 removable, self powered
    uhub1: 2 ports with 2 removable, self powered
    uhub2: 2 ports with 2 removable, self powered
    uhub3: 2 ports with 2 removable, self powered
    uhub4: 8 ports with 8 removable, self powered
    SMP: AP CPU #1 Launched!
    SMP: AP CPU #2 Launched!
    SMP: AP CPU #3 Launched!
    Trying to mount root from ufs:/dev/ad4s1a
    pflog0: promiscuous mode enabled
    [2.1-DEVELOPMENT][admin@paula.milewski.org]/root(5): pciconf -l
    hostb0@pci0:0:0:0: class=0x060000 card=0xa0008086 chip=0xa0008086 rev=0x02 hdr=0x00
    vgapci0@pci0:0:2:0: class=0x030000 card=0xa0018086 chip=0xa0018086 rev=0x02 hdr=0x00
    vgapci1@pci0:0:2:1: class=0x038000 card=0xa0018086 chip=0xa0028086 rev=0x02 hdr=0x00
    none0@pci0:0:27:0: class=0x040300 card=0x20051297 chip=0x27d88086 rev=0x02 hdr=0x00
    pcib1@pci0:0:28:0: class=0x060400 card=0x20051297 chip=0x27d08086 rev=0x02 hdr=0x01
    pcib2@pci0:0:28:1: class=0x060400 card=0x20051297 chip=0x27d28086 rev=0x02 hdr=0x01
    pcib3@pci0:0:28:3: class=0x060400 card=0x20051297 chip=0x27d68086 rev=0x02 hdr=0x01
    uhci0@pci0:0:29:0: class=0x0c0300 card=0x20051297 chip=0x27c88086 rev=0x02 hdr=0x00
    uhci1@pci0:0:29:1: class=0x0c0300 card=0x20051297 chip=0x27c98086 rev=0x02 hdr=0x00
    uhci2@pci0:0:29:2: class=0x0c0300 card=0x20051297 chip=0x27ca8086 rev=0x02 hdr=0x00
    uhci3@pci0:0:29:3: class=0x0c0300 card=0x20051297 chip=0x27cb8086 rev=0x02 hdr=0x00
    ehci0@pci0:0:29:7: class=0x0c0320 card=0x20051297 chip=0x27cc8086 rev=0x02 hdr=0x00
    pcib4@pci0:0:30:0: class=0x060401 card=0x20051297 chip=0x24488086 rev=0xe2 hdr=0x01
    isab0@pci0:0:31:0: class=0x060100 card=0x20051297 chip=0x27bc8086 rev=0x02 hdr=0x00
    atapci0@pci0:0:31:2: class=0x010601 card=0x20051297 chip=0x27c18086 rev=0x02 hdr=0x00
    none1@pci0:0:31:3: class=0x0c0500 card=0x20051297 chip=0x27da8086 rev=0x02 hdr=0x00
    none2@pci0:2:0:0: class=0x088000 card=0x20051297 chip=0x2382197b rev=0x80 hdr=0x00
    none3@pci0:2:0:2: class=0x080501 card=0x20051297 chip=0x2381197b rev=0x80 hdr=0x00
    none4@pci0:2:0:3: class=0x088000 card=0x20051297 chip=0x2383197b rev=0x80 hdr=0x00
    jme0@pci0:2:0:5: class=0x020000 card=0x20051297 chip=0x0250197b rev=0x03 hdr=0x00
    none5@pci0:3:0:0: class=0x028000 card=0x817610ec chip=0x817610ec rev=0x01 hdr=0x00</intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></cpu></cpu></cpu></cpu></generic></system></isa></high></at></keyboard></at></thermal></power></sleep></serial></ata></ata></ata></ata></intel></isa></pci-isa></acpi></acpi></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></network></acpi></acpi></jmp211></mii></jmicron></acpi></acpi></acpi></acpi></multimedia,></vga-compatible></intel></vga-compatible></acpi></acpi></embedded></acpi></acpi></acpi></acpi></shuttl></software></version></lahf></syscall,nx,lm></sse3,dtes64,mon,ds_cpl,tm2,ssse3,cx16,xtpr,pdcm,movbe></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>


  • Netgate Administrator

    Good to know, still slightly odd.  ::)

    You have a lot of unrecognised devices there, none0-5.

    Steve



  • none2@pci0:2:0:0:  class=0x088000 card=0x20051297 chip=0x2382197b rev=0x80 hdr=0x00
    none3@pci0:2:0:2:  class=0x080501 card=0x20051297 chip=0x2381197b rev=0x80 hdr=0x00
    none4@pci0:2:0:3:  class=0x088000 card=0x20051297 chip=0x2383197b rev=0x80 hdr=0x00

    These are probably the 4:1 Card Reader (JMicron - 197b:2381, 197b:2382, 197b:2383)

    none5@pci0:3:0:0:  class=0x028000 card=0x817610ec chip=0x817610ec rev=0x01 hdr=0x00

    This is could possibly be the WiFi (Realtek - 10ec:8176)

    none0@pci0:0:27:0:  class=0x040300 card=0x20051297 chip=0x27d88086 rev=0x02 hdr=0x00

    Intel Audio (Intel - 8086:27d8)

    none1@pci0:0:31:3:  class=0x0c0500 card=0x20051297 chip=0x27da8086 rev=0x02 hdr=0x00

    This appears to be the ICH7 chipset (Intel - 8086:27da)



  • none1@pci0:0:31:3:   class=0x0c0500 card=0x20051297 chip=0x27da8086 rev=0x02 hdr=0x00

    This appears to be the ICH7 chipset (Intel - 8086:27da)

    Which would explain why I can't mount anything, yes?


  • Netgate Administrator

    That is the SMB controller in the ICH7 chipset:

    pci0: <serial bus,="" smbus="">at device 31.3 (no driver attached)</serial>

    It's not stopping you mounting anything.

    I don't recall ever seeing a PCI attached card reader before, they are almost always USB, but that looks like what it is.

    The last item looks like an RTL8188CE, as you said. It's very unlikely you will get this to work with pfSense. There are no FreeBSD drivers so you have to use NDIS wrapper.

    Steve



  • Yeah, couldn't care less about that wireless card. I might replace it with something more useful down the road, but for now I'm using an external AP.

    And you're right, that pciconf is from the working system. So, if there's no interest in fixing this hardware for 2.0 (or understanding why 2.1 works where 2.0 doesn't), then I think we can call this one solved. :)


Log in to reply