When I click the Advanced and MLPPP ,then PF server dead.



  • When I click " Click here for additional PPPoE configuration options. Save first if you made changes. " in PPPoE configuration page, then the PPPoe link down and PF server dead.

    I have to resart server, and delete and reconfig WAN PPPoe.  ???



  • click the interfaces_ppps_edit.php?id=2 page, then server dead. only may ping server. but all PPPoe link down.



  • Which version of pfSense are you using?



  • @chpalmer:

    Which version of pfSense are you using?

    2.1-DEVELOPMENT-i386-20120321-1402



  • resart web still not open server, it only resart server can open PF server.



  • What does this page say?

    /diag_logs_ppp.php



  • click the interfaces_ppps_edit.php?id=5 page PF web service dead, but PPPOE still online.

    I can't open Pf WEB now, So I will post log later.



  • @chpalmer:

    What does this page say?

    /diag_logs_ppp.php

    restart server get log show:

    Last 50 PPP log entries
    Jan 1 16:50:45 ppp: [wan] IPCP: state change Initial –> Starting
    Jan 1 16:50:45 ppp: [wan] IPCP: LayerStart
    Jan 1 16:50:45 ppp: [wan] IPV6CP: Open event
    Jan 1 16:50:45 ppp: [wan] IPV6CP: state change Initial –> Starting
    Jan 1 16:50:45 ppp: [wan] IPV6CP: LayerStart
    Jan 1 16:50:45 ppp: [wan] IPCP: Up event
    Jan 1 16:50:45 ppp: [wan] IPCP: state change Starting –> Req-Sent
    Jan 1 16:50:45 ppp: [wan] IPCP: SendConfigReq #1
    Jan 1 16:50:45 ppp: [wan] IPADDR 0.0.0.0
    Jan 1 16:50:45 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Jan 1 16:50:45 ppp: [wan] PRIDNS 0.0.0.0
    Jan 1 16:50:45 ppp: [wan] SECDNS 0.0.0.0
    Jan 1 16:50:45 ppp: [wan] IPV6CP: Up event
    Jan 1 16:50:45 ppp: [wan] IPV6CP: state change Starting –> Req-Sent
    Jan 1 16:50:45 ppp: [wan] IPV6CP: SendConfigReq #1
    Jan 1 16:50:45 ppp: [wan] IPCP: rec'd Configure Request #110 (Req-Sent)
    Jan 1 16:50:45 ppp: [wan] IPADDR 124.114.64.1
    Jan 1 16:50:45 ppp: [wan] 124.114.64.1 is OK
    Jan 1 16:50:45 ppp: [wan] IPCP: SendConfigAck #110
    Jan 1 16:50:45 ppp: [wan] IPADDR 124.114.64.1
    Jan 1 16:50:45 ppp: [wan] IPCP: state change Req-Sent –> Ack-Sent
    Jan 1 16:50:45 ppp: [wan] IPCP: rec'd Configure Reject #1 (Ack-Sent)
    Jan 1 16:50:45 ppp: [wan] COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Jan 1 16:50:45 ppp: [wan] IPCP: SendConfigReq #2
    Jan 1 16:50:45 ppp: [wan] IPADDR 0.0.0.0
    Jan 1 16:50:45 ppp: [wan] PRIDNS 0.0.0.0
    Jan 1 16:50:45 ppp: [wan] SECDNS 0.0.0.0
    Jan 1 16:50:45 ppp: [wan_link0] LCP: rec'd Protocol Reject #172 (Opened)
    Jan 1 16:50:45 ppp: [wan_link0] LCP: protocol IPV6CP was rejected
    Jan 1 16:50:45 ppp: [wan] IPV6CP: protocol was rejected by peer
    Jan 1 16:50:45 ppp: [wan] IPV6CP: state change Req-Sent –> Stopped
    Jan 1 16:50:45 ppp: [wan] IPV6CP: LayerFinish
    Jan 1 16:50:45 ppp: [wan] IPCP: rec'd Configure Nak #2 (Ack-Sent)
    Jan 1 16:50:45 ppp: [wan] IPADDR 124.114.67.24
    Jan 1 16:50:45 ppp: [wan] 124.114.67.24 is OK
    Jan 1 16:50:45 ppp: [wan] PRIDNS 218.30.19.50
    Jan 1 16:50:45 ppp: [wan] SECDNS 61.134.1.5
    Jan 1 16:50:45 ppp: [wan] IPCP: SendConfigReq #3
    Jan 1 16:50:45 ppp: [wan] IPADDR 124.114.67.24
    Jan 1 16:50:45 ppp: [wan] PRIDNS 218.30.19.50
    Jan 1 16:50:45 ppp: [wan] SECDNS 61.134.1.5
    Jan 1 16:50:45 ppp: [wan] IPCP: rec'd Configure Ack #3 (Ack-Sent)
    Jan 1 16:50:45 ppp: [wan] IPADDR 124.114.67.24
    Jan 1 16:50:45 ppp: [wan] PRIDNS 218.30.19.50
    Jan 1 16:50:45 ppp: [wan] SECDNS 61.134.1.5
    Jan 1 16:50:45 ppp: [wan] IPCP: state change Ack-Sent –> Opened
    Jan 1 16:50:45 ppp: [wan] IPCP: LayerUp
    Jan 1 16:50:45 ppp: [wan] 124.114.67.24 -> 124.114.64.1
    Jan 1 16:50:46 ppp: [wan] IFACE: Up event
    Jan 1 16:50:46 ppp: [wan] IFACE: Rename interface ng0 to pppoe6



  • I don't see any attempt for MLPPP in those logs…  Are you sure you have MLPPP service?



  • When I creat an PPPOE link and I want to setup the Advanced and MLPPP. when I click that,then PF server down. why I can't click it?

    what's need me do it ?

    MY ISP support MUlti-PPPOE for link and get Different ipv4 ip address and Different ipv4 gateway from ISP.

    Mybe I can setup PPPoE link Aggregation ?

    I find the codes http://mpd.sourceforge.net/,  it is help for this?



  • @chpalmer:

    I don't see any attempt for MLPPP in those logs…   Are you sure you have MLPPP service?

    So the PF server down when click that, I am restart server after, just I can get and see logs.



  • I need to take my test box to the office where I have MLPPP service myself. Until then I cannot answer.

    What is the reason you are running a beta?

    I use 2.0.1 at the office and MLPPP works just fine there.



  • @chpalmer:

    I need to take my test box to the office where I have MLPPP service myself. Until then I cannot answer.

    What is the reason you are running a beta?

    I use 2.0.1 at the office and MLPPP works just fine there.

    I am need full support ipv6. So I try newest version. I hope setup PPPoE link Aggregation.

    I think click pfsense web php page not should dead. it is should show any information.



  • Yon-

    Have you ever made MLPPP work before?

    Does it work with an earlier version of pfSense?




  • No, I still not try use it.  I am new build PFsense server.

    Just I know MY ISP support multi PPPoE.



  • I find edit about PPPoe things, then PF server dead.



  • I have update to 2.1-DEVELOPMENT-i386-20120403-1619. but the wrong still no fix.



  • Crash reporter

    Crash report begins.  Anonymous machine information:

    i386
    8.3-RC2
    FreeBSD 8.3-RC2 #1: Wed Apr  4 08:00:43 EDT 2012    root@FreeBSD_8.3_pfSense_2.1.snaps.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_SMP.8

    Crash report details:

    PHP Errors:
    [13-Jan-2003 14:05:39 UTC] PHP Parse error:  syntax error, unexpected $end, expecting T_VARIABLE or '$' in /usr/local/pkg/filer.inc on line 178

    Filename: /var/crash/minfree
    2048


Log in to reply