[TUTORIAL] SMB_AUTH no pfSense



  • Usar o SMB_AUTH no PFSENSE 2.0.1

    Baixar e instalar Instalar os seguintes pacotes:

    URL: http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/
    pkg_add samba34-libsmbclient.tbz
    pkg_add samba34-nmblookup.tbz
    pkg_add samba34-smbclient.tbz
    pkg_add libexecinfo.tbz
    pkg_add libmcrypt.tbz
    pkg_add talloc.tbz

    Dentro do arquivo /usr/local/libexec/squid/smb_auth.sh e adicionar o -U $USER na linha abaixo:

    authinfo=$SAMBAPREFIX/bin/smbclient "//$dcname/$AUTHSHARE" **-U $USER** -I $dcip -d 0 -E -W "$DOMAINNAME" -c "get $authfilebs -" 2>/dev/null

    No arquivo /usr/local/pkg/squid.inc trocar a seguinte linha:
    $conf .= ‘auth_param basic program /usr/local/libexec/squid/ncsa_auth ‘ . SQUID_PASSWD . “\n”;

    Por:
    $conf .= "auth_param basic program /usr/local/libexec/squid/smb_auth -W DOMINIO -U IP_DO_SAMBA \n";

    Agora e só ir no Squid > Auth Settings e coloca o metodo e autenticação como local! :)

    Estou usando assim desde sexta-feira quando migrei do CentOS para pfSense, como não uso LDAP e nem RADIUS tive que implementar essa solução para ter os logins unificados!



  • diegogyn,

    Este método de autenticação mostra tela de login ou faz autenticação integrada com o browser?

    att,
    Marcello Coutinho



  • Mostra a tela de login.



  • diegogyn,

    Que tal publicar esta sua "receita de bolo" no blog da comunidade? http://www.pfsense-br.org/blog/

    Abraços!
    Jack



  • Como realizo a instalação desses pacotes no pfsense? Deculpe mas ainda não possuo grande dominio no pfsense



  • @manovelho:

    Como realizo a instalação desses pacotes no pfsense? Deculpe mas ainda não possuo grande dominio no pfsense

    use o pkg_add e Junte a url com o nome do pacote na console/ssh do pfsense

    ex:

    pkg_add -r http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/old-releases/i386/8.1-RELEASE/packages/Latest/samba34-libsmbclient.tbz

    O caminho completo é necessário porque a versão do freebsd que esta nesta versão é a 8.1 enquanto o repositório oficial(sem url completa) já está na  8.3



  • Fiz todo o procedimento e quando apareceu para o usuário colocar as suas credenciais… coloquei o meu usuário e senha no samba e infelizmente não deu certo.... o que pode ser?



  • Confere primeiro o cache.log do squid, (/var/squid/logs)



  • No pfSense digita o comando:

    /squid/smb_auth -W DOMINIO -U IP_DO_SERVIDOR -d

    usuario senha (depois você digita o usuário espaço senha)

    O comando vai retornar mais ou menos isso:
    Domain name: DOMINIO
    Pass-through authentication: no
    Query address options: -U IP_DO_SERVIDOR -R
    Domain controller IP address: IP_DO_SERVIDOR
    Domain controller NETBIOS name: LINUX
    Contents of //LINUX/NETLOGON/proxyauth:
    ERR

    Note que na frente de Contents of //LINUX/NETLOGON/proxyauth deveria aparecer a palavra allow e na linha debaixo OK ao invés de ERR.



  • tenta fazer o join no dominio denovo(pelo menos nos windows2003/nt funcionava  :)).



  • @marcelloc:

    Confere primeiro o cache.log do squid, (/var/squid/logs)

    marcelloc,

    eu trabalho junto com manovelho, no analisando o cache.log, nao percebi nada de diferente nele, apenas que a ultima alteração foi no dia 20/01/2012. segue link pra ele.
    http://dl.dropbox.com/u/39267233/cache.log



  • só achei isso de esquisito

    2012-01-20 08:27:55 [15615] (squidGuard): can't write to logfile /var/log/squidGuard.log
    2012-01-20 08:27:55 [15615] New setting: logdir: /var/squidGuard/log
    


  • @marcelloc:

    só achei isso de esquisito

    2012-01-20 08:27:55 [15615] (squidGuard): can't write to logfile /var/log/squidGuard.log
    2012-01-20 08:27:55 [15615] New setting: logdir: /var/squidGuard/log
    

    Então o que me sugeres?



  • @jaugusto_ap:

    Então o que me sugeres?

    tente debugar melhor o que este comando tenta fazer (/squid/smb_auth -W DOMINIO -U IP_DO_SERVIDOR -d)

    veja se existe parametro de debug, log do samba, event viewer, etc…


Log in to reply