LightSquid Segmentation fault access.log



  • Hi

    In recent days I try to have my authentication name in my reports of used on captive portal instead of IP addresses. I installed sarg and I changed in sarg.conf
                                    user_ip no and still no change. I have a DHCP server so I never know what address will be users.
    I then installed and the file LightSquid lightsquid.cfg I changed
                                    ip2name $ = "squidauth";;
    I tried several solutions but nothing works ..
    But when I try to see what is in my access.log file (clog access.log) tells me an error Segmentation fault (core dumped) maybe the operating system does not record the userid.

    thank you
    raphael



  • You are trying to use captive portal with squidguard config? I think it will work only if you find a way to authenticate squid user on captive portal database building a custom squid_helper.



  • I use squidGuard to establish a "blacklist" for user. It makes me no problem not to use squidGuard configuration. I just want to have my username on my reports LightSquid or Sarg. I'm looking for the most simple and effective but I have not yet found. In fact if you have a simpler solution, I will build around it.

    thanks



  • If your squid can log usernames, then reports will show username.

    what you get on access.log squid file?



  • Thank you for your response as fast.

    In my configuration file sarg.conf I put access log that goes into the / var / squid / log /
    where I find my file and access.log, cache.log and clog.core.

    I type the command to clog access.log to see if that has in it but its telling me "Segmentation fault (core dumped)".

    I've never been able to open this file even with several re-installation.
    I have over 1 gig of RAM.



  • @raphtelecom:

    I've never been able to open this file even with several re-installation.

    with access.log you need to tail it instead of loading it to memory.

    do on console/ssh

    tail -f /var/squid/logs/access.log



  • I log on and log off as user and it does absolutely nothing happens in my access.log file … I tested with the command tail-f access.log. I will review my configuration sarg.conf ?!

    EDIT : I was asleep, I have two access log. The first / usr / local / etc / sarg / access.log which is not helpful and did I tell you that it was written there. The second / usr / local / squid / var / logs / access.log / access.log works and I wrote my ip address in the report. I must exchange it for the username.

    I changed : And I have in reports my computer names instead of IP address (DNS name) when I put my option resolve_ip yes / no option and not to user_ip yes / no to no, I only have IP addresses

    TAG:  resolve_ip yes/no

    Convert ip address to dns name

    sarg -n

    resolve_ip yes

    TAG:  user_ip yes/no

    Use Ip Address instead userid in reports.

    sarg -p

    user_ip no



  • Do you have an idea to help me for my userid in sarg report, it would be appreciated



  • @raphtelecom:

    Do you have an idea to help me for my userid in sarg report, it would be appreciated

    check how users are logged on squid access.log file and select username or domain/username on sarg user tab.

    save changes and check realtime log for users instead of ip addresses.



  • I have ip address in my access.log





    ![raphael.rdltelecom - Status Sarg Realtime - Google Chrome.jpg](/public/imported_attachments/1/raphael.rdltelecom - Status Sarg Realtime - Google Chrome.jpg)
    ![raphael.rdltelecom - Status Sarg Realtime - Google Chrome.jpg_thumb](/public/imported_attachments/1/raphael.rdltelecom - Status Sarg Realtime - Google Chrome.jpg_thumb)



  • Sarg and lightsquid will show only info that are on squid logs.

    Look for squid auth configs tutorials to have username logged on access files first.



  • Is that my problem may be that I have checked the transparent proxy



  • @raphtelecom:

    Is that my problem may be that I have checked the transparent proxy

    transparent proxy does not authenticate users.



  • This is probably the cause of my problems, how to redigirer then my requests for port 80 on my proxy.

    thank



  • Use WPAD/PAC proxy scripts, you can configure it on dhcp and/or dns



  • Does he have an easier way to get an authentication UserID in my reports ?

    Thanks


Locked