WAN Interface only gets DHCP if speed manually set?



  • I'm running the latest snapshot, although this issue has existed for me on all builds of 2.1:

    If I don't manually set the WAN interface to "100baseTX Full Duplex", PFSense will not get a DHCP address during boot-up for that interface.

    The device doing the DHCP is a Motorola Surfboard (SBG6580) cable modem.
    The PFSense Hardware is an Intel D2500CCE Mini-ITX motherboard, with (2) Intel 82574L 10/100/1000 ethernet ports.

    Setting it to Auto always fails. Setting it to any higher speed fails (even though the Motorola claims to have gigabit ports on this model).

    Any suggestions? Thanks!


  • Rebel Alliance Global Moderator

    I would troubleshoot why your auto setting is not working, makes sense you wouldn't get dhcp if interface can not figure out correct settings for gig.  There is more at play with gig then just speed and duplex.  For starters isn't gig always full?  And I don't even think they actually neg the speed but the other stuff required for gig to work as designed.

    Does it not neg a 100 or 10 full/half connection at some point?  Or you just don't get any connection at all unless you hard code?

    If it works when you hard code gig, then clearly the SBG does have and supports gig.  Everything I have read says its bad juju to hard code gig.  If you solve the negotiation issue, that should solve your dhcp issue.

    Have you tried using a different cable (known good with autoneg working with gig) between your SBG and pfsense wan interface? Have you tried connecting different device with different nic to your SBG, does that autoneg to gig fine?



  • I had tried loading Windows on the same hardware, and it was able to pull a DHCP address just fine as far as I could tell.

    I have not tried a different cable however, I will try that tonight and see what results I get.


  • Rebel Alliance Global Moderator

    And did windows autoneg to gig?  Or did it neg some other combination? 10/100 full/half



  • It auto negotiated to Gig, and by the time I logged into the system, it had a correctly assigned DHCP IPV4 address. However, I don't know if Windows "keeps trying" if it doesn't get it the first time around. I think PFSense tries just the one time.



  • I've seen this same behavior before on a Microsoft Virtual PC VM.  If I recall I was able to do an interface down/up (ifconfig) and then it would get an address.  I know that doesn't solve the problem but perhaps a clue toward the root cause if that works in your case too.



  • @Eurisko:

    It auto negotiated to Gig

    My guess is you were using a different cable with the Windows box. Probably now using a CAT5 cable, not CAT5e, which should just negotiate fine to 100 Mb but maybe either the NIC you have or your cable modem doesn't play nicely with autonegotiation when it can't negotiate to gigabit.

    @Eurisko:

    and by the time I logged into the system, it had a correctly assigned DHCP IPV4 address. However, I don't know if Windows "keeps trying" if it doesn't get it the first time around. I think PFSense tries just the one time.

    No, it'll try indefinitely, the same as Windows and every other DHCP client, it'll keep trying forever until it gets a lease.



  • I can confirm that running the same hardware (Intel D2500CCE with an added two-port Intel Gigabit card for WAN) and a Huawei HG655b xDSL modem in bridge mode I do not get any DHCP replies unless I manually set my speed to 100 Mbps full duplex. I always thought this was an issue with the modem's speed negociation, but this thread makes me think otherwise.



  • @bkraptor:

    I can confirm that running the same hardware (Intel D2500CCE with an added two-port Intel Gigabit card for WAN) and a Huawei HG655b xDSL modem in bridge mode I do not get any DHCP replies unless I manually set my speed to 100 Mbps full duplex. I always thought this was an issue with the modem's speed negociation, but this thread makes me think otherwise.

    I had this same problem - it was the cable…


  • Rebel Alliance Global Moderator

    "the same as Windows and every other DHCP client, it'll keep trying forever until it gets a lease. "

    Not sure I would state it like that for windows - with "windows" the dhcp client will at some point it will just assign its own random 169.254 address (APIPA) This feature can be turned off.  But is on by default.

    So according to this
    http://support.microsoft.com/kb/220874

    Depending if the interface had a previous address, or lease expires then the timing changes.  But yes it does continue to send out dhcp discover either every 3 minutes or every 5 minutes depending even after its assigned itself a 169.254 address.  It looks like it will send out atleast 3 discover if has never had a lease.  But they also state "more" so its not real clear on exact number of discover it will send our how fast it sends them, etc.  Before it does APIPA and then resorts to sending at a timed interval a discover.



  • @cmb:

    No, it'll try indefinitely, the same as Windows and every other DHCP client, it'll keep trying forever until it gets a lease.

    On at least some versions of Ubuntu the DHCP client gave up after some time.



  • @bkraptor:

    I can confirm that running the same hardware (Intel D2500CCE with an added two-port Intel Gigabit card for WAN) and a Huawei HG655b xDSL modem in bridge mode I do not get any DHCP replies unless I manually set my speed to 100 Mbps full duplex. I always thought this was an issue with the modem's speed negociation, but this thread makes me think otherwise.

    Can you do network capture to see if pfSense is making DHCP request.  In my MS-VPC instance it was not.

    Don't just assume the DHCP request is actually being made.


  • Rebel Alliance Global Moderator

    I don't believe dhcp client is going to make a request until the interface is up, interface is not up if can not neg what speed or duplex it should be connected at.

    This is why he needs to troubleshoot his autoneg - chicken/egg thing, you can't have dhcp working if you don't have a working inteface.  How do you have a working interface if no speed or duplex worked out, etc.



  • I hate to admit it, but it was the cable!

    I had already swapped the cable out once before, but obviously I have some inferior cables laying around. Nice new CAT5e cable, and it works perfectly.

    Thanks!


  • Rebel Alliance Global Moderator

    Great to hear..  Its not very common, but yes sometimes the wire is not quite right..


Locked