Error message



  • php: : The command '/sbin/mount -u -r -f -o sync,noatime /cf' returned exit code '1', the output was 'mount: not currently mounted /cf'

    Any one ever seen this message before ?


  • Rebel Alliance Developer Netgate

    Usually that means the cf slice doesn't exist, or is broken/corrupted in some way.

    Try this:

    # Just in case your system is keeping your config elsewhere since the cf slice is broken:
    cp /cf/conf/config.xml /root/config.backup
    # Run a filesystem check on the cf slice
    fsck -y /cf
    # Try to mount it again
    mount /cf
    

    And if you find that your config suddenly went bonkers after doing that, run:

    cp /root/config.backup /cf/conf/config.xml
    rm /tmp/config.cache
    


  • When I run:
    $ fsck -y /cf

    I get this:

    Can't stat /dev/ufs/cf: No such file or directory
    Can't stat /dev/ufs/cf: No such file or directory

    And when I run:

    $ mount /cf

    I get this:

    mount: /dev/ufs/cf : No such file or directory

    Appreciate the assistance, anything else i can try?

    Thanks,


  • Rebel Alliance Developer Netgate

    Well I suppose the real question is: Is this really NanoBSD? Or a full install?

    If that is NanoBSD, I'd seriously question whether or not your CF was ever written properly, or if it's about to fail. Either way, fresh CF with an appropriately sized image (and make sure the imaging program reports no errors) and then boot that and restore your config to be extra safe.



  • I am running this on a msata drive with a intel DN2800MT mobo 1 on board intel gig nic and 1 pcie gig nic

    i have the nanobsd 4g file on my usb key which i then zcat over to my msata drive and then reboot

    The drive passes all tests and shows no other error and pfsense works great other then this issue which i can't explain.

    Any other suggestion or ideas are definitely welcome and thanks.


  • Rebel Alliance Developer Netgate

    Are you sure the 4GB mSATA is actually 4GB?

    If it's working otherwise, I'd try it again with a 2GB image.

    If the drive is too small and the image file is bigger than the drive, it would explain the missing cf slice.

    As it is, if you upgrade the firmware you'd lose your config in the process because it's not being stored in the correct place on the disk.



  • The msata is a 30 gig drive and is pretty much brand new.

    I have secure erased it in pmagic prior to zcat the image over.

    I just tried again with most recent image and still get the same error as it boots up for the first time.

    Anything else I could try ?  Much appreciated and thanks.



  • Please post the output of pfSense shell commands:```
    more /etc/fstab
    sysctl kern.disks
    ls /dev/ad*
    mount



  • as per your request:

    $ more /etc/fstab
    /dev/ufs/pfsense0 / ufs ro,sync,noatime 1 1
    /dev/ufs/cf /cf ufs ro,sync,noatime 1 1
    
    $ sysctl kern.disks
    kern.disks: ad6
    
    $ ls /dev/ad*
    /dev/ad6
    /dev/ad6a
    
    $ mount
    /dev/ufs/pfsense0 on / (ufs, local, noatime, synchronous)
    devfs on /dev (devfs, local)
    /dev/md0 on /tmp (ufs, local)
    /dev/md1 on /var (ufs, local)
    devfs on /var/dhcpd/dev (devfs, local)
    
    

  • Rebel Alliance Developer Netgate

    What about:

    ls -l /dev/ufs
    

    On a properly formatted NanoBSD image, it should look like:

    : ls -l /dev/ufs
    total 0
    crw-r-----  1 root  operator    0,  63 Jan  4 21:02 cf
    crw-r-----  1 root  operator    0,  65 Jan  4 21:02 pfsense0
    crw-r-----  1 root  operator    0,  67 Jan  4 21:02 pfsense1
    

    Judging by the fact that you only have /dev/ad6a I'm guessing something is seriously not right with how that was written to the disk. Normally that looks like:

    
    : ls -l /dev/ad*
    crw-r-----  1 root  operator    0,  56 Jan  4 21:02 /dev/ad0
    crw-r-----  1 root  operator    0,  57 Jan  4 21:02 /dev/ad0s1
    crw-r-----  1 root  operator    0,  60 Jan  4 21:02 /dev/ad0s1a
    crw-r-----  1 root  operator    0,  58 Jan  4 21:02 /dev/ad0s2
    crw-r-----  1 root  operator    0,  61 Jan  4 21:02 /dev/ad0s2a
    crw-r-----  1 root  operator    0,  59 Jan  4 21:02 /dev/ad0s3
    


  • I agree with you 100 %

    When i write to the msata – i first zero out the whole drive with parted magic, i then write directly to the card.

    "zcat (current name of the current imag) | dd of=/dev/sda bs=16k"

    It then indicates it has written 4g nanobsd vga image to msata with no errors.  Then i reboot and while its loading for the first time is when i see that error.

    Here is the code you asked me to run and you are correct about things not showing as correct.

    $ ls -l /dev/ufs
    total 0
    crw-r-----  1 root  operator    0,  78 Jan  8 22:41 pfsense0
    

    Any suggestions on how this is going wrong?  I've tried to remove any variables but still end up here.

    Many thanks again for any assistance.


  • Rebel Alliance Developer Netgate

    What is the exact filename of the 4GB image you used to write that out?



  • latest-nanobsd-vga-4g.img.gz 09-Jan-2013 17:59 86M


  • Rebel Alliance Developer Netgate

    That is an update slice, not a full nanobsd image.



  • WOW i feel like a complete idiot.. the worst part is i know that i was troubleshooting to far and it was going to be something easy and way obvious…for this i say thank you.  I now have it fully installed with
    pfSense-2.1-BETA1-4g-amd64-nanobsd_vga-20130109-1617.img.gz 09-Jan-2013 17:59 172M
    (2.1-BETA1 (amd64)
    built on Wed Jan 9 16:17:18 EST 2013
    FreeBSD gho57.localdomain 8.3-RELEASE-p5 FreeBSD 8.3-RELEASE-p5 #0: Wed Jan 9 17:47:08 EST 2013 root@snapshots-8_3-amd64.builders.pfsense.org:/usr/obj./usr/pfSensesrc/src/sys/pfSense_wrap_vga.8.amd64 amd64)
    nanobsd (4g)
    and running on both slices.

    But i'm still having issues upgrading either auto update/console update or manual update and on both slices.

    It down loads the package it attempts to install but thats as far as it goes.

    I log back in and met with a warning message:

    php: : New alert found: Something went wrong when trying to update the fstab entry. Aborting upgrade.
    
    php: : The command '/usr/local/sbin/gzsig verify /etc/pubkey.pem < '/root/firmware.tgz'' returned exit code '2', the output was 'No gzip signature found Couldn't verify input'
    

    I have checked and i do have allow invalid or missing signatures to be used.

    Any more help or suggestion would be much appreciated.

    Thanks again.


Locked