Multi wan - gateway offline



  • hello
    i have configured multi wan and i think it's working fine and when a wan link is down it's show offline status
    but when it comes back , it's always offline and never come online until a reload to pfsense

    so how i could solve this ?



  • On the 2 gateways, do you have it set to a monitor IP?

    • A screenshot of your gateways and group would be a nice start.


  • Yes i have configured the monitor ip










  • If I understand the OP correctly, I think I am having a similar issue.

    I have two WANs set up–WAN and WAN2.  WAN is a residential connection that receives a dynamic public IP.  WAN2 is a business connection that has a static public IP.  WAN usually goes down for 30 minutes on Sunday night a 1AM and WAN2 is more stable.  I have a Gateway Group set up with WAN set to tier 2 and WAN2 is at tier 1.

    When WAN goes down it fails to WAN2 and that works great.  However, pfSense never fails back to WAN when it comes back up.  In fact, the line will remain down until I go to the Interfact and click the RENEW button to renew the DHCP lease.  It hasn't once in the past 4x-5x renewed the lease on it's own or indicated that the line is back up.

    Not sure if there is another setting I need to tweak to have pfSense periodically tickle the interface to see if it's alive again and/or renew the DHCP lease.



  • Ok , The only thing I see that is missing is your DNS failover. You should have a rule on the floating tab, with both WAN interfaces set to DNS port I will include a screenshot of my rule.. You will also need to then go to your general settings and set the DNS to none. I will show you in the shots.

    also could you include one of the Gateway Group? Are both gateways set to Tier 1 ?

    I know in the lab I have failed over static gateways with no issues. It's static , Once it comes back online the interface should come up and new traffic should start getting routed via that gateway also.

    When you say , Physically disconnect WAN2 , let it failover to WAN1. Wait 5 minutes , Don't clear any states just let the TTL's expire in ARP table..ect..

    Now , Re-Connect WAN2 , Check PFsense to see if the gateway goes ONLINE. If the gateway goes online..

    Go to a host, Go to say.. www.dnsleak.com and Refresh until you get both your IP's to show. ( If you refresh 40 times and nothing happens…then..)

    Now the issue that Tim talks about I am not sure and unable to confirm right now , I have a lab I can try today with 2 cable modems running on different gateways with a DHCP lease. I will let you know my findings.





  • i have made the dns rule but no difference at all and for the DNS gateway , i don't have the gateway tab in my pfsense beside DNS servers

    but i have noticed that from seeing the next hope after the pfsense which is a cisco router

    after i bring back the second line online no packets hits this line at all

    and all the traffic goes to the first line , and all the icmp used in monitoring is generated from one interface
    is that normal . after one line goes down all the icmp traffic used in monitoring goes to one line
    so how it could check if the second line is come back online ??

    notes: the dsl lines are not directly attached to pfsense , and their is a cisco router after the pfsense and after it the 2 dsl lines

    so why the pfsense is insisting that the wan is offline and it didn't came back online



  • i figure out that it comes back online but after a few hours



  • Does it come back online if you renew the interface ? or disable and then re-enable it?



  • it comes back if i enter to the wan interface (the down one) and i just click save and apply changes without made any configuration.



  • Post a screenshot of your gateways and gateway groups.. are both tier 1?



  • YES , tier 1





  • Rebel Alliance

    Your WAN is on 10.24.250.x Net & your WAN2 is on 10.24.250.x Net also, are you sure that both Netwworks doesn't overlap ? Which network mask do you have on each WAN ?

    Maybe you need to elaborate a bit more about your setup…



  • @ptt:

    Your WAN is on 10.24.250.x Net & your WAN2 is on 10.24.250.x Net also, are you sure that both Netwworks doesn't overlap ? Which network mask do you have on each WAN ?

    Internal NIC on 10.24.250.x as well. Unless those are small subnet masks, all 3 NICs may have overlapping subnets.



  • it's all /29 subnet mask



  • i have another problem now that i found that squid proxy is not working with multi wan when i enable it and i enable proxy on lan and loopback interfaces :(



  • I have the same problem with multi-WAN switching. Please help.



  • Same problem here.
    My ISP disconnects every 24 hours automatically. So WAN1 goes offline, comes back after a few seconds, but PfSense is still saying 'Offline'. I've set the monitor IP to an IP which is definitely pingable.

    But I have to say I'm using PfSense 2.1-BETA1 (March 28).

    Any ideas to solve this??



  • Have same problem here.
    When I dissable Gateway Monitoring it works.

    I have tried a high down ping time, ms and packetloss but with same problem.

    I am running 2.0.3


Log in to reply