2.0.1 -> 2.1 The image file is corrupt