Dyndns update problem on 1.0-BETA1-TESTING-SNAPSHOT-2-5-06



  • I have follow problem on first boot the dyndns work when i disconnect my ppoe connection and new connect
    the dyndns client update not my dyndns adress  ip.

    Is it possible to start update dyndns manual over shell ?



  • what does the dyndns updater report in the systemlogs when you do this? What version are you on?



  • My hardware WARP

    First boot i can see dyndns in log normal but when i disconnect an reconnet then i see nothing in log from Dyndns. (Dyndns.org)



  • Just speculating what it says does nothing for us.  Show us the log snippets.



  • OK Here the systemlog

    Here the log after reboot.

    Feb 8 18:26:22 last message repeated 2 times
    Feb 8 18:26:22 php: : Not installing nat reflection rules for a port range > 500
    Feb 8 18:26:12 login: login on console as root
    Feb 8 18:26:10 php: : Resyncing configuration for all packages.
    Feb 8 18:26:08 pftpx[912]: listening on 127.0.0.1 port 8021
    Feb 8 18:26:08 pftpx[912]: listening on 127.0.0.1 port 8021
    Feb 8 18:26:06 mpd: [pt15] using interface ng16
    Feb 8 18:26:06 mpd: [pt15] ppp node is "mpd855-pt15"
    Feb 8 18:26:06 mpd: [pt14] using interface ng15
    Feb 8 18:26:06 mpd: [pt14] ppp node is "mpd855-pt14"
    Feb 8 18:26:06 mpd: [pt13] using interface ng14
    Feb 8 18:26:06 mpd: [pt13] ppp node is "mpd855-pt13"
    Feb 8 18:26:06 mpd: [pt12] using interface ng13
    Feb 8 18:26:06 mpd: [pt12] ppp node is "mpd855-pt12"
    Feb 8 18:26:06 mpd: [pt11] using interface ng12
    Feb 8 18:26:05 mpd: [pt11] ppp node is "mpd855-pt11"
    Feb 8 18:26:05 mpd: [pt10] using interface ng11
    Feb 8 18:26:05 mpd: [pt10] ppp node is "mpd855-pt10"
    Feb 8 18:26:05 mpd: [pt9] using interface ng10
    Feb 8 18:26:05 mpd: [pt9] ppp node is "mpd855-pt9"
    Feb 8 18:26:05 mpd: [pt8] using interface ng9
    Feb 8 18:26:05 mpd: [pt8] ppp node is "mpd855-pt8"
    Feb 8 18:26:05 mpd: [pt7] using interface ng8
    Feb 8 18:26:05 mpd: [pt7] ppp node is "mpd855-pt7"
    Feb 8 18:26:05 mpd: [pt6] using interface ng7
    Feb 8 18:26:05 mpd: [pt6] ppp node is "mpd855-pt6"
    Feb 8 18:26:05 mpd: [pt5] using interface ng6
    Feb 8 18:26:05 mpd: [pt5] ppp node is "mpd855-pt5"
    Feb 8 18:26:05 mpd: [pt4] using interface ng5
    Feb 8 18:26:05 mpd: [pt4] ppp node is "mpd855-pt4"
    Feb 8 18:26:05 mpd: [pt3] using interface ng4
    Feb 8 18:26:05 mpd: [pt3] ppp node is "mpd855-pt3"
    Feb 8 18:26:05 mpd: [pt2] using interface ng3
    Feb 8 18:26:05 mpd: [pt2] ppp node is "mpd855-pt2"
    Feb 8 18:26:05 mpd: [pt1] using interface ng2
    Feb 8 18:26:05 mpd: [pt1] ppp node is "mpd855-pt1"
    Feb 8 18:26:03 mpd: [pt0] using interface ng1
    Feb 8 18:26:03 mpd: mpd: local IP address for PPTP is 0.0.0.0
    Feb 8 18:26:03 mpd: [pt0] ppp node is "mpd855-pt0"
    Feb 8 18:26:03 mpd: mpd: pid 855, version 3.18 (root@builder.livebsd.com 21:39 5-Feb-2006)
    Feb 8 18:26:02 dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
    Feb 8 18:26:02 dhcpd: All rights reserved.
    Feb 8 18:26:02 dhcpd: Copyright 2004-2005 Internet Systems Consortium.
    Feb 8 18:26:02 dhcpd: Internet Systems Consortium DHCP Server V3.0.3
    Feb 8 18:26:01 php: : phpDynDNS: (Success) IP Address Changed Successfully! (87.78.45.153)
    Feb 8 18:25:59 php: : phpDynDNS: updating cache file /cf/conf/dyndns.cache: 87.78.45.153
    Feb 8 18:25:59 php: : DynDns: Current Service: dyndns
    Feb 8 18:25:59 php: : DynDns: DynDns _checkStatus() starting.
    Feb 8 18:25:58 php: : DynDns: DynDns _update() starting.
    Feb 8 18:25:58 php: : DynDns: cacheIP != wan_ip. Updating.
    Feb 8 18:25:58 php: : DynDns: Cached IP: 87.78.47.237
    Feb 8 18:25:57 php: : DynDns: Current WAN IP: 87.78.45.153
    Feb 8 18:25:57 php: : DynDns: _detectChange() starting.
    Feb 8 18:25:57 php: : DynDns: updatedns() starting
    Feb 8 18:25:57 php: : DynDns: Running updatedns()
    Feb 8 18:25:43 last message repeated 2 times
    Feb 8 18:25:57 dnsmasq[820]: using nameserver 213.168.112.60#53
    Feb 8 18:25:57 dnsmasq[820]: reading /etc/resolv.conf
    Feb 8 18:25:57 dnsmasq[820]: read /etc/hosts - 4 addresses
    Feb 8 18:25:57 dnsmasq[820]: started, version 2.22 cachesize 150
    Feb 8 18:25:43 php: : Not installing nat reflection rules for a port range > 500
    Feb 8 18:25:42 kernel: pflog0: promiscuous mode enabled
    Feb 8 18:25:41 kernel: sis0: promiscuous mode enabled
    Feb 8 18:25:41 kernel: ath0: promiscuous mode enabled
    Feb 8 18:25:40 kernel: bridge0: Ethernet address: ac🇩🇪48:2c:e9:13
    Feb 8 18:25:19 php: : Hotplug event detected for sis2 but ignoring since interface is not set for DHCP
    Feb 8 18:25:14 php: : DEVD Ethernet attached event for sis1
    Feb 8 18:25:11 mpd: [pppoe] IFACE: Up event
    Feb 8 18:25:10 mpd: [pppoe] exec: /usr/local/sbin/ppp-linkup ng0 inet 87.78.45.153 195.14.247.95 nc-xxxxx@netcologne.de dns1 213.168.112.60
    Feb 8 18:25:10 mpd: [pppoe] exec: /sbin/route add 0.0.0.0 195.14.247.95
    Feb 8 18:25:10 mpd: [pppoe] exec: /sbin/route add 87.78.45.153 -iface lo0
    Feb 8 18:25:10 mpd: [pppoe] exec: /sbin/ifconfig ng0 87.78.45.153 195.14.247.95 netmask 0xffffffff -link0
    Feb 8 18:25:10 mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
    Feb 8 18:25:10 mpd: [pppoe] IFACE: Up event
    Feb 8 18:25:10 mpd: 87.78.45.153 -> 195.14.247.95
    Feb 8 18:25:10 mpd: [pppoe] IPCP: LayerUp
    Feb 8 18:25:10 mpd: [pppoe] IPCP: state change Ack-Sent –> Opened
    Feb 8 18:25:10 mpd: PRIDNS 213.168.112.60
    Feb 8 18:25:10 mpd: IPADDR 87.78.45.153
    Feb 8 18:25:10 mpd: [pppoe] IPCP: rec'd Configure Ack #3 link 0 (Ack-Sent)
    Feb 8 18:25:10 mpd: [pppoe] IPCP: state change Req-Sent –> Ack-Sent
    Feb 8 18:25:10 mpd: IPADDR 195.14.247.95
    Feb 8 18:25:10 mpd: [pppoe] IPCP: SendConfigAck #204
    Feb 8 18:25:10 mpd: 195.14.247.95 is OK
    Feb 8 18:25:10 mpd: IPADDR 195.14.247.95
    Feb 8 18:25:10 mpd: [pppoe] IPCP: rec'd Configure Request #204 link 0 (Req-Sent)
    Feb 8 18:25:10 mpd: PRIDNS 213.168.112.60
    Feb 8 18:25:10 mpd: IPADDR 87.78.45.153
    Feb 8 18:25:10 mpd: [pppoe] IPCP: SendConfigReq #3
    Feb 8 18:25:10 mpd: PRIDNS 213.168.112.60
    Feb 8 18:25:10 mpd: 87.78.45.153 is OK
    Feb 8 18:25:10 mpd: IPADDR 87.78.45.153
    Feb 8 18:25:10 mpd: [pppoe] IPCP: rec'd Configure Nak #2 link 0 (Req-Sent)
    Feb 8 18:25:10 mpd: PRIDNS 0.0.0.0
    Feb 8 18:25:10 mpd: IPADDR 0.0.0.0
    Feb 8 18:25:10 mpd: [pppoe] IPCP: SendConfigReq #2
    Feb 8 18:25:10 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Feb 8 18:25:10 mpd: [pppoe] IPCP: rec'd Configure Reject #1 link 0 (Req-Sent)
    Feb 8 18:25:10 mpd: PRIDNS 0.0.0.0
    Feb 8 18:25:10 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Feb 8 18:25:10 mpd: IPADDR 0.0.0.0
    Feb 8 18:25:10 mpd: [pppoe] IPCP: SendConfigReq #1
    Feb 8 18:25:10 mpd: [pppoe] IPCP: state change Starting –> Req-Sent
    Feb 8 18:25:10 mpd: [pppoe] IPCP: Up event
    Feb 8 18:25:10 mpd: [pppoe] up: 1 link, total bandwidth 64000 bps
    Feb 8 18:25:10 mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
    Feb 8 18:25:10 mpd: [pppoe] LCP: phase shift AUTHENTICATE –> NETWORK
    Feb 8 18:25:10 mpd: [pppoe] LCP: authorization successful
    Feb 8 18:25:10 mpd: [pppoe] PAP: rec'd ACK #1
    Feb 8 18:25:10 mpd: [pppoe] LCP: LayerUp
    Feb 8 18:25:10 mpd: [pppoe] PAP: sending REQUEST
    Feb 8 18:25:10 mpd: [pppoe] PAP: using authname "nc-xxxxx@netcologne.de"
    Feb 8 18:25:10 mpd: [pppoe] LCP: auth: peer wants PAP, I want nothing
    Feb 8 18:25:10 mpd: [pppoe] LCP: phase shift ESTABLISH –> AUTHENTICATE
    Feb 8 18:25:10 mpd: [pppoe] LCP: state change Ack-Sent –> Opened
    Feb 8 18:25:10 mpd: MAGICNUM be6a0b40
    Feb 8 18:25:10 mpd: MRU 1492
    Feb 8 18:25:10 mpd: [pppoe] LCP: rec'd Configure Ack #1 link 0 (Ack-Sent)
    Feb 8 18:25:10 mpd: [pppoe] LCP: state change Req-Sent –> Ack-Sent
    Feb 8 18:25:10 mpd: MAGICNUM 2e2e9ee1
    Feb 8 18:25:10 mpd: AUTHPROTO PAP
    Feb 8 18:25:10 mpd: MRU 1492
    Feb 8 18:25:10 mpd: [pppoe] LCP: SendConfigAck #170
    Feb 8 18:25:10 mpd: MAGICNUM 2e2e9ee1
    Feb 8 18:25:10 mpd: AUTHPROTO PAP
    Feb 8 18:25:10 mpd: MRU 1492
    Feb 8 18:25:10 mpd: [pppoe] LCP: rec'd Configure Request #170 link 0 (Req-Sent)
    Feb 8 18:25:10 php: : Hotplug event detected for sis0 but ignoring since interface is not set for DHCP
    Feb 8 18:25:09 mpd: MAGICNUM be6a0b40
    Feb 8 18:25:09 mpd: MRU 1492
    Feb 8 18:25:09 mpd: [pppoe] LCP: SendConfigReq #1
    Feb 8 18:25:09 mpd: [pppoe] LCP: phase shift DEAD –> ESTABLISH
    Feb 8 18:25:09 mpd: [pppoe] LCP: state change Starting –> Req-Sent
    Feb 8 18:25:09 mpd: [pppoe] LCP: Up event
    Feb 8 18:25:09 mpd: [pppoe] link: origination is local
    Feb 8 18:25:09 mpd: [pppoe] link: UP event
    Feb 8 18:25:09 mpd: [pppoe] device is now in state UP
    Feb 8 18:25:09 mpd: [pppoe] device: UP event in state OPENING
    Feb 8 18:25:09 mpd: [pppoe] PPPoE connection successful
    Feb 8 18:25:09 mpd: [pppoe] rec'd ACNAME "netdsl"
    Feb 8 18:25:09 mpd: [pppoe] device is now in state OPENING
    Feb 8 18:25:09 mpd: [pppoe] device: OPEN event in state DOWN
    Feb 8 18:25:09 mpd: [pppoe] LCP: LayerStart
    Feb 8 18:25:09 mpd: [pppoe] LCP: state change Initial –> Starting
    Feb 8 18:25:09 mpd: [pppoe] LCP: Open event
    Feb 8 18:25:09 mpd: [pppoe] link: OPEN event
    Feb 8 18:25:09 mpd: [pppoe] opening link "pppoe"…
    Feb 8 18:25:09 mpd: [pppoe] bundle: OPEN event in state CLOSED
    Feb 8 18:25:09 mpd: [pppoe] IPCP: LayerStart
    Feb 8 18:25:09 mpd: [pppoe] IPCP: state change Initial –> Starting
    Feb 8 18:25:08 mpd: [pppoe] IPCP: Open event
    Feb 8 18:25:08 mpd: [pppoe] IFACE: Open event
    Feb 8 18:25:08 mpd: [pppoe] IPCP: peer address cannot be zero
    Feb 8 18:25:08 mpd: [pppoe] using interface ng0
    fsense mpd: [pppoe] /sbin/ifconfig sis1 up

    log after disconnect and new reconnect

    Feb 8 18:31:56 sshd[1517]: Accepted keyboard-interactive/pam for admin from 192.168.0.200 port 2060 ssh2
    Feb 8 18:29:53 mpd: [pppoe] IFACE: Up event
    Feb 8 18:29:53 mpd: [pppoe] exec: /usr/local/sbin/ppp-linkup ng0 inet 87.78.46.236 195.14.247.95 nc-xxxxxx@netcologne.de dns1 213.168.112.60
    Feb 8 18:29:52 mpd: [pppoe] exec: /sbin/route add 0.0.0.0 195.14.247.95
    Feb 8 18:29:52 mpd: [pppoe] exec: /sbin/route add 87.78.46.236 -iface lo0
    Feb 8 18:29:52 mpd: [pppoe] exec: /sbin/ifconfig ng0 87.78.46.236 195.14.247.95 netmask 0xffffffff -link0
    Feb 8 18:29:52 mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
    Feb 8 18:29:52 mpd: [pppoe] IFACE: Up event
    Feb 8 18:29:52 mpd: 87.78.46.236 -> 195.14.247.95
    Feb 8 18:29:52 mpd: [pppoe] IPCP: LayerUp
    Feb 8 18:29:52 mpd: [pppoe] IPCP: state change Ack-Rcvd –> Opened
    Feb 8 18:29:52 mpd: IPADDR 195.14.247.95
    Feb 8 18:29:52 mpd: [pppoe] IPCP: SendConfigAck #241
    Feb 8 18:29:52 mpd: 195.14.247.95 is OK
    Feb 8 18:29:52 mpd: IPADDR 195.14.247.95
    Feb 8 18:29:52 mpd: [pppoe] IPCP: rec'd Configure Request #241 link 0 (Ack-Rcvd)
    Feb 8 18:29:52 mpd: [pppoe] IPCP: state change Req-Sent –> Ack-Rcvd
    Feb 8 18:29:52 mpd: PRIDNS 213.168.112.60
    Feb 8 18:29:52 mpd: IPADDR 87.78.46.236
    Feb 8 18:29:52 mpd: [pppoe] IPCP: rec'd Configure Ack #7 link 0 (Req-Sent)
    Feb 8 18:29:52 mpd: PRIDNS 213.168.112.60
    Feb 8 18:29:52 mpd: IPADDR 87.78.46.236
    Feb 8 18:29:52 mpd: [pppoe] IPCP: SendConfigReq #7
    Feb 8 18:29:52 mpd: PRIDNS 213.168.112.60
    Feb 8 18:29:52 mpd: 87.78.46.236 is OK
    Feb 8 18:29:52 mpd: IPADDR 87.78.46.236
    Feb 8 18:29:52 mpd: [pppoe] IPCP: rec'd Configure Nak #6 link 0 (Req-Sent)
    Feb 8 18:29:52 mpd: PRIDNS 0.0.0.0
    Feb 8 18:29:52 mpd: IPADDR 0.0.0.0
    Feb 8 18:29:52 mpd: [pppoe] IPCP: SendConfigReq #6
    Feb 8 18:29:52 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Feb 8 18:29:52 mpd: [pppoe] IPCP: rec'd Configure Reject #5 link 0 (Req-Sent)
    Feb 8 18:29:52 mpd: PRIDNS 0.0.0.0
    Feb 8 18:29:52 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Feb 8 18:29:52 mpd: IPADDR 0.0.0.0
    Feb 8 18:29:52 mpd: [pppoe] IPCP: SendConfigReq #5
    Feb 8 18:29:52 mpd: [pppoe] IPCP: state change Starting –> Req-Sent
    Feb 8 18:29:52 mpd: [pppoe] IPCP: Up event
    Feb 8 18:29:52 mpd: [pppoe] up: 1 link, total bandwidth 64000 bps
    Feb 8 18:29:52 mpd: [pppoe] setting interface ng0 MTU to 1492 bytes
    Feb 8 18:29:52 mpd: [pppoe] LCP: phase shift AUTHENTICATE –> NETWORK
    Feb 8 18:29:52 mpd: [pppoe] LCP: authorization successful
    Feb 8 18:29:52 mpd: [pppoe] PAP: rec'd ACK #1
    Feb 8 18:29:51 mpd: [pppoe] LCP: LayerUp
    Feb 8 18:29:51 mpd: [pppoe] PAP: sending REQUEST
    Feb 8 18:29:51 mpd: [pppoe] PAP: using authname "nc-xxxxxx@netcologne.de"
    Feb 8 18:29:51 mpd: [pppoe] LCP: auth: peer wants PAP, I want nothing
    Feb 8 18:29:51 mpd: [pppoe] LCP: phase shift ESTABLISH –> AUTHENTICATE
    Feb 8 18:29:51 mpd: [pppoe] LCP: state change Ack-Sent –> Opened
    Feb 8 18:29:51 mpd: MAGICNUM bf66b577
    Feb 8 18:29:51 mpd: MRU 1492
    Feb 8 18:29:51 mpd: [pppoe] LCP: rec'd Configure Ack #3 link 0 (Ack-Sent)
    Feb 8 18:29:51 mpd: [pppoe] LCP: state change Req-Sent –> Ack-Sent
    Feb 8 18:29:51 mpd: MAGICNUM 13dbcedd
    Feb 8 18:29:51 mpd: AUTHPROTO PAP
    Feb 8 18:29:51 mpd: MRU 1492
    Feb 8 18:29:51 mpd: [pppoe] LCP: SendConfigAck #86
    Feb 8 18:29:51 mpd: MAGICNUM 13dbcedd
    Feb 8 18:29:51 mpd: AUTHPROTO PAP
    Feb 8 18:29:51 mpd: MRU 1492
    Feb 8 18:29:51 mpd: [pppoe] LCP: rec'd Configure Request #86 link 0 (Req-Sent)
    Feb 8 18:29:51 mpd: MAGICNUM bf66b577
    Feb 8 18:29:51 mpd: MRU 1492
    Feb 8 18:29:51 mpd: [pppoe] LCP: SendConfigReq #3
    Feb 8 18:29:51 mpd: [pppoe] LCP: phase shift DEAD –> ESTABLISH
    Feb 8 18:29:51 mpd: [pppoe] LCP: state change Starting –> Req-Sent
    Feb 8 18:29:51 mpd: [pppoe] LCP: Up event
    Feb 8 18:29:51 mpd: [pppoe] link: origination is local
    Feb 8 18:29:51 mpd: [pppoe] link: UP event
    Feb 8 18:29:51 mpd: [pppoe] device is now in state UP
    Feb 8 18:29:51 mpd: [pppoe] device: UP event in state OPENING
    Feb 8 18:29:51 mpd: [pppoe] PPPoE connection successful
    Feb 8 18:29:51 mpd: [pppoe] rec'd ACNAME "netdsl"
    Feb 8 18:29:51 mpd: [pppoe] device is now in state OPENING
    Feb 8 18:29:51 mpd: [pppoe] device: OPEN event in state DOWN
    Feb 8 18:29:51 mpd: [pppoe] LCP: Open event
    Feb 8 18:29:51 mpd: [pppoe] link: OPEN event
    Feb 8 18:29:51 mpd: [pppoe] LCP: LayerStart
    Feb 8 18:29:51 mpd: [pppoe] LCP: state change Initial –> Starting
    Feb 8 18:29:51 mpd: [pppoe] LCP: Open event
    Feb 8 18:29:51 mpd: [pppoe] link: OPEN event
    Feb 8 18:29:51 mpd: [pppoe] opening link "pppoe"…
    Feb 8 18:29:51 mpd: [pppoe] bundle: OPEN event in state OPENED
    Feb 8 18:29:51 mpd: [pppoe] opening link "pppoe"…
    Feb 8 18:29:51 mpd: [pppoe] bundle: OPEN event in state CLOSED
    Feb 8 18:29:51 mpd: [pppoe] IPCP: LayerStart
    Feb 8 18:29:51 mpd: [pppoe] IPCP: state change Initial –> Starting
    Feb 8 18:29:51 mpd: [pppoe] IPCP: Open event
    Feb 8 18:29:51 mpd: [pppoe] rec'd signal usr1, opening
    Feb 8 18:29:25 mpd: [pppoe] LCP: phase shift ESTABLISH –> DEAD
    Feb 8 18:29:25 mpd: [pppoe] LCP: state change Closed –> Initial
    Feb 8 18:29:25 mpd: [pppoe] LCP: Down event
    Feb 8 18:29:25 mpd: [pppoe] link: DOWN event
    Feb 8 18:29:25 mpd: [pppoe] device is now in state DOWN
    Feb 8 18:29:25 mpd: [pppoe] device: DOWN event in state CLOSING
    Feb 8 18:29:25 mpd: [pppoe] device is now in state CLOSING
    Feb 8 18:29:25 mpd: [pppoe] device: CLOSE event in state UP
    Feb 8 18:29:25 mpd: [pppoe] LCP: LayerFinish
    Feb 8 18:29:25 mpd: [pppoe] LCP: phase shift TERMINATE –> ESTABLISH
    Feb 8 18:29:25 mpd: [pppoe] LCP: state change Closing –> Closed
    Feb 8 18:29:25 mpd: [pppoe] LCP: rec'd Terminate Ack #2 link 0 (Closing)
    Feb 8 18:29:25 mpd: [pppoe] LCP: Close event
    Feb 8 18:29:25 mpd: [pppoe] link: CLOSE event
    Feb 8 18:29:25 mpd: [pppoe] LCP: LayerDown
    Feb 8 18:29:25 mpd: [pppoe] LCP: SendTerminateReq #2
    Feb 8 18:29:25 mpd: [pppoe] closing link "pppoe"…
    Feb 8 18:29:25 mpd: [pppoe] IPCP: state change Closed –> Initial
    Feb 8 18:29:25 mpd: [pppoe] IPCP: Down event
    Feb 8 18:29:25 mpd: [pppoe] up: 0 links, total bandwidth 9600 bps
    Feb 8 18:29:25 mpd: [pppoe] setting interface ng0 MTU to 1500 bytes
    Feb 8 18:29:25 mpd: [pppoe] LCP: phase shift NETWORK –> TERMINATE
    Feb 8 18:29:25 mpd: [pppoe] LCP: state change Opened –> Closing
    Feb 8 18:29:25 mpd: [pppoe] LCP: Close event
    Feb 8 18:29:25 mpd: [pppoe] link: CLOSE event
    Feb 8 18:29:25 mpd: [pppoe] closing link "pppoe"…
    Feb 8 18:29:25 mpd: [pppoe] bundle: CLOSE event in state OPENED
    Feb 8 18:29:25 mpd: [pppoe] IPCP: LayerFinish
    Feb 8 18:29:25 mpd: [pppoe] IPCP: state change Closing –> Closed
    Feb 8 18:29:25 mpd: [pppoe] IPCP: rec'd Terminate Ack #4 link 0 (Closing)
    Feb 8 18:29:25 mpd: [pppoe] exec: /sbin/ifconfig ng0 down delete -link0
    Feb 8 18:29:25 mpd: [pppoe] exec: /sbin/route delete 87.78.45.153 -iface lo0
    Feb 8 18:29:24 mpd: [pppoe] exec: /sbin/route delete 0.0.0.0 195.14.247.95
    Feb 8 18:29:24 mpd: [pppoe] IFACE: Down event
    Feb 8 18:29:24 mpd: [pppoe] IPCP: LayerDown
    Feb 8 18:29:24 mpd: [pppoe] IPCP: SendTerminateReq #4
    Feb 8 18:29:24 mpd: [pppoe] IPCP: state change Opened –> Closing
    Feb 8 18:29:24 mpd: [pppoe] IPCP: Close event
    Feb 8 18:29:24 mpd: [pppoe] rec'd signal usr2, closing



  • When you disconnect and reconnect, how are you doing this?  Letting the connection idle out?  Using the connect / disconnect button in the interfaces status screen?



  • In the log i have the line with the button diconnectet and reconnect.



  • So this is being done from the interfaces status screen?



  • yes

    my line is 24h connect no idle out

    sorry my english is not good



  • This is strange because ppp-linkup basically sets a file that check_reload_status gets invoked to cover.

    Can you send me the entire log file to sullrich@gmail.com

    Also, did you reflash this version as opposed to updating?



  • This problem also exists if you let it idle out.

    After 24h the connection is terminated and then reconnected by pfSense.
    DynDNS does not update correctly after reconnecting… :-(



  • Now I use the dyndns update service client on my server and it works without problems…

    Strange behaviour of the ddns client in pfSense.

    Scott sais, they do a periodic update once a day... but perhaps it is not enough ?



  • Good news: Scott found the error and will fix it in the next snapshot AFTER 2-8-06


Locked