Nic card failure

  • Hi. My first post on this forum - so it might not be the right place.
    I have had linux pfSense installed for a couple of years as a user. During this time it has needed very little attention and has performed admirably. I now find myself in the position of the internet connection failing and my support man has disappeared. Therefore I am trying to muddle through myself.
    I have established that the router (used as abridge only) is OK and that both the LAN and DMZ have acceptable interfaces. The WAN is showing as WAN (wan)  pppoe0  NONE (PPPoE).

    I have surmised (perhaps wrongly?) that the Nic for the WAN connection has failed and have replaced with a new card.

    On rebooting pfSense I am still not getting an IP address.

    The pfSense 2.0.1-RELEASE-pfSense (i386) is showing:-

    LAN (lan)        rl0      
    WAN (wan)      pppoe0        NONE (PPPoE)
    DMZ (opt1)    fxp0  

    I am now thinking that there is more required than simply replacing the Nic.

    Do I have to assign that pppoe0 interface by plugging in a cable?

    help please


  • Netgate Administrator

    Hi, welcome to the forum.  :)
    Just a quick point of information, pfSense is built on FreeBSD which is not Linux.  ;)

    Your router is in bridge mode and you are connecting to your ISP directly using PPPoE (or at least you should be). This is the recommended setup so that's good.
    Now your WAN interface is showing as NONE, it has no IP address that could be for a number of reasons including, as you say, the NIC has failed but that's unlikely.
    If you select option 8 at the command console you will get a command prompt. At that prompt enter ifconfig. You will see a list of all your network interfaces including whatever card the system is using for the link to the modem. You want to check that the system is showing the correct media and status information. For example:

    fxp1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=209b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic>ether 00:90:7f:31:4b:f2
            inet netmask 0xffffff00 broadcast
            inet6 fe80::290:7fff:fe31:4bf2%fxp1 prefixlen 64 scopeid 0x6
            nd6 options=43 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active</full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_magic></up,broadcast,running,simplex,multicast> 

    Copy and paste the entire output here if you can or just check those things.

    The other place to look is the ppp logs. In the web GUI go to Status: Logs: then the PPP tab. There should be some clues there as to why the PPPoE connection is failing. You can force the system to try to connect by going to Status: Interfaces: and clicking the 'connect' button next to the WAN section. Then go back to the PPP logs and look at the results.

    It's possible your ISP changed your login details if it's been setup for some time and just stopped working. Do you know the login details?


  • Netgate Administrator

    I just re-read you post and now realise that you have replaced the NIC already. I must read more carefully.  :-[
    IS the NIC identical to the previous one? Is it being detected at all. The ifconfig command should tell you that.
    If not you will have to reassign it.

    Also please let me know if I'm basing this info at the correct level or being incredibly patronising!


  • Steve Hi. Thanks for responding. I think that the first line of your first message indicates the level at which I am at. So not patronising at all - and if you were it would not matter a jot. Have supported user software on MS for many years but this is all new to me since retiring.

    pfSense has performed with so little problems and when they did my "man who knows what he is doing" talked me through fixing the problem (and I don't think that it was ever pfSense - always router or hardware as I recall).

    But back to problem. I am paranoid about upsetting things so have avoided doing anything that I am not sure of.

    Yes have replaced the Nic and no it was not the same type. I did venture into the assign interfaces (option 1) but chickened out after answering no to the vlan question as I did not want to screw up the two connections that seem OK.

    can I just  assign the one interface or do I have to re-do all three?

    The manual says that you plug in a cable as each interface is listed. Am I correct?


  • Netgate Administrator

    Ok, it appears from your quetions that you are using the console on the pfSense box to do this, yes? Are you just using the keyboard/monitor directly or connecting via SSH?

    Since your LAN interface is already setup you should be able to do everything you need to via the web gui.

    In the simplest case you probably need to go to Interfaces: (assign): PPPs: and then edit your PPPoE0 connection. In the drop down select the new NIC you installed, which will presumably be whatever is listed there that isn't fxp0 or rl0.

    That assumes everything else has gone perfectly, which it may not.  ;)

    Now usually when you remove a NIC pfSense will ask you to re-assign the interfaces at the next boot because things have changed. However I'm not sure if that would happen with the base NIC of a PPPoE connection because it's not actually assigned. It seems like this didn't happen because you say your selected option 1 from the menu to assign interfaces rather than being force to do so.

    The output of ifconfig from the command line would help a lot here. If you SSH to the box you can easily copy and paste the output.
    Alternatively you can run it from the webgui in Diagnostics: Command Prompt: in the Execute Shell Command box.


  • Hi Steve
    With the confidence you gave me in your posts yesterday things have moved on a bit (a lot maybe??)

    In between me raising the first question and receiving your replies I had begun to think that it was the router (bridge) that was flakey and maybe not the Nic. So, with new found confidence following your response, I replaced the Nic with the original. I then replaced the router (bridge) and rebooted everything hoping that all would magically fall back into place and we would be up and running.

    Not so.

    So, again with the confidence instilled by your good self, I have re-assigned the interfaces and set the interface IP addresses. For the WAN I put in - it was the only thing that seemed to work - and I now have:
    WAN (wan)        re0 (DHCP)
    LAN (lan)          rl0
    OPT1 (opt1)      fxp0

    And all seems to be working except that I cannot now get to the dashboard with my browser.

    I am not sure about the way I have set up the WAN. I set it with DHCP and the system tells me that I can access the webConfigurator with http://dhcp:/ but that doesn't seem to work.

    Where have I gone wrong?

    PS what part of the world are you in? Me UK

  • Netgate Administrator

    Ah OK.
    Hmm, if you set it to dhcp you should not have to enter an IP for WAN because it will receive one automatically via dhcp.


    I set it with DHCP and the system tells me that I can access the webConfigurator with http://dhcp:/ but that doesn't seem to work.

    This would normally show the name of your pfSense box, if you have set one. The fact that is says 'dhcp' perhaps implies you typed dhcp in the wrong field? Or that something has gone very wrong indeed.  ;)

    I can't really understand why you can't get to the webgui via the browser. Can you ping from a client machine on LAN?

    I'm in London.


  • hi Steve. thanks for your continued input.
    Since your last post I have been at it constantly - going round and round in circles I think. I managed to lose all contact with the outside world - hence the slow response.
    I think the answer to one question may well help:-

    On the console screen that gives all the options what should I be seeing against the WAN interface?

    Given that the router is acting as a modem and my internet connection is via a dynamically allocated IP from my ISP, is
    WAN (wan)        re0            NONE (DHCP)



  • Netgate Administrator

    No. If your modem is bridged such that the pfSense box is connecting to the ISP via PPPoE you should see:

     WAN (wan)                 -> pppoe0     -> (PPPoE)

    Obviously not that IP though.


  • so what do I have to enter in option 2 - Set Interface IP addresses to achieve this?

  • Netgate Administrator

    I said in another recent thread, it's such a long time since I set up my own home PPPoE connections that I'm struggling to remember the correct order to do this. Basically I suspect that the configuration you had when you first posted was mostly correct but now you have re-assigned the interfaces this are a little more complex.

    Here's what you do. Setting up the pppoe connection requires the webgui, it can't be done at the console. At least not without resorting to command line incantations!  ;)

    In the webgui go to Interfaces: (assign):. In the drop down next to WAN check to see if pppoe0 is already an option. It may be since you were previously using it in which case select that and apply the setting.

    If not then go to Interfaces: WAN: and change the type to PPPoE. Fill in the connection details from your ISP. Save and apply.


  • Hi Steve
    Many many thanks for your help in trying to resolve my problem. Nothing I tried (or dared to try) seemed to get me to the correct configuration and I retired hurt on Sunday evening.
    Thankfully my man returned on Monday and talked me through a complete re-configuration from modem tru to a defgalt re-start of pfsense (something I dared not to do) and all is now well.

    I certainly have learned an awful lot over the last few days and am resolved to learn more about pfsense.

    Once again thanks for your help.


  • Netgate Administrator


    I certainly have learned an awful lot over the last few days and am resolved to learn more about pfsense.

    Not all bad then.  ;) Thanks for signing off.


Log in to reply