Squid3 and PLEX



  • Hello.

    I have been trying to set up a reverse proxy to access PLEX (a media streaming app) via HTTPS on port 443.  PLEX does not support HTTPS out of the box so I have to do this to have encryption.

    Essentially I want to connect to my server using https:// and have it translate to port 32400 on my local network.  Here are my configs:

    http://imgur.com/8ZFNw9a,kzLfOW1,kfhH7OV

    (Note there are 3 images)

    The server is unreachable using https://starch.hopto.org with this setup.  I have verified that 443 is open for everything except pfsense and would normally be reachable if I had a NAT rule setup for it.

    Does anyone have any advice for a novice?



  • Try to fill https field options.



  • @marcelloc:

    Try to fill https field options.

    No luck with that.  Am I getting the FQDN and URI stuff correct?  The actual address that I am looking to start is something like:

    https://starch.hopto.org/web/

    If it makes any difference that is a dynamic dns I use to keep up with my home IP as it changes often.  Would there be any issue with that?